aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-silfreed-plugins
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2004-07-22 10:22:21 +0000
committerBruce M Simpson <bms@FreeBSD.org>2004-07-22 10:22:21 +0000
commit106486ea35c236a651a81a75483fc601744e8f11 (patch)
treebb0a43910adaf24d04820c22a7c08cd05fc507b6 /net-mgmt/nagios-silfreed-plugins
parent609a8522c291d20975ec67af2d41355c57e6c344 (diff)
downloadports-106486ea35c236a651a81a75483fc601744e8f11.tar.gz
ports-106486ea35c236a651a81a75483fc601744e8f11.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-silfreed-plugins')
-rw-r--r--net-mgmt/nagios-silfreed-plugins/Makefile18
-rw-r--r--net-mgmt/nagios-silfreed-plugins/pkg-plist2
2 files changed, 9 insertions, 11 deletions
diff --git a/net-mgmt/nagios-silfreed-plugins/Makefile b/net-mgmt/nagios-silfreed-plugins/Makefile
index 40d8d5738abb..5b1272e3ccca 100644
--- a/net-mgmt/nagios-silfreed-plugins/Makefile
+++ b/net-mgmt/nagios-silfreed-plugins/Makefile
@@ -24,13 +24,10 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= bms@FreeBSD.org
COMMENT= Additional SNMP plugins for Nagios from silfreed.net
-.include <bsd.port.pre.mk>
-
# Also uses traceroute, dig at runtime (in base system with hardcoded paths).
RUN_DEPENDS+= \
- ${LOCALBASE}/libexec/nagios:${PORTSDIR}/net-mgmt/nagios-plugins \
- ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}:net-mgmt/p5-Net-Netmask \
- ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}:net-mgmt/p5-Net-SNMP
+ ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
+ ${SITE_PERL}/Net/SNMP.pm:${PORTSDIR}/net-mgmt/p5-Net-SNMP
.if defined(WITH_EXPECT_TOOLS)
RUN_DEPENDS+= \
${LOCALBASE}/bin/expect:${PORTSDIR}/lang/expect
@@ -39,9 +36,7 @@ RUN_DEPENDS+= \
USE_PERL5= yes
NO_WRKSUBDIR= yes
-# XXX: Strictly speaking this shouldn't obey ${PREFIX}, as it has to be
-# installed to the same location as the Nagios plugins themselves.
-NAGIOS_PLUGIN_DIR= ${LOCALBASE}/libexec/nagios
+NAGIOS_PLUGIN_DIR= ${PREFIX}/libexec/nagios
pre-everything::
.if !defined(WITH_EXPECT_TOOLS)
@@ -53,8 +48,8 @@ pre-everything::
.endif
do-build:
- ( cd ${WRKSRC}/check_tcping-0.1.5 ; \
- ${CC} ${CFLAGS} -o check_tcping check_tcping.c )
+ cd ${WRKSRC}/check_tcping-0.1.5 ; \
+ ${CC} ${CFLAGS} -o check_tcping check_tcping.c
# Documentation
PLUGIN_README_DIRS= \
@@ -80,6 +75,7 @@ PLIST_SUB+= EXPECTTOOLS="@comment "
.endif
do-install:
+ ${MKDIR} ${NAGIOS_PLUGIN_DIR}
${MKDIR} ${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/check_snmp_counter-0.5.0/check_snmp_counter ${NAGIOS_PLUGIN_DIR}
${INSTALL_SCRIPT} ${WRKSRC}/check_snmp_gauge-0.3.0/check_snmp_gauge ${NAGIOS_PLUGIN_DIR}
@@ -104,4 +100,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-silfreed-plugins/pkg-plist b/net-mgmt/nagios-silfreed-plugins/pkg-plist
index 65c433521871..32aa4fbfd4fd 100644
--- a/net-mgmt/nagios-silfreed-plugins/pkg-plist
+++ b/net-mgmt/nagios-silfreed-plugins/pkg-plist
@@ -12,7 +12,9 @@ libexec/nagios/gen_check_snmp_if_services
%%EXPECTTOOLS%%libexec/nagios/pm3.exp
%%EXPECTTOOLS%%libexec/nagios/tnt
%%EXPECTTOOLS%%libexec/nagios/tnt.exp
+@unexec rmdir %D/libexec/nagios 2>/dev/null || true
%%EXAMPLESDIR%%/services-check_snmp_if.template
+@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%%%DOCSDIR%%/check_snmp_counter-0.5.0.README
%%PORTDOCS%%%%DOCSDIR%%/check_snmp_gauge-0.3.0.README
%%PORTDOCS%%%%DOCSDIR%%/check_snmp_if-0.3.5.README