aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios-snmp-plugins-extras
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:13:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-06-15 21:13:19 +0000
commit4ac1be2ede132ca5dfafd687377a6eaf62d1108e (patch)
tree1d9dceee71612802c5037bf45b6b77fa2f8e6255 /net-mgmt/nagios-snmp-plugins-extras
parent614e3e8eeabf5aebc66801be383df23a81a0f23c (diff)
downloadports-4ac1be2ede132ca5dfafd687377a6eaf62d1108e.tar.gz
ports-4ac1be2ede132ca5dfafd687377a6eaf62d1108e.zip
Notes
Diffstat (limited to 'net-mgmt/nagios-snmp-plugins-extras')
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/Makefile52
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/distinfo3
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/pkg-descr16
-rw-r--r--net-mgmt/nagios-snmp-plugins-extras/pkg-plist1
4 files changed, 72 insertions, 0 deletions
diff --git a/net-mgmt/nagios-snmp-plugins-extras/Makefile b/net-mgmt/nagios-snmp-plugins-extras/Makefile
new file mode 100644
index 000000000000..03ab0e7379fa
--- /dev/null
+++ b/net-mgmt/nagios-snmp-plugins-extras/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: nagios-snmp-plugins-extras
+# Date created: Sat 13 Jun 2009
+# Whom: Alexey V. Degtyarev
+#
+# $FreeBSD$
+#
+
+PORTNAME= nagios-snmp-plugins-extras
+PORTVERSION= 1.1.2
+CATEGORIES= net-mgmt
+MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= A set of Nagios plugins written in Perl to check devices with SNMP
+
+NO_BUILD= yes
+USE_PERL_RUN= yes
+
+RUN_DEPENDS+= p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${LOCALBASE}/libexec/nagios/utils.pm:${PORTSDIR}/net-mgmt/nagios-plugins
+
+PLUGINS= \
+ check_snmp_boostedge.pl \
+ check_snmp_cpfw.pl \
+ check_snmp_css.pl \
+ check_snmp_css_main.pl \
+ check_snmp_env.pl \
+ check_snmp_int.pl \
+ check_snmp_linkproof_nhr.pl \
+ check_snmp_load.pl \
+ check_snmp_mem.pl \
+ check_snmp_nsbox.pl \
+ check_snmp_process.pl \
+ check_snmp_storage.pl \
+ check_snmp_vrrp.pl \
+ check_snmp_win.pl \
+
+PLIST_FILES= ${PLUGINS:S,^,libexec/nagios/,}
+
+WRKSRC= ${WRKDIR}/plugins
+
+post-extract:
+ ${SED} -i "" -e "s#/tmp/#/var/tmp/#" \
+ -e "s#/usr/local/nagios/libexec#${LOCALBASE}/libexec/nagios#" \
+ ${PLUGINS:S,^,${WRKSRC}/,}
+
+do-install:
+ ${MKDIR} ${PREFIX}/libexec/nagios
+ ${INSTALL_SCRIPT} ${PLUGINS:S,^,${WRKSRC}/,} ${PREFIX}/libexec/nagios/
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nagios-snmp-plugins-extras/distinfo b/net-mgmt/nagios-snmp-plugins-extras/distinfo
new file mode 100644
index 000000000000..55bdc90fd4ce
--- /dev/null
+++ b/net-mgmt/nagios-snmp-plugins-extras/distinfo
@@ -0,0 +1,3 @@
+MD5 (nagios-snmp-plugins-extras-1.1.2.tar.gz) = da90e6f07196e5f79ce4bb69e5b24fb4
+SHA256 (nagios-snmp-plugins-extras-1.1.2.tar.gz) = 66354a29c960b49269319457a7bca12a691bd73b236d7421376d2c220374eff7
+SIZE (nagios-snmp-plugins-extras-1.1.2.tar.gz) = 102348
diff --git a/net-mgmt/nagios-snmp-plugins-extras/pkg-descr b/net-mgmt/nagios-snmp-plugins-extras/pkg-descr
new file mode 100644
index 000000000000..802e83e609bd
--- /dev/null
+++ b/net-mgmt/nagios-snmp-plugins-extras/pkg-descr
@@ -0,0 +1,16 @@
+The general idea of these scripts is to check as many things as possible with
+SNMP: disks, memory, load, network interfaces, running processes, etc...
+
+The other idea is to select disks, interfaces, process using regular
+expressions:
+
+- it is possible to test more than one disk/int/process in one Nagios check
+ (ex.: eth* instead of eth0,eth1,eth2,...)
+
+- you only have to provide a unique part of the name to select a
+ disk/int/process (ex. : "C:" instead of "C:\ Label: Serial Number xxxxxxx"
+ makes it easy to use on multiple Windows hosts).
+
+Most of these scripts can make performance outputs.
+
+WWW: http://nagios.manubulon.com/
diff --git a/net-mgmt/nagios-snmp-plugins-extras/pkg-plist b/net-mgmt/nagios-snmp-plugins-extras/pkg-plist
new file mode 100644
index 000000000000..70333e5eb62f
--- /dev/null
+++ b/net-mgmt/nagios-snmp-plugins-extras/pkg-plist
@@ -0,0 +1 @@
+@dirrmtry libexec/nagios