aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2001-04-03 22:07:20 +0000
committerMichael Haro <mharo@FreeBSD.org>2001-04-03 22:07:20 +0000
commit05b2ac3b5bf74e8785ab71e635bd6a8958f1d003 (patch)
treee36cd221d15592f885c75a70cd44966658896373 /net-mgmt/nagios/Makefile
parentbf853364e786dea0ba01785c7576e97f9f5eaf3b (diff)
downloadports-05b2ac3b5bf74e8785ab71e635bd6a8958f1d003.tar.gz
ports-05b2ac3b5bf74e8785ab71e635bd6a8958f1d003.zip
Notes
Diffstat (limited to 'net-mgmt/nagios/Makefile')
-rw-r--r--net-mgmt/nagios/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 7e331c57fe19..dc57265d8145 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= netsaint
-PORTVERSION= 0.0.7b2
+PORTVERSION= 0.0.7b3
CATEGORIES= net
MASTER_SITES= http://netsaint.sourceforge.net/download/
@@ -14,18 +14,23 @@ MAINTAINER= blaz@amis.net
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-# no run depends due to circular reference
-#RUN_DEPENDS= ${LOCALBASE}/libexec/netsaint/check_netsaint:${PORTSDIR}/net/netsaint-plugins
+RUN_DEPENDS= ${LOCALBASE}/libexec/netsaint/check_netsaint:${PORTSDIR}/net/netsaint-plugins
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lgd -lgnugetopt"
-CONFIGURE_ARGS= --with-command-user=root \
- --with-command-grp=wheel \
+CONFIGURE_ARGS= --with-command-user=nobody \
+ --with-command-grp=nogroup \
--with-netsaint-user=netsaint \
- --with-netsaint-grp=netsaint
-INSTALL_TARGET= all install config install-config install-daemoninit
+ --with-netsaint-grp=netsaint \
+ --sbindir=${PREFIX}/share/netsaint/sbin \
+ --libexecdir=${PREFIX}/libexec/netsaint \
+ --datadir=${PREFIX}/share/netsaint \
+ --sysconfdir=${PREFIX}/etc/netsaint \
+ --localstatedir=${PREFIX}/var/netsaint
+
+INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
pre-fetch:
@${SH} ${SCRIPTDIR}/checkps