aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagios
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2009-05-04 15:36:05 +0000
committerWesley Shields <wxs@FreeBSD.org>2009-05-04 15:36:05 +0000
commitce03a68eef1882d8f468fc69548754f164053527 (patch)
tree83e6fcebd3d329521c0305a12997aea9487d8b1f /net-mgmt/nagios
parent3c713d889cdb2f47ab7f519e4519de5c89e69f7a (diff)
downloadports-ce03a68eef1882d8f468fc69548754f164053527.tar.gz
ports-ce03a68eef1882d8f468fc69548754f164053527.zip
Notes
Diffstat (limited to 'net-mgmt/nagios')
-rw-r--r--net-mgmt/nagios/Makefile9
-rw-r--r--net-mgmt/nagios/files/patch-base-utils.c38
2 files changed, 43 insertions, 4 deletions
diff --git a/net-mgmt/nagios/Makefile b/net-mgmt/nagios/Makefile
index 6821be1bd620..f091c61ec841 100644
--- a/net-mgmt/nagios/Makefile
+++ b/net-mgmt/nagios/Makefile
@@ -6,7 +6,8 @@
#
PORTNAME= nagios
-DISTVERSION= 3.0.6
+PORTVERSION= 3.0.6
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -16,8 +17,6 @@ COMMENT= Extremely powerful network monitoring system
LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:${PORTSDIR}/net-mgmt/nagios-plugins
-MAKE_JOBS_UNSAFE= yes
-
USE_ICONV= yes
USE_PERL5_BUILD= yes
USE_AUTOTOOLS= autoconf:262 libltdl:15
@@ -68,6 +67,8 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LIBS="-L${LOCALBASE}/lib" \
PERL=${PERL}
+MAKE_JOBS_UNSAFE= yes
+
INSTALL_TARGET= install install-commandmode install-config
PLIST_SUB= NAGIOSDIR=${NAGIOSDIR} \
@@ -86,7 +87,7 @@ SUB_FILES= pkg-install \
### XXX: Subtle bug with removing PREFIX from here
SUB_LIST= PREFIX=${PREFIX} \
- ${PLIST_SUB}
+ ${PLIST_SUB}
.if defined(WITH_EMBEDDED_PERL)
USE_PERL5= 5.8.0+
diff --git a/net-mgmt/nagios/files/patch-base-utils.c b/net-mgmt/nagios/files/patch-base-utils.c
new file mode 100644
index 000000000000..e4aa4a489b82
--- /dev/null
+++ b/net-mgmt/nagios/files/patch-base-utils.c
@@ -0,0 +1,38 @@
+--- base/utils.c.orig 2008-12-01 03:52:58.000000000 +1030
++++ base/utils.c 2009-05-03 11:51:19.000000000 +0930
+@@ -3597,7 +3597,7 @@
+ /* initializes embedded perl interpreter */
+ int init_embedded_perl(char **env){
+ #ifdef EMBEDDEDPERL
+- char *embedding[]={ "", "" };
++ char **embedding = NULL;
+ int exitstatus=0;
+ char *temp_buffer=NULL;
+ int argc=2;
+@@ -3613,6 +3613,17 @@
+
+ else{
+
++ embedding = malloc(argc * sizeof(char *));
++ if (embedding == NULL) {
++ use_embedded_perl = FALSE;
++ logit(NSLOG_RUNTIME_ERROR, TRUE, "Error: Unable to allocate memory for embedded Perl interpreter! (see ports/131993)\n");
++ } else {
++ embedding[0] = malloc(sizeof(char));
++ if (embedding[0] == NULL) {
++ use_embedded_perl = FALSE;
++ logit(NSLOG_RUNTIME_ERROR, TRUE, "Error: Unable to allocate memory for embedded Perl interpreter! (see ports/131993)\n");
++ } else {
++ *embedding[0] = '\0';
+ embedding[1]=p1_file;
+
+ use_embedded_perl=TRUE;
+@@ -3624,6 +3635,8 @@
+ logit(NSLOG_RUNTIME_ERROR,TRUE,"Error: Could not allocate memory for embedded Perl interpreter!\n");
+ }
+ }
++ }
++ }
+
+ /* a fatal error occurred... */
+ if(use_embedded_perl==FALSE){