aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagiosgraph
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-24 09:20:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-24 09:20:53 +0000
commit4edc85e788ac61639625650b0dd160996cb1a107 (patch)
treef89274100ffc2455efda0484193b07f8e5117013 /net-mgmt/nagiosgraph
parentba7572abf5acd7193b217b04952117b693075d55 (diff)
downloadports-4edc85e788ac61639625650b0dd160996cb1a107.tar.gz
ports-4edc85e788ac61639625650b0dd160996cb1a107.zip
Notes
Diffstat (limited to 'net-mgmt/nagiosgraph')
-rw-r--r--net-mgmt/nagiosgraph/Makefile2
-rw-r--r--net-mgmt/nagiosgraph/files/patch-insert.pl22
2 files changed, 23 insertions, 1 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index 4eb1a15394a9..387b629947d6 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nagiosgraph
PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-mgmt/nagiosgraph/files/patch-insert.pl b/net-mgmt/nagiosgraph/files/patch-insert.pl
new file mode 100644
index 000000000000..252d0e4f0d0a
--- /dev/null
+++ b/net-mgmt/nagiosgraph/files/patch-insert.pl
@@ -0,0 +1,22 @@
+Index: insert.pl
+===================================================================
+--- insert.pl (.../vendor/nagiosgraph/0.8.2/insert.pl) (revision 1211)
++++ insert.pl (.../trunk/src/nagiosgraph/insert.pl) (revision 1211)
+@@ -148,9 +148,14 @@
+ if ( $ARGV[0] ) {
+ @inputlines = $ARGV[0];
+ } elsif ( defined $Config{perflog} ) {
+- open PERFLOG, $Config{perflog};
+- @inputlines = <PERFLOG>;
+- close PERFLOG
++ if (-s $Config{perflog}) {
++ my $worklog = $Config{perflog} . ".nagiosgraph";
++ rename($Config{perflog}, $worklog);
++ open PERFLOG, $worklog;
++ @inputlines = <PERFLOG>;
++ close PERFLOG;
++ unlink($worklog);
++ }
+ }
+
+ # Quit if there are no data to process