aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagiosgraph
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2014-03-07 06:26:31 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2014-03-07 06:26:31 +0000
commitbdf942631c4573f0d733a9f5eb4e5059891cd096 (patch)
tree419d0bf377f0f601d52b4cd1425479000e34a038 /net-mgmt/nagiosgraph
parent4954f48169736902078142ed6c023b18522d7d99 (diff)
downloadports-bdf942631c4573f0d733a9f5eb4e5059891cd096.tar.gz
ports-bdf942631c4573f0d733a9f5eb4e5059891cd096.zip
Notes
Diffstat (limited to 'net-mgmt/nagiosgraph')
-rw-r--r--net-mgmt/nagiosgraph/Makefile97
-rw-r--r--net-mgmt/nagiosgraph/pkg-plist80
2 files changed, 99 insertions, 78 deletions
diff --git a/net-mgmt/nagiosgraph/Makefile b/net-mgmt/nagiosgraph/Makefile
index 71733c75d63a..ae67d4a43947 100644
--- a/net-mgmt/nagiosgraph/Makefile
+++ b/net-mgmt/nagiosgraph/Makefile
@@ -3,84 +3,99 @@
PORTNAME= nagiosgraph
PORTVERSION= 1.4.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= SF
MAINTAINER= hizel@vyborg.ru
-COMMENT= Generate rrdtool\'s graphs by performance data from nagios plugins
+COMMENT= Generate rrdtool graphs using performance data from nagios plugins
-RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios \
- rrdtool>=0:${PORTSDIR}/databases/rrdtool
+RUN_DEPENDS= rrdtool>=0:${PORTSDIR}/databases/rrdtool
-USES= perl5
+OPTIONS_SINGLE= NAGIOS
+OPTIONS_SINGLE_NAGIOS= NAGIOS35 NAGIOS4
+OPTIONS_DEFAULT= NAGIOS35
+
+NAGIOS35_DESC= Install for nagios-3.5.x (net-mgmt/nagios)
+NAGIOS35_RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios
+
+NAGIOS4_DESC= Install for nagios-4.0.x (net-mgmt/nagios4)
+NAGIOS4_RUN_DEPENDS= ${LOCALBASE}/bin/nagios:${PORTSDIR}/net-mgmt/nagios4
+
+USES= perl5 shebangfix
USE_PERL5= run
NO_BUILD= yes
-PORTDOCS= AUTHORS CHANGELOG INSTALL README TODO
+DOCS= AUTHORS CHANGELOG INSTALL README TODO
NAGIOSWWWDIR?= www/nagios
-CGIFILES= show.cgi showconfig.cgi showgraph.cgi showgroup.cgi showhost.cgi \
- showservice.cgi testcolor.cgi
+CGIFILES= show.cgi showconfig.cgi showgraph.cgi showgroup.cgi \
+ showhost.cgi showservice.cgi testcolor.cgi
LIBFILES= insert.pl
-CFGFILES= nagiosgraph.conf nagiosgraph_de.conf nagiosgraph_es.conf nagiosgraph_fr.conf \
- servdb.conf groupdb.conf hostdb.conf datasetdb.conf map access.conf labels.conf \
- rrdopts.conf
+CFGFILES= nagiosgraph.conf nagiosgraph_de.conf nagiosgraph_es.conf \
+ nagiosgraph_fr.conf servdb.conf groupdb.conf hostdb.conf \
+ datasetdb.conf map access.conf labels.conf rrdopts.conf
+
+SHEBANG_FILES= utils/*.pl
PLIST_SUB= NAGIOSWWWDIR=${NAGIOSWWWDIR} PORTNAME=${PORTNAME}
-NO_STAGE= yes
post-patch:
- @${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!' ${WRKSRC}/etc/nagiosgraph.conf
+ @${REINPLACE_CMD} -e 's!%%PREFIX%%!${PREFIX}!' \
+ ${WRKSRC}/etc/nagiosgraph.conf
.for i in ${CGIFILES}
- @${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
- -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' \
- ${WRKSRC}/cgi/$i
+ @${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' \
+ -e 's!/usr/local!${PREFIX}!g' \
+ -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' \
+ ${WRKSRC}/cgi/$i
.endfor
.for i in ${LIBFILES}
- @${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' -e 's!/usr/local!${PREFIX}!g' \
- -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' \
- ${WRKSRC}/lib/$i
+ @${REINPLACE_CMD} -e 's!/usr/bin/perl!${PERL}!g' \
+ -e 's!/usr/local!${PREFIX}!g' \
+ -e 's!/opt/nagiosgraph/etc!${PREFIX}/etc/nagios/nagiosgraph!g' \
+ ${WRKSRC}/lib/$i
.endfor
do-install:
- ${MKDIR} ${PREFIX}/etc/nagios/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/etc/ngshared.pm ${PREFIX}/etc/nagios/${PORTNAME}/ngshared.pm
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/nagios/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/etc/ngshared.pm \
+ ${STAGEDIR}${PREFIX}/etc/nagios/${PORTNAME}/ngshared.pm
.for i in ${CFGFILES}
- ${INSTALL_DATA} ${WRKSRC}/etc/$i ${PREFIX}/etc/nagios/${PORTNAME}/${i}.sample
- [ -f ${PREFIX}/etc/nagios/${PORTNAME}/${i} ] || ${CP} -p ${PREFIX}/etc/nagios/${PORTNAME}/${i}.sample \
- ${PREFIX}/etc/nagios/${PORTNAME}/${i}
+ ${INSTALL_DATA} ${WRKSRC}/etc/$i \
+ ${STAGEDIR}${PREFIX}/etc/nagios/${PORTNAME}/${i}.sample
.endfor
- ${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.for i in ${LIBFILES}
- ${INSTALL_SCRIPT} ${WRKSRC}/lib/${i} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/lib/${i} \
+ ${STAGEDIR}${PREFIX}/libexec/${PORTNAME}
.endfor
- ${MKDIR} ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}
.for i in ${CGIFILES}
- ${INSTALL_SCRIPT} ${WRKSRC}/cgi/$i ${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/cgi/$i \
+ ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/cgi-bin/${PORTNAME}/
.endfor
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/stylesheets
.for i in share/nagiosgraph.css share/nagiosgraph.js share/nagiosgraph.ssi
- ${INSTALL_DATA} ${WRKSRC}/$i ${PREFIX}/${NAGIOSWWWDIR}/stylesheets
+ ${INSTALL_DATA} ${WRKSRC}/$i \
+ ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/stylesheets/
.endfor
- ${INSTALL_DATA} ${WRKSRC}/share/graph.gif ${PREFIX}/${NAGIOSWWWDIR}/images/action-nagiosgraph.gif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/images
+ ${INSTALL_DATA} ${WRKSRC}/share/graph.gif \
+ ${STAGEDIR}${PREFIX}/${NAGIOSWWWDIR}/images/action-nagiosgraph.gif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in utils/testentry.pl utils/upgrade.pl
- ${INSTALL_SCRIPT} ${WRKSRC}/$i ${EXAMPLESDIR}/
+ ${INSTALL_SCRIPT} ${WRKSRC}/$i ${STAGEDIR}${EXAMPLESDIR}/
+.endfor
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}/
.endfor
-.endif
-
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-. for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
-. endfor
-.endif
.include <bsd.port.mk>
diff --git a/net-mgmt/nagiosgraph/pkg-plist b/net-mgmt/nagiosgraph/pkg-plist
index 23f4de4b02ad..21544530c1ce 100644
--- a/net-mgmt/nagiosgraph/pkg-plist
+++ b/net-mgmt/nagiosgraph/pkg-plist
@@ -1,41 +1,48 @@
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/groupdb.conf.sample %D/etc/nagios/%%PORTNAME%%/groupdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/groupdb.conf; fi
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/access.conf.sample %D/etc/nagios/%%PORTNAME%%/access.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/access.conf ; fi
+etc/nagios/%%PORTNAME%%/access.conf.sample
+@exec [ ! -f %B/access.conf ] && cp -p %D/%F %B/access.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/datasetdb.conf.sample %D/etc/nagios/%%PORTNAME%%/datasetdb.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/datasetdb.conf ; fi
+etc/nagios/%%PORTNAME%%/datasetdb.conf.sample
+@exec [ ! -f %B/datasetdb.conf ] && cp -p %D/%F %B/datasetdb.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/groupdb.conf.sample %D/etc/nagios/%%PORTNAME%%/groupdb.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/groupdb.conf ; fi
etc/nagios/%%PORTNAME%%/groupdb.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/groupdb.conf ] ; then cp -p %D/%F %B/groupdb.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/hostdb.conf.sample %D/etc/nagios/%%PORTNAME%%/hostdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/hostdb.conf; fi
+@exec [ ! -f %B/groupdb.conf ] && cp -p %D/%F %B/groupdb.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/hostdb.conf.sample %D/etc/nagios/%%PORTNAME%%/hostdb.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/hostdb.conf ; fi
etc/nagios/%%PORTNAME%%/hostdb.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/hostdb.conf ] ; then cp -p %D/%F %B/hostdb.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/map.sample %D/etc/nagios/%%PORTNAME%%/map; then rm -f %D/etc/nagios/%%PORTNAME%%/map; fi
+@exec [ ! -f %B/hostdb.conf ] && cp -p %D/%F %B/hostdb.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/labels.conf.sample %D/etc/nagios/%%PORTNAME%%/labels.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/labels.conf ; fi
+etc/nagios/%%PORTNAME%%/labels.conf.sample
+@exec [ ! -f %B/labels.conf ] && cp -p %D/%F %B/labels.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/map.sample %D/etc/nagios/%%PORTNAME%%/map ; then rm -f %D/etc/nagios/%%PORTNAME%%/map ; fi
etc/nagios/%%PORTNAME%%/map.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/map ] ; then cp -p %D/%F %B/map; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf.sample %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf; fi
-etc/nagios/%%PORTNAME%%/nagiosgraph.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph.conf ] ; then cp -p %D/%F %B/nagiosgraph.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/nagiosgraph_de.conf.sample %D/etc/nagios/%%PORTNAME%%/nagiosgraph_de.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_de.conf; fi
-etc/nagios/%%PORTNAME%%/nagiosgraph_de.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_de.conf ] ; then cp -p %D/%F %B/nagiosgraph_de.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/nagiosgraph_es.conf.sample %D/etc/nagios/%%PORTNAME%%/nagiosgraph_es.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_es.conf; fi
-etc/nagios/%%PORTNAME%%/nagiosgraph_es.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_es.conf ] ; then cp -p %D/%F %B/nagiosgraph_es.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/nagiosgraph_fr.conf.sample %D/etc/nagios/%%PORTNAME%%/nagiosgraph_fr.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_fr.conf; fi
-etc/nagios/%%PORTNAME%%/nagiosgraph_fr.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/nagiosgraph_fr.conf ] ; then cp -p %D/%F %B/nagiosgraph_fr.conf; fi
+@exec [ ! -f %B/map ] && cp -p %D/%F %B/map || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%.conf.sample %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%.conf ; fi
+etc/nagios/%%PORTNAME%%/%%PORTNAME%%.conf.sample
+@exec [ ! -f %B/%%PORTNAME%%.conf ] && cp -p %D/%F %B/%%PORTNAME%%.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_de.conf.sample %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_de.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_de.conf ; fi
+etc/nagios/%%PORTNAME%%/%%PORTNAME%%_de.conf.sample
+@exec [ ! -f %B/%%PORTNAME%%_de.conf ] && cp -p %D/%F %B/%%PORTNAME%%_de.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_es.conf.sample %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_es.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_es.conf ; fi
+etc/nagios/%%PORTNAME%%/%%PORTNAME%%_es.conf.sample
+@exec [ ! -f %B/%%PORTNAME%%_es.conf ] && cp -p %D/%F %B/%%PORTNAME%%_es.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_fr.conf.sample %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_fr.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/%%PORTNAME%%_fr.conf ; fi
+etc/nagios/%%PORTNAME%%/%%PORTNAME%%_fr.conf.sample
+@exec [ ! -f %B/%%PORTNAME%%_fr.conf ] && cp -p %D/%F %B/%%PORTNAME%%_fr.conf || true
etc/nagios/%%PORTNAME%%/ngshared.pm
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/servdb.conf.sample %D/etc/nagios/%%PORTNAME%%/servdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/servdb.conf; fi
-etc/nagios/%%PORTNAME%%/servdb.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/servdb.conf ] ; then cp -p %D/%F %B/servdb.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/datasetdb.conf.sample %D/etc/nagios/%%PORTNAME%%/datasetdb.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/datasetdb.conf; fi
-etc/nagios/%%PORTNAME%%/datasetdb.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/datasetdb.conf ] ; then cp -p %D/%F %B/datasetdb.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/access.conf.sample %D/etc/nagios/%%PORTNAME%%/access.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/access.conf; fi
-etc/nagios/%%PORTNAME%%/access.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/access.conf ] ; then cp -p %D/%F %B/access.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/labels.conf.sample %D/etc/nagios/%%PORTNAME%%/labels.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/labels.conf; fi
-etc/nagios/%%PORTNAME%%/labels.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/labels.conf ] ; then cp -p %D/%F %B/labels.conf; fi
-@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/rrdopts.conf.sample %D/etc/nagios/%%PORTNAME%%/rrdopts.conf; then rm -f %D/etc/nagios/%%PORTNAME%%/rrdopts.conf; fi
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/rrdopts.conf.sample %D/etc/nagios/%%PORTNAME%%/rrdopts.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/rrdopts.conf ; fi
etc/nagios/%%PORTNAME%%/rrdopts.conf.sample
-@exec if [ ! -f %D/etc/nagios/%%PORTNAME%%/rrdopts.conf ] ; then cp -p %D/%F %B/rrdopts.conf; fi
+@exec [ ! -f %B/rrdopts.conf ] && cp -p %D/%F %B/rrdopts.conf || true
+@unexec if cmp -s %D/etc/nagios/%%PORTNAME%%/servdb.conf.sample %D/etc/nagios/%%PORTNAME%%/servdb.conf ; then rm -f %D/etc/nagios/%%PORTNAME%%/servdb.conf ; fi
+etc/nagios/%%PORTNAME%%/servdb.conf.sample
+@exec [ ! -f %B/servdb.conf ] && cp -p %D/%F %B/servdb.conf || true
libexec/%%PORTNAME%%/insert.pl
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testentry.pl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upgrade.pl
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/show.cgi
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showconfig.cgi
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showgraph.cgi
@@ -43,13 +50,12 @@ libexec/%%PORTNAME%%/insert.pl
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showhost.cgi
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/showservice.cgi
%%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%/testcolor.cgi
-%%NAGIOSWWWDIR%%/images/action-nagiosgraph.gif
+%%NAGIOSWWWDIR%%/images/action-%%PORTNAME%%.gif
%%NAGIOSWWWDIR%%/stylesheets/%%PORTNAME%%.css
%%NAGIOSWWWDIR%%/stylesheets/%%PORTNAME%%.js
%%NAGIOSWWWDIR%%/stylesheets/%%PORTNAME%%.ssi
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/testentry.pl
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/upgrade.pl
-@dirrm libexec/%%PORTNAME%%
@dirrmtry %%NAGIOSWWWDIR%%/cgi-bin/%%PORTNAME%%
+%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry libexec/%%PORTNAME%%
@dirrmtry etc/nagios/%%PORTNAME%%
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%