aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nagiostat/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-22 01:48:42 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-07-22 01:48:42 +0000
commitac47e376bcd341604648e044f405c837c6f0c106 (patch)
tree84639941c8f041587f2e77bfbda61ff090750d21 /net-mgmt/nagiostat/Makefile
parentaff387dcb567b34383a43b1e493d9ba83c20f20e (diff)
downloadports-ac47e376bcd341604648e044f405c837c6f0c106.tar.gz
ports-ac47e376bcd341604648e044f405c837c6f0c106.zip
Notes
Diffstat (limited to 'net-mgmt/nagiostat/Makefile')
-rw-r--r--net-mgmt/nagiostat/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-mgmt/nagiostat/Makefile b/net-mgmt/nagiostat/Makefile
new file mode 100644
index 000000000000..f1c53c103a4c
--- /dev/null
+++ b/net-mgmt/nagiostat/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: nagiostat
+# Date created: 20 July 2004
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= nagiostat
+PORTVERSION= 1.0.0
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Nagiostat parses performance-data from Nagios and generates graphs
+
+RUN_DEPENDS= rrdtool:${PORTSDIR}/net/rrdtool \
+ nagios:${PORTSDIR}/net-mgmt/nagios \
+ ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
+
+USE_PERL5= yes
+NO_BUILD= yes
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+NAGIOSDIR?= /var/spool/nagios
+DOC_FILES= README GPL.txt
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|%%NAGIOSTATCONFDIR%%|${PREFIX}/etc/|' \
+ -e 's|%%NAGIOSTATDIR%%|${PREFIX}/libexec/${PORTNAME}/|' \
+ -e 's|%%NAGIOSTATRRD%%|${NAGIOSDIR}/${PORTNAME}rrd/|' \
+ -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/nagiostat ${WRKSRC}/nagiostat.conf ${WRKSRC}/README
+do-install:
+ @${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ @${MKDIR} ${NAGIOSDIR}/${PORTNAME}rrd
+ @${INSTALL_SCRIPT} ${WRKSRC}/nagiostat ${PREFIX}/libexec/${PORTNAME}/
+ @${LN} -fs ${PREFIX}/libexec/${PORTNAME}/nagiostat ${PREFIX}/share/nagios/cgi-bin/nagiostat.cgi
+ @${INSTALL_DATA} ${WRKSRC}/nagiostat.conf ${PREFIX}/etc/nagiostat.conf-sample
+ @${INSTALL_DATA} ${WRKSRC}/graph.gif ${PREFIX}/share/nagios/images/logos
+ @${MKDIR} ${PREFIX}/libexec/${PORTNAME}/html-templates/
+ @${INSTALL_DATA} ${WRKSRC}/html-templates/default.html ${PREFIX}/libexec/${PORTNAME}/html-templates/
+ @${INSTALL_DATA} ${WRKSRC}/html-templates/graphindex.html ${PREFIX}/libexec/${PORTNAME}/html-templates/
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>