aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ndpmon/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2011-09-25 16:47:03 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2011-09-25 16:47:03 +0000
commitf6da2654cccf5b166fd6b70956fe8c297100a254 (patch)
tree3072fb826289bff10b7dc6fa261b83b9dcecd160 /net-mgmt/ndpmon/Makefile
parent7f63fbb09bcc28003ba116f53937dd0b5a19a759 (diff)
downloadports-f6da2654cccf5b166fd6b70956fe8c297100a254.tar.gz
ports-f6da2654cccf5b166fd6b70956fe8c297100a254.zip
Notes
Diffstat (limited to 'net-mgmt/ndpmon/Makefile')
-rw-r--r--net-mgmt/ndpmon/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index 6471c3256250..08c1de70d1f6 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -14,7 +14,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= On-link icmpv6 message monitoring and reporting daemon
-OPTIONS= PY4SUITE "Depend on py-4suite-xml (for generating HTML)" off
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS= PY4SUITE "Depend on py-4suite-xml (for generating HTML)" off \
+ MACRESOLV "Enable MAC Manufacturer Resolution" off
.include <bsd.port.options.mk>
@@ -30,13 +34,19 @@ USE_GNOME= libxml2
USE_PERL5_RUN= yes
USE_RC_SUBR= ndpmonitor
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= OSTYPE=FreeBSD
-CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var --with-confdir=${ETCDIR}
+CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var --with-confdir=${ETCDIR} \
+ --with-libxml2=${LOCALBASE} --cache-file=/dev/null
MAN8= ndpmon.8
PORTDOCS= INSTALL README
+.if defined(WITH_MACRESOLV)
+CONFIGURE_ARGS+=--enable-mac-resolv
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' \