aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ndpmon
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-10-26 13:33:43 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-10-26 13:33:43 +0000
commit89e1c532552690fec5364e060cb9cf04cb6ae1fa (patch)
treefd9e307ed79b52f7ddd2b20ab75c101c33649457 /net-mgmt/ndpmon
parentf00607e9f4e3c524587540ae7d44ebce3e6a084b (diff)
downloadports-89e1c532552690fec5364e060cb9cf04cb6ae1fa.tar.gz
ports-89e1c532552690fec5364e060cb9cf04cb6ae1fa.zip
Notes
Diffstat (limited to 'net-mgmt/ndpmon')
-rw-r--r--net-mgmt/ndpmon/Makefile18
-rw-r--r--net-mgmt/ndpmon/distinfo6
-rw-r--r--net-mgmt/ndpmon/files/patch-config__ndpmon.xml15
-rw-r--r--net-mgmt/ndpmon/files/patch-config__ndpmon.xml.in20
-rw-r--r--net-mgmt/ndpmon/files/patch-create__html__table.py14
-rw-r--r--net-mgmt/ndpmon/files/patch-demopipeprogram.pl.sample (renamed from net-mgmt/ndpmon/files/patch-demopipeprogram.pl)6
-rw-r--r--net-mgmt/ndpmon/files/patch-ndpmon.82
-rw-r--r--net-mgmt/ndpmon/files/patch-ndpmon.c20
-rw-r--r--net-mgmt/ndpmon/files/patch-ndpmon__defs.h.in17
-rw-r--r--net-mgmt/ndpmon/files/patch-neighbor__list.xml12
-rw-r--r--net-mgmt/ndpmon/pkg-plist6
11 files changed, 80 insertions, 56 deletions
diff --git a/net-mgmt/ndpmon/Makefile b/net-mgmt/ndpmon/Makefile
index d3664b71e22a..ebeba1d701ce 100644
--- a/net-mgmt/ndpmon/Makefile
+++ b/net-mgmt/ndpmon/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ndpmon
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3a
CATEGORIES= net-mgmt ipv6
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,21 +18,21 @@ COMMENT= On-link icmpv6 message monitoring and reporting daemon
USE_GNOME= libxml2
USE_PERL5_RUN= yes
USE_RC_SUBR= ndpmonitor
-WRKSRC= ${WRKDIR}/${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= OSTYPE=FreeBSD
+CONFIGURE_ARGS= --with-var-datadir=${PREFIX}/var
MAN8= ndpmon.8
PORTDOCS= INSTALL README
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/ndpmon.c \
${WRKSRC}/ndpmon.8 \
${WRKSRC}/config_ndpmon.xml \
- ${WRKSRC}/neighbor_list.xml \
- ${WRKSRC}/demopipeprogram.pl
+ ${WRKSRC}/create_html_table.py \
+ ${WRKSRC}/demopipeprogram.pl.sample
+ (cd ${WRKSRC}; ${MAKE} clean)
do-install:
${INSTALL_MAN} ${WRKSRC}/ndpmon.8 ${PREFIX}/man/man8
@@ -41,9 +40,12 @@ do-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/*.dtd \
${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/demopipeprogram.pl \
+ ${INSTALL_SCRIPT} ${WRKSRC}/demopipeprogram.pl.sample \
${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${PREFIX}/etc/config_ndpmon.xml-dist
+ ${INSTALL_SCRIPT} ${WRKSRC}/create_html_table.py \
+ ${DATADIR}
+ ${MKDIR} ${PREFIX}/etc/ndpmon
+ ${INSTALL_DATA} ${WRKSRC}/config_ndpmon.xml ${PREFIX}/etc/ndpmon/config_ndpmon.xml-dist
${MKDIR} ${PREFIX}/var
${INSTALL_DATA} ${WRKSRC}/neighbor_list.xml ${PREFIX}/var/ndpmon_neighbor_list.xml
diff --git a/net-mgmt/ndpmon/distinfo b/net-mgmt/ndpmon/distinfo
index 2c71b891aa3f..ec17f9df936d 100644
--- a/net-mgmt/ndpmon/distinfo
+++ b/net-mgmt/ndpmon/distinfo
@@ -1,3 +1,3 @@
-MD5 (ndpmon-1.2.tgz) = 4073e4b4d0a9031572a2988760622116
-SHA256 (ndpmon-1.2.tgz) = 9e7239a59d33348bd7a69150bc34c7877916e9afecb58314c5e319d23447a2ef
-SIZE (ndpmon-1.2.tgz) = 234792
+MD5 (ndpmon-1.3a.tgz) = 3f0532fa61a0ac5bd5123eab2e95c9c2
+SHA256 (ndpmon-1.3a.tgz) = 0425914ac03c9915ba8d3d54f2d93d6103f4d5346d9b544ce6fbe26203764675
+SIZE (ndpmon-1.3a.tgz) = 298651
diff --git a/net-mgmt/ndpmon/files/patch-config__ndpmon.xml b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
index 01dd6af5cf42..4cb27164e050 100644
--- a/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
+++ b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml
@@ -3,25 +3,26 @@ $FreeBSD$
--- config_ndpmon.xml.orig
+++ config_ndpmon.xml
-@@ -1,5 +1,5 @@
+@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="ISO-8859-1"?>
--<!DOCTYPE config_ndpmon SYSTEM "config_ndpmon.dtd">
+ <?xml-stylesheet type="text/xsl" href="config.xsl" ?>
+-<!DOCTYPE config_ndpmon SYSTEM "/usr/local/etc/ndpmon/config_ndpmon.dtd">
+<!DOCTYPE config_ndpmon SYSTEM "%%PREFIX%%/share/ndpmon/config_ndpmon.dtd">
<config_ndpmon>
<ignor_autoconf>1</ignor_autoconf>
<syslog_facility>LOG_LOCAL1</syslog_facility>
-@@ -7,12 +7,12 @@
+@@ -8,12 +8,12 @@
<actions_low_pri>
<sendmail>1</sendmail>
<syslog>1</syslog>
-- <exec_pipe_program>/usr/local/ndpmon/demopipeprogram.pl</exec_pipe_program>
-+ <exec_pipe_program>%%PREFIX%%/share/ndpmon/demopipeprogram.pl</exec_pipe_program>
+- <exec_pipe_program>/usr/local/ndpmon/create_html_table.py</exec_pipe_program>
++ <exec_pipe_program>%%PREFIX%%/share/ndpmon/create_html_table.py</exec_pipe_program>
</actions_low_pri>
<actions_high_pri>
<sendmail>1</sendmail>
<syslog>1</syslog>
-- <exec_pipe_program>/usr/local/ndpmon/demopipeprogram.pl</exec_pipe_program>
-+ <exec_pipe_program>%%PREFIX%%/share/ndpmon/demopipeprogram.pl</exec_pipe_program>
+- <exec_pipe_program>/usr/local/ndpmon/create_html_table.py</exec_pipe_program>
++ <exec_pipe_program>%%PREFIX%%/share/ndpmon/create_html_table.py</exec_pipe_program>
</actions_high_pri>
<use_reverse_hostlookups>1</use_reverse_hostlookups>
<routers>
diff --git a/net-mgmt/ndpmon/files/patch-config__ndpmon.xml.in b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml.in
new file mode 100644
index 000000000000..a54c29b7e698
--- /dev/null
+++ b/net-mgmt/ndpmon/files/patch-config__ndpmon.xml.in
@@ -0,0 +1,20 @@
+
+$FreeBSD$
+
+--- config_ndpmon.xml.in.orig
++++ config_ndpmon.xml.in
+@@ -8,12 +8,12 @@
+ <actions_low_pri>
+ <sendmail>1</sendmail>
+ <syslog>1</syslog>
+- <exec_pipe_program>/usr/local/ndpmon/create_html_table.py</exec_pipe_program>
++ <exec_pipe_program>@prefix@/share/ndpmon/create_html_table.py</exec_pipe_program>
+ </actions_low_pri>
+ <actions_high_pri>
+ <sendmail>1</sendmail>
+ <syslog>1</syslog>
+- <exec_pipe_program>/usr/local/ndpmon/create_html_table.py</exec_pipe_program>
++ <exec_pipe_program>@prefix@/share/ndpmon/create_html_table.py</exec_pipe_program>
+ </actions_high_pri>
+ <use_reverse_hostlookups>1</use_reverse_hostlookups>
+ <routers>
diff --git a/net-mgmt/ndpmon/files/patch-create__html__table.py b/net-mgmt/ndpmon/files/patch-create__html__table.py
new file mode 100644
index 000000000000..a3dac0ac8439
--- /dev/null
+++ b/net-mgmt/ndpmon/files/patch-create__html__table.py
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- create_html_table.py.orig
++++ create_html_table.py
+@@ -11,7 +11,7 @@
+ from xml.dom import Node
+
+ # The file in which we will write the alerts
+-alerts = "/var/local/ndpmon/alerts.xml"
++alerts = "%%PREFIX%%/var/ndpmon/alerts.xml"
+
+ # The alert itself piped from NDPmon to this script
+ lines = sys.stdin.readlines()
diff --git a/net-mgmt/ndpmon/files/patch-demopipeprogram.pl b/net-mgmt/ndpmon/files/patch-demopipeprogram.pl.sample
index 1923b678ad66..eaf4ce901aef 100644
--- a/net-mgmt/ndpmon/files/patch-demopipeprogram.pl
+++ b/net-mgmt/ndpmon/files/patch-demopipeprogram.pl.sample
@@ -1,14 +1,14 @@
$FreeBSD$
---- demopipeprogram.pl.orig
-+++ demopipeprogram.pl
+--- demopipeprogram.pl.sample.orig
++++ demopipeprogram.pl.sample
@@ -1,7 +1,7 @@
#!/usr/bin/perl
my $i=0;
-open DATA, ">>/usr/local/ndpmon/test.txt" or die "Cannot open /usr/local/ndpmon/test.txt for writing\n";
-+open DATA, ">>%%PREFIX%%/var/ndpmon_test.txt" or die "Cannot open %%PREFIX%%/var/ndpmon_test.txt for writing\n";
++open DATA, ">>%%PREFIX%%/var/ndpmon/ndpmon_test.txt" or die "Cannot open %%PREFIX%%/var/ndpmon/ndpmon_test.txt for writing\n";
print DATA "-----\n";
while (<STDIN>) {
diff --git a/net-mgmt/ndpmon/files/patch-ndpmon.8 b/net-mgmt/ndpmon/files/patch-ndpmon.8
index 2884a0cc7924..b0eb037f0e5c 100644
--- a/net-mgmt/ndpmon/files/patch-ndpmon.8
+++ b/net-mgmt/ndpmon/files/patch-ndpmon.8
@@ -29,7 +29,7 @@ $FreeBSD$
.B -g
flag is used to change the path to the neighbor cache. The default is
-.I /usr/local/ndpmon/neighbor_list.xml
-+.I %%PREFIX%%/var/ndpmon_neighbor_list.xml
++.I %%PREFIX%%/var/ndpmon/ndpmon_neighbor_list.xml
.LP
Note that an empty
.I neighbor_cache.xml
diff --git a/net-mgmt/ndpmon/files/patch-ndpmon.c b/net-mgmt/ndpmon/files/patch-ndpmon.c
deleted file mode 100644
index 4d183a8eaa44..000000000000
--- a/net-mgmt/ndpmon/files/patch-ndpmon.c
+++ /dev/null
@@ -1,20 +0,0 @@
-
-$FreeBSD$
-
---- ndpmon.c.orig
-+++ ndpmon.c
-@@ -43,10 +43,10 @@
- char admin_mail[128] = "";
- char syslog_facility[16] = "";
- int ignor_autoconf = 0;
--char config_path[128] = "/usr/local/ndpmon/config_ndpmon.xml";
--char cache_path[128] = "/usr/local/ndpmon/neighbor_list.xml";
--char dtd_path[128] = "/usr/local/ndpmon/neighbor_list.dtd";
--char dtd_config_path[128] = "/usr/local/ndpmon/config_ndpmon.dtd";
-+char config_path[128] = "%%PREFIX%%/etc/config_ndpmon.xml";
-+char cache_path[128] = "%%PREFIX%%/var/ndpmon_neighbor_list.xml";
-+char dtd_path[128] = "%%PREFIX%%/share/ndpmon/neighbor_list.dtd";
-+char dtd_config_path[128] = "%%PREFIX%%/share/ndpmon/config_ndpmon.dtd";
-
- struct action_selector action_low_pri, action_high_pri;
- int use_reverse_hostlookups;
diff --git a/net-mgmt/ndpmon/files/patch-ndpmon__defs.h.in b/net-mgmt/ndpmon/files/patch-ndpmon__defs.h.in
new file mode 100644
index 000000000000..68373c9d6cd9
--- /dev/null
+++ b/net-mgmt/ndpmon/files/patch-ndpmon__defs.h.in
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- ndpmon_defs.h.in.orig
++++ ndpmon_defs.h.in
+@@ -10,9 +10,9 @@
+ #endif
+
+ #define _CONFIG_PATH_ "@prefix@/etc/ndpmon/config_ndpmon.xml"
+-#define _CONFIG_DTD_PATH_ "@prefix@/etc/ndpmon/config_ndpmon.dtd"
++#define _CONFIG_DTD_PATH_ "@prefix@/share/ndpmon/config_ndpmon.dtd"
+ #define _CACHE_PATH_ "@VARDATADIR@/ndpmon/neighbor_list.xml"
+-#define _CACHE_DTD_PATH_ "@VARDATADIR@/ndpmon/neighbor_list.dtd"
++#define _CACHE_DTD_PATH_ "@prefix@/share/ndpmon/neighbor_list.dtd"
+ #define _DISCOVERY_HISTORY_PATH_ "@VARDATADIR@/ndpmon/discovery_history.dat"
+
+ extern int DEBUG;
diff --git a/net-mgmt/ndpmon/files/patch-neighbor__list.xml b/net-mgmt/ndpmon/files/patch-neighbor__list.xml
deleted file mode 100644
index 46531fbaa1f4..000000000000
--- a/net-mgmt/ndpmon/files/patch-neighbor__list.xml
+++ /dev/null
@@ -1,12 +0,0 @@
-
-$FreeBSD$
-
---- neighbor_list.xml.orig
-+++ neighbor_list.xml
-@@ -1,5 +1,5 @@
- <?xml version="1.0" encoding="ISO-8859-1"?>
- <!DOCTYPE neighbor_list
--SYSTEM "/usr/local/ndpmon/neighbor_list.dtd">
-+SYSTEM "%%PREFIX%%/share/ndpmon/neighbor_list.dtd">
- <neighbor_list>
- </neighbor_list>
diff --git a/net-mgmt/ndpmon/pkg-plist b/net-mgmt/ndpmon/pkg-plist
index 96287a742ae6..b7e317dbd014 100644
--- a/net-mgmt/ndpmon/pkg-plist
+++ b/net-mgmt/ndpmon/pkg-plist
@@ -1,8 +1,10 @@
sbin/ndpmon
%%DATADIR%%/config_ndpmon.dtd
%%DATADIR%%/neighbor_list.dtd
-%%DATADIR%%/demopipeprogram.pl
+%%DATADIR%%/demopipeprogram.pl.sample
+%%DATADIR%%/create_html_table.py
@dirrmtry %%DATADIR%%
var/ndpmon_neighbor_list.xml
@dirrmtry var
-etc/config_ndpmon.xml-dist
+etc/ndpmon/config_ndpmon.xml-dist
+@dirrmtry etc/ndpmon