aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2017-12-04 18:54:38 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2017-12-04 18:54:38 +0000
commit3fcd48bc9a9e5541c387fe802defa3344cc42505 (patch)
tree4ad8531943c985082b596fa1f496bd40df72fcf0 /net-mgmt/net-snmp/Makefile
parent4a70d839f9ac3dbc5985fdd1667a643fd206090d (diff)
downloadports-3fcd48bc9a9e5541c387fe802defa3344cc42505.tar.gz
ports-3fcd48bc9a9e5541c387fe802defa3344cc42505.zip
Notes
Diffstat (limited to 'net-mgmt/net-snmp/Makefile')
-rw-r--r--net-mgmt/net-snmp/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 1bf28d2cf01c..937f5af4cbc4 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -75,9 +75,9 @@ TLS_CONFIGURE_ON= --with-security-modules=tsm --with-transports=TLSTCP,DTLSUDP
.if ${PORT_OPTIONS:MPYTHON}
PYDISTUTILS_PKGNAME?= netsnmp-python
PYDISTUTILS_PKGVERSION?= 1.0a1
-USES+= python
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools
+USES+= python:2.7
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR}
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}setuptools>0:devel/py-setuptools@${PY_FLAVOR}
CONFIGURE_ARGS+=--with-python-modules
CONFIGURE_ENV+= PYTHONPROG="${PYTHON_CMD}"
MAKE_ENV+= PYDISTUTILS_INSTALLARGS="${PYDISTUTILS_INSTALLARGS}" STAGEDIR="${STAGEDIR}"