aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp4
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /net-mgmt/net-snmp4
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
downloadports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.tar.gz
ports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.zip
Notes
Diffstat (limited to 'net-mgmt/net-snmp4')
-rw-r--r--net-mgmt/net-snmp4/Makefile4
-rw-r--r--net-mgmt/net-snmp4/files/snmpd.sh.sample20
2 files changed, 21 insertions, 3 deletions
diff --git a/net-mgmt/net-snmp4/Makefile b/net-mgmt/net-snmp4/Makefile
index f7de629c1338..a6810058b6bc 100644
--- a/net-mgmt/net-snmp4/Makefile
+++ b/net-mgmt/net-snmp4/Makefile
@@ -66,9 +66,7 @@ post-install:
${INSTALL_DATA} $$F ${PREFIX}/share/examples/ucd-snmp ; done
@if [ ! -f ${STARTUP_FILE} ]; then \
${ECHO} "Creating ${PREFIX}/etc/rc.d/snmpd.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${STARTUP_FILE}; \
- ${ECHO} "[ -x ${PREFIX}/sbin/snmpd ] && ${PREFIX}/sbin/snmpd && ${ECHO} -n ' snmpd'" >> ${STARTUP_FILE}; \
- ${CHMOD} 751 ${STARTUP_FILE}; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/snmpd.sh.sample ${STARTUP_FILE}; \
fi
.include <bsd.port.post.mk>
diff --git a/net-mgmt/net-snmp4/files/snmpd.sh.sample b/net-mgmt/net-snmp4/files/snmpd.sh.sample
new file mode 100644
index 000000000000..71f8b504ce81
--- /dev/null
+++ b/net-mgmt/net-snmp4/files/snmpd.sh.sample
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x ${PREFIX}/sbin/snmpd ] && ${PREFIX}/sbin/snmpd && echo -n ' snmpd'
+ ;;
+stop)
+ killall snmpd && echo -n ' snmpd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0