aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-04-27 02:49:06 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-04-27 02:49:06 +0000
commit48dde50267a26d2194b65fb8e3c0d0edb9979aac (patch)
tree1faed17b6b09d98bf6f4f8b0c26bcfbccedf9d4a /net-mgmt/net-snmp
parent30d89750ca9a091ca347406da4aabcedf41d6d64 (diff)
downloadports-48dde50267a26d2194b65fb8e3c0d0edb9979aac.tar.gz
ports-48dde50267a26d2194b65fb8e3c0d0edb9979aac.zip
Notes
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent__mibgroup__agent__extend.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 05a94f885017..826fec63db81 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent__mibgroup__agent__extend.c b/net-mgmt/net-snmp/files/patch-agent__mibgroup__agent__extend.c
new file mode 100644
index 000000000000..b3aecfacb6bb
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent__mibgroup__agent__extend.c
@@ -0,0 +1,13 @@
+--- ./agent/mibgroup/agent/extend.c.orig 2011-09-28 00:53:47.000000000 -0400
++++ ./agent/mibgroup/agent/extend.c 2012-04-26 22:32:10.000000000 -0400
+@@ -1380,6 +1380,10 @@
+ * Determine which line we've been asked for....
+ */
+ line_idx = *table_info->indexes->next_variable->val.integer;
++ if (line_idx < 1 || line_idx > extension->numlines) {
++ netsnmp_set_request_error(reqinfo, request, SNMP_NOSUCHINSTANCE);
++ continue;
++ }
+ cp = extension->lines[line_idx-1];
+
+ /*