aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/net-snmp
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2015-09-09 19:36:49 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2015-09-09 19:36:49 +0000
commitdec73d3958de19d5b166ca74100be6a7bfebc105 (patch)
treef22f54b4d9fb30bd55eddbce0ebf69d6e3072c42 /net-mgmt/net-snmp
parent1c3f2614cf15a0cf0f86a5058f8ea6428e41ae79 (diff)
downloadports-dec73d3958de19d5b166ca74100be6a7bfebc105.tar.gz
ports-dec73d3958de19d5b166ca74100be6a7bfebc105.zip
Notes
Diffstat (limited to 'net-mgmt/net-snmp')
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/net-snmp/files/patch-agent_mibgroup_ucd-snmp_diskio.c54
2 files changed, 55 insertions, 1 deletions
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index 3a7916037e6f..f262ec436340 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= snmp
PORTVERSION= 5.7.3
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net-mgmt ipv6
MASTER_SITES= SF/net-${PORTNAME}/net-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= net-
diff --git a/net-mgmt/net-snmp/files/patch-agent_mibgroup_ucd-snmp_diskio.c b/net-mgmt/net-snmp/files/patch-agent_mibgroup_ucd-snmp_diskio.c
new file mode 100644
index 000000000000..c4e4f671cc94
--- /dev/null
+++ b/net-mgmt/net-snmp/files/patch-agent_mibgroup_ucd-snmp_diskio.c
@@ -0,0 +1,54 @@
+--- agent/mibgroup/ucd-snmp/diskio.c.orig 2014-12-08 20:23:22 UTC
++++ agent/mibgroup/ucd-snmp/diskio.c
+@@ -944,14 +944,14 @@ var_diskio(struct variable * vp,
+ return (u_char *) stat->dinfo->devices[indx].device_name;
+ case DISKIO_NREAD:
+ #if HAVE_DEVSTAT_GETDEVS
+- long_ret = (signed long) stat->dinfo->devices[indx].bytes[DEVSTAT_READ];
++ long_ret = (signed long) stat->dinfo->devices[indx].bytes[DEVSTAT_READ] & 0xFFFFFFFF;
+ #else
+ long_ret = (signed long) stat->dinfo->devices[indx].bytes_read;
+ #endif
+ return (u_char *) & long_ret;
+ case DISKIO_NWRITTEN:
+ #if HAVE_DEVSTAT_GETDEVS
+- long_ret = (signed long) stat->dinfo->devices[indx].bytes[DEVSTAT_WRITE];
++ long_ret = (signed long) stat->dinfo->devices[indx].bytes[DEVSTAT_WRITE] & 0xFFFFFFFF;
+ #else
+ long_ret = (signed long) stat->dinfo->devices[indx].bytes_written;
+ #endif
+@@ -959,7 +959,7 @@ var_diskio(struct variable * vp,
+ case DISKIO_NREADX:
+ *var_len = sizeof(struct counter64);
+ #if HAVE_DEVSTAT_GETDEVS
+- longlong_ret = stat->dinfo->devices[indx].bytes[DEVSTAT_READ];
++ longlong_ret = stat->dinfo->devices[indx].bytes[DEVSTAT_READ] & 0xFFFFFFFF;
+ #else
+ longlong_ret = stat->dinfo->devices[indx].bytes_read;
+ #endif
+@@ -969,7 +969,7 @@ var_diskio(struct variable * vp,
+ case DISKIO_NWRITTENX:
+ *var_len = sizeof(struct counter64);
+ #if HAVE_DEVSTAT_GETDEVS
+- longlong_ret = stat->dinfo->devices[indx].bytes[DEVSTAT_WRITE];
++ longlong_ret = stat->dinfo->devices[indx].bytes[DEVSTAT_WRITE] & 0xFFFFFFFF;
+ #else
+ longlong_ret = stat->dinfo->devices[indx].bytes_written;
+ #endif
+@@ -978,14 +978,14 @@ var_diskio(struct variable * vp,
+ return (u_char *) & c64_ret;
+ case DISKIO_READS:
+ #if HAVE_DEVSTAT_GETDEVS
+- long_ret = (signed long) stat->dinfo->devices[indx].operations[DEVSTAT_READ];
++ long_ret = (signed long) stat->dinfo->devices[indx].operations[DEVSTAT_READ] & 0xFFFFFFFF;
+ #else
+ long_ret = (signed long) stat->dinfo->devices[indx].num_reads;
+ #endif
+ return (u_char *) & long_ret;
+ case DISKIO_WRITES:
+ #if HAVE_DEVSTAT_GETDEVS
+- long_ret = (signed long) stat->dinfo->devices[indx].operations[DEVSTAT_WRITE];
++ long_ret = (signed long) stat->dinfo->devices[indx].operations[DEVSTAT_WRITE] & 0xFFFFFFFF;
+ #else
+ long_ret = (signed long) stat->dinfo->devices[indx].num_writes;
+ #endif