aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netdisco/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-06-13 11:43:07 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-06-13 11:43:07 +0000
commit5449bb6104b58fb806f8ab9dd52c0c1c968d0217 (patch)
tree455982bb8bf13d07c5c8f14efed2734169aa1527 /net-mgmt/netdisco/Makefile
parente62948168e5f3d4d4d5dc00a7dc5039b16117ee9 (diff)
downloadports-5449bb6104b58fb806f8ab9dd52c0c1c968d0217.tar.gz
ports-5449bb6104b58fb806f8ab9dd52c0c1c968d0217.zip
Notes
Diffstat (limited to 'net-mgmt/netdisco/Makefile')
-rw-r--r--net-mgmt/netdisco/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/net-mgmt/netdisco/Makefile b/net-mgmt/netdisco/Makefile
index e2c6ce5e80c9..3867bd375047 100644
--- a/net-mgmt/netdisco/Makefile
+++ b/net-mgmt/netdisco/Makefile
@@ -2,24 +2,23 @@
# $FreeBSD$
PORTNAME= netdisco
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= net-mgmt www
MASTER_SITES= SF
MAINTAINER= dgeo@centrale-marseille.fr
COMMENT= Web-based network management tool for moderate to large networks
-OPTIONS_DEFINE= GRAPHVIZ OUIDL MIBS
+OPTIONS_DEFINE= GRAPHVIZ MIBS
OPTIONS_DEFAULT=GRAPHVIZ MIBS
MIBS_DESC= Depend on net-mgmt/netdisco-mibs
-OUIDL_DESC= Download oui.txt file
GRAPHVIZ_DESC= Install GraphViz for network map support
RUN_DEPENDS+= ${APACHE_PKGNAMEPREFIX}mod_perl2>=0:${PORTSDIR}/www/mod_perl2 \
p5-Apache-DBI>=0:${PORTSDIR}/www/p5-Apache-DBI \
p5-libapreq2>=0:${PORTSDIR}/www/p5-libapreq2 \
p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
- p5-SNMP-Info>=0:${PORTSDIR}/net-mgmt/p5-SNMP-Info \
+ p5-SNMP-Info>=3.01:${PORTSDIR}/net-mgmt/p5-SNMP-Info \
p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason \
p5-DB_File-Lock>=0:${PORTSDIR}/devel/p5-DB_File-Lock \
p5-Apache-Session>=0:${PORTSDIR}/www/p5-Apache-Session \
@@ -44,7 +43,7 @@ NETDISCO_RUNDIR=/var/run
NETDISCO_DBDIR= /var/db/netdisco
SUB_FILES= pkg-message
-SUB_LIST= NETDISCO_DBDIR=${NETDISCO_DBDIR} NETDISCO_RUNDIR=${NETDISCO_RUNDIR} NETDISCO_USER=${USERS}
+SUB_LIST= NETDISCO_DBDIR=${NETDISCO_DBDIR} NETDISCO_RUNDIR=${NETDISCO_RUNDIR} NETDISCO_USER=${USERS} NETDISCO_GROUP=${GROUPS}
PLIST_SUB= NETDISCO_DBDIR=${NETDISCO_DBDIR} NETDISCO_RUNDIR=${NETDISCO_RUNDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -86,12 +85,6 @@ RUN_DEPENDS+= p5-Graph>=0:${PORTSDIR}/math/p5-Graph \
p5-GraphViz>=0:${PORTSDIR}/graphics/p5-GraphViz
.endif
-.if ${PORT_OPTIONS:MOUIDL}
-PLIST_SUB+= OUIDL=""
-.else
-PLIST_SUB+= OUIDL="@comment "
-.endif
-
pre-install:
. for i in ${ALTER_FILES}
@(${MV} ${WRKSRC}/${i}.bak ${WRKSRC}/${i} 2>/dev/null || ${TRUE})
@@ -159,10 +152,6 @@ do-install:
fi)
. endif
-. if ${PORT_OPTIONS:MOUIDL}
- ${FETCH_CMD} -q -o ${DATADIR}/oui.txt http://standards.ieee.org/develop/regauth/oui/oui.txt
-. endif
-
post-install:
@${CAT} ${PKGMESSAGE}