aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netdot/files
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2012-03-07 20:36:31 +0000
committerAnton Berezin <tobez@FreeBSD.org>2012-03-07 20:36:31 +0000
commit87bbfe30bf4c6e4814af9225f483a2ad0b5a63e8 (patch)
tree3e941e23e0d1f784ca50a0ba47d0ccc7af0bddb5 /net-mgmt/netdot/files
parent45185299d9d2555078c9d00063ad58fa22525177 (diff)
downloadports-87bbfe30bf4c6e4814af9225f483a2ad0b5a63e8.tar.gz
ports-87bbfe30bf4c6e4814af9225f483a2ad0b5a63e8.zip
Notes
Diffstat (limited to 'net-mgmt/netdot/files')
-rw-r--r--net-mgmt/netdot/files/patch-Default.conf11
-rw-r--r--net-mgmt/netdot/files/patch-etc-Makefile12
-rw-r--r--net-mgmt/netdot/files/patch-etc-netdot_apache2_local.conf12
-rw-r--r--net-mgmt/netdot/files/pkg-install.in30
-rw-r--r--net-mgmt/netdot/files/pkg-message.in24
5 files changed, 89 insertions, 0 deletions
diff --git a/net-mgmt/netdot/files/patch-Default.conf b/net-mgmt/netdot/files/patch-Default.conf
new file mode 100644
index 000000000000..96cf50101a1a
--- /dev/null
+++ b/net-mgmt/netdot/files/patch-Default.conf
@@ -0,0 +1,11 @@
+--- etc/Default.conf.orig 2011-06-18 23:45:16.519629047 +0100
++++ etc/Default.conf 2011-06-19 00:34:52.153707362 +0100
+@@ -84,7 +84,7 @@
+ # should contain the binaries themselves, e.g. if "which mysql" gives
+ # "/usr/local/mysql/bin/mysql", $DB_HOME should be "/usr/local/mysql"
+
+-DB_HOME => '/usr',
++DB_HOME => '%%LOCALPREFIX%%',
+
+ # Set DB_DBA to the name of a DB user with permission to create new databases
+ # Set DB_DBA_PASSWORD to that user's password (if you don't, you'll be prompted
diff --git a/net-mgmt/netdot/files/patch-etc-Makefile b/net-mgmt/netdot/files/patch-etc-Makefile
new file mode 100644
index 000000000000..00b81b7f2287
--- /dev/null
+++ b/net-mgmt/netdot/files/patch-etc-Makefile
@@ -0,0 +1,12 @@
+--- etc/Makefile.orig 2012-02-26 18:34:11.000000000 +0000
++++ etc/Makefile 2012-02-26 18:34:17.000000000 +0000
+@@ -8,9 +8,3 @@
+
+ all:
+ $(substitute)
+- if ! test -r $(PREFIX)/$(DIR)/Site.conf; then \
+- $(SED) -r $(REPLACEMENT_EXPRESSIONS) Site.conf \
+- > Site.conf.tmp;\
+- install -m $(FMOD) Site.conf.tmp $(PREFIX)/$(DIR)/Site.conf;\
+- rm -rf Site.conf.tmp;\
+- fi;
diff --git a/net-mgmt/netdot/files/patch-etc-netdot_apache2_local.conf b/net-mgmt/netdot/files/patch-etc-netdot_apache2_local.conf
new file mode 100644
index 000000000000..ed9ee147fc02
--- /dev/null
+++ b/net-mgmt/netdot/files/patch-etc-netdot_apache2_local.conf
@@ -0,0 +1,12 @@
+--- etc/netdot_apache2_local.conf.orig 2011-06-18 23:08:29.960472329 +0100
++++ etc/netdot_apache2_local.conf 2011-06-18 23:08:56.032350612 +0100
+@@ -22,7 +22,8 @@
+
+ # Uncomment this next line if you get errors from libapreq2
+ # about an 'undefined symbol'
+-LoadModule apreq_module /usr/lib/apache2/modules/mod_apreq2.so
++LoadModule perl_module libexec/apache22/mod_perl.so
++LoadModule apreq_module libexec/apache22/mod_apreq2.so
+
+ <Perl>
+ use lib qw( <<Make:PREFIX>>/lib );
diff --git a/net-mgmt/netdot/files/pkg-install.in b/net-mgmt/netdot/files/pkg-install.in
new file mode 100644
index 000000000000..a922f1f0b018
--- /dev/null
+++ b/net-mgmt/netdot/files/pkg-install.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# This script sets ownership for various files required by the netdot
+# package.
+#
+
+WWWDIR=%%WWWDIR%%
+WWWOWN=%%WWWOWN%%
+WWWGRP=%%WWWGRP%%
+CHOWN=%%CHOWN%%
+CHMOD=%%CHMOD%%
+
+case $2 in
+POST-INSTALL)
+ for changedir in \
+ doc/manual htdocs/img/graphs htdocs/masondata \
+ htdocs/masondata/cache htdocs/masondata/obj \
+ tmp tmp/sessions tmp/sessions/locks \
+ export/bind export/cacti export/dhcpd \
+ export/docs export/ethers export/nagios \
+ export/rancid export/sysmon \
+ ; do
+ ${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${changedir}
+ ${CHMOD} 0755 ${WWWDIR}/${changedir}
+ done
+
+ # Restrict world read access to these dirs
+ ${CHMOD} 0750 ${WWWDIR}/tmp
+ ${CHMOD} 0750 ${WWWDIR}/htdocs/img/graphs
+esac
diff --git a/net-mgmt/netdot/files/pkg-message.in b/net-mgmt/netdot/files/pkg-message.in
new file mode 100644
index 000000000000..8119db34985e
--- /dev/null
+++ b/net-mgmt/netdot/files/pkg-message.in
@@ -0,0 +1,24 @@
+###############################################################################
+1. If you do not already have a Site.conf configuration file, you will need
+to create one. Simply copy %%WWWDIR%%/etc/Default.conf
+to Site.conf and edit to suit.
+
+2. New installations will need to run the following commands:
+
+cd %%WWWDIR%%/bin/
+./initdb initdb
+
+This command assumes that you have created a customised Site.conf
+configuration file.
+
+3. Please see %%WWWDIR%%/etc/netdot.cron
+in the root directory of the installation package for suggestions on
+what should be added to your server's crontab.
+
+4. Suggested Apache configuration files are available here:
+
+%%WWWDIR%%/etc/netdot_apache2_local.conf
+%%WWWDIR%%/etc/netdot_apache2_ldap.conf
+
+Note that any changes to Site.conf require an apache reload.
+###############################################################################