aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netsaint
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-08-18 16:15:10 +0000
commitefb928619b234d49b326a13f59a6e2ee354bf902 (patch)
treec62bd82140831e81442480b9cefc699e0c08f08d /net-mgmt/netsaint
parentdfc14c855f8ec76c9bd42bc90e325a160cc5d6cf (diff)
downloadports-efb928619b234d49b326a13f59a6e2ee354bf902.tar.gz
ports-efb928619b234d49b326a13f59a6e2ee354bf902.zip
Notes
Diffstat (limited to 'net-mgmt/netsaint')
-rw-r--r--net-mgmt/netsaint/Makefile21
-rw-r--r--net-mgmt/netsaint/files/patch-ad19
2 files changed, 8 insertions, 32 deletions
diff --git a/net-mgmt/netsaint/Makefile b/net-mgmt/netsaint/Makefile
index 9a042d807eae..05c660ff4a87 100644
--- a/net-mgmt/netsaint/Makefile
+++ b/net-mgmt/netsaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= netsaint
PORTVERSION= 0.0.7
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://netsaint.sourceforge.net/download/ \
@@ -18,18 +18,16 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} netsaint-graphics.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Extremely powerful network monitoring system
-LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd
RUN_DEPENDS= ${LOCALBASE}/libexec/netsaint/check_netsaint:${PORTSDIR}/net/netsaint-plugins
-USE_GETOPT_LONG=yes
-GNU_CONFIGURE= yes
USE_PERL5= yes
-CPPFLAGS= -I${LOCALBASE}/include
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lgd"
+USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-command-user=netsaint \
--with-command-grp=www \
+ --with-gd-lib=${LOCALBASE}/lib \
+ --with-gd-inc=${LOCALBASE}/include \
--with-netsaint-user=netsaint \
--with-netsaint-grp=netsaint \
--sbindir=${PREFIX}/share/netsaint/sbin \
@@ -37,6 +35,7 @@ CONFIGURE_ARGS= --with-command-user=netsaint \
--datadir=${PREFIX}/share/netsaint \
--sysconfdir=${PREFIX}/etc/netsaint \
--localstatedir=${PREFIX}/var/netsaint
+INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
.if defined(WITH_MYSQL)
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
@@ -53,18 +52,14 @@ CONFIGURE_ARGS+=--with-pgsql-lib=${LOCALBASE}/pgsql \
--with-pgsql-xdata
.endif
-INSTALL_TARGET= all install config install-config install-daemoninit install-commandmode
-
pre-fetch:
@${SH} ${SCRIPTDIR}/checkps
pre-install:
@PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-BSDIMAGES= bsd_logofullsize.gif bsd_sblogo.gif
-
post-install:
-.for i in ${BSDIMAGES}
+.for i in bsd_logofullsize.gif bsd_sblogo.gif
${INSTALL_DATA} ${WRKDIR}/netsaint-0.0.7b6/html/images/$i ${PREFIX}/share/${PORTNAME}/images/
.endfor
diff --git a/net-mgmt/netsaint/files/patch-ad b/net-mgmt/netsaint/files/patch-ad
index 6d8038c4bd21..aeb6f67857ca 100644
--- a/net-mgmt/netsaint/files/patch-ad
+++ b/net-mgmt/netsaint/files/patch-ad
@@ -21,22 +21,3 @@
fi
fi
for ac_site_file in $CONFIG_SITE; do
-@@ -1298,6 +1298,9 @@
- LDFLAGS="${LDFLAGS} -L${withval}"
- LD_RUN_PATH="${withval}${LD_RUN_PATH:+:}${LD_RUN_PATH}"
-
-+else
-+ LDFLAGS="${LDFLAGS} -L/usr/local/lib"
-+ LD_RUN_PATH="/usr/local/ib${LD_RUN_PATH:+:}${LD_RUN_PATH}"
- fi
-
- # Check whether --with-gd-inc or --without-gd-inc was given.
-@@ -1305,6 +1308,8 @@
- withval="$with_gd_inc"
-
- CFLAGS="${CFLAGS} -I${withval}"
-+else
-+ CFLAGS="${CFLAGS} -I/usr/local/include/gd"
-
- fi
-