aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nettop/Makefile
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 14:12:50 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2006-04-21 14:12:50 +0000
commit13a81d7fbf67085651e46e22b3a21eb95a03887b (patch)
tree53be30569df1b1d67358b3f1aab79b53cbb1faa3 /net-mgmt/nettop/Makefile
parenta4de7e3450130c4bb7efa0f447fbd89045a7739d (diff)
downloadports-13a81d7fbf67085651e46e22b3a21eb95a03887b.tar.gz
ports-13a81d7fbf67085651e46e22b3a21eb95a03887b.zip
Notes
Diffstat (limited to 'net-mgmt/nettop/Makefile')
-rw-r--r--net-mgmt/nettop/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mgmt/nettop/Makefile b/net-mgmt/nettop/Makefile
new file mode 100644
index 000000000000..11b4e40ef09f
--- /dev/null
+++ b/net-mgmt/nettop/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: nettop
+# Date created: 21 April 2006
+# Whom: Yen-Ming Lee <leeym@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nettop
+PORTVERSION= 0.2.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://srparish.net/scripts/
+
+MAINTAINER= leeym@FreeBSD.org
+COMMENT= A program which looks like top, but is for network packets
+
+LIB_DEPENDS= slang.1:${PORTSDIR}/devel/libslang
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-slang-libraries=${LOCALBASE}/lib \
+ --with-slang-includes=${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-lcurses"
+
+PLIST_FILES= bin/nettop
+PORTDOCS= README THANKS ChangeLog
+
+post-patch:
+.if !exists(/usr/lib/libpthread.so)
+ ${REINPLACE_CMD} -e 's/lpthread/lc_r/g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>