aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/netxms/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-24 06:22:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-24 06:22:20 +0000
commitf6e625d36563a216f2c8e2599e25aeed893eeaf7 (patch)
tree27985af413f4c103784bc5367b18d994eaf54dd0 /net-mgmt/netxms/Makefile
parentc15071922e622234fa0334e4096cc3d87723f916 (diff)
Notes
Diffstat (limited to 'net-mgmt/netxms/Makefile')
-rw-r--r--net-mgmt/netxms/Makefile84
1 files changed, 21 insertions, 63 deletions
diff --git a/net-mgmt/netxms/Makefile b/net-mgmt/netxms/Makefile
index bd38cd33bcfb..1d17a51b5742 100644
--- a/net-mgmt/netxms/Makefile
+++ b/net-mgmt/netxms/Makefile
@@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= netxms
-PORTVERSION= 1.0.13
-PORTREVISION= 2
+PORTVERSION= 1.2.13
CATEGORIES= net-mgmt
-MASTER_SITES= http://www.netxms.org/download/
+MASTER_SITES= http://www.netxms.org/download/ \
+ http://www.netxms.org/download/archive/
MAINTAINER= 5u623l20@gmail.com
COMMENT= Network monitoring system
@@ -13,18 +13,15 @@ COMMENT= Network monitoring system
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-PORTSCOUT= limit:^1\.0\.[0-9]* # 1.1.X branch is Development Branch
-
-OPTIONS_DEFINE= SERVER CLIENT AGENT NXHTTPD MYSQL PGSQL SQLITE ODBC
+OPTIONS_DEFINE= SERVER CLIENT AGENT
OPTIONS_DEFAULT= CLIENT AGENT
+SERVER_ENABLED_MODULES= MYSQL
+SERVER_DISABLED_MODULES= PGSQL SQLITE ODBC
+OPTIONS_SINGLE= SERVER
+OPTIONS_SINGLE_SERVER= ${SERVER_ENABLED_MODULES} ${SERVER_DISABLED_MODULES}
SERVER_DESC= Install NetXMS server & agent
CLIENT_DESC= Install NetXMS client
AGENT_DESC= Install NetXMS agent
-NXHTTPD_DESC= Install web-interface
-
-BROKEN= Does not fetch
-DEPRECATED= Broken for more than 6 month
-EXPIRATION_DATE= 2014-02-27
NO_PACKAGE= yes
@@ -37,44 +34,29 @@ USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NETXMS_OWN= netxms
-NETXMS_GRP= netxms
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
+USERS= netxms
+GROUPS= netxms
-SUB_FILES= pkg-install pkg-deinstall
+.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSERVER} || ${PORT_OPTIONS:MAGENT} || ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MNXHTTPD}
+.if ${PORT_OPTIONS:MSERVER} || ${PORT_OPTIONS:MAGENT} || ${PORT_OPTIONS:MCLIENT}
PLIST_SUB+= NXCPTEST=""
-LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS+= libexpat.so:${PORTSDIR}/textproc/expat2
.else
PLIST_SUB+= NXCPTEST="@comment "
.endif
-.if ${PORT_OPTIONS:MSERVER} || ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MNXHTTPD}
+.if ${PORT_OPTIONS:MSERVER} || ${PORT_OPTIONS:MCLIENT}
PLIST_SUB+= NXMAP=""
.else
PLIST_SUB+= NXMAP="@comment "
.endif
-.if ${PORT_OPTIONS:MCLIENT} || ${PORT_OPTIONS:MNXHTTPD}
-PLIST_SUB+= NXCL=""
-.else
-PLIST_SUB+= NXCL="@comment "
-.endif
-
.if ! ${PORT_OPTIONS:MSERVER}
PLIST_SUB+= SERVER="@comment "
-.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || ${PORT_OPTIONS:MSQLITE} || ${PORT_OPTIONS:MODBC}
-IGNORE= is useless database support without a SERVER. Please (re)run 'make config' and choose SERVER with database
-.endif
.else
CONFIGURE_ARGS+= --with-server
PLIST_SUB+= SERVER=""
-.if ! ${PORT_OPTIONS:MMYSQL} && ! ${PORT_OPTIONS:MPGSQL} && ! ${PORT_OPTIONS:MSQLITE} && ! ${PORT_OPTIONS:MODBC}
-IGNORE= is useless without a database. Please (re)run 'make config' and choose database support
-.else
USE_RC_SUBR+= netxmsd
.if ${PORT_OPTIONS:MAGENT}
PLIST_SUB+= AGENT="@comment "
@@ -82,7 +64,6 @@ PLIST_SUB+= AGENT="@comment "
USE_RC_SUBR+= nxagentd
.endif
.endif
-.endif
.if ${PORT_OPTIONS:MCLIENT}
CONFIGURE_ARGS+= --with-client
@@ -99,15 +80,6 @@ PLIST_SUB+= AGENT=""
PLIST_SUB+= AGENT="@comment "
.endif
-.if ${PORT_OPTIONS:MNXHTTPD}
-USE_RC_SUBR+= nxhttpd
-CONFIGURE_ARGS+= --with-nxhttpd
-PLIST_SUB+= NXHTTPD=""
-LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-.else
-PLIST_SUB+= NXHTTPD="@comment "
-.endif
-
.if ${PORT_OPTIONS:MMYSQL}
CONFIGURE_ARGS+= --with-mysql
PLIST_SUB+= MYSQL=""
@@ -135,35 +107,21 @@ PLIST_SUB+= SQLITE="@comment "
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+= --with-odbc
PLIST_SUB+= ODBC=""
-LIB_DEPENDS+= odbc.2:${PORTSDIR}/databases/unixODBC
+LIB_DEPENDS+= libodbc.so:${PORTSDIR}/databases/unixODBC
.else
PLIST_SUB+= ODBC="@comment "
.endif
-pre-install:
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} PRE-INSTALL
+post-install:
.if ${PORT_OPTIONS:MSERVER}
-.if !exists(${PREFIX}/etc/netxmsd.conf-dist)
- ${INSTALL_DATA} ${WRKSRC}/contrib/netxmsd.conf-dist ${PREFIX}/etc
- ${CHOWN} ${NETXMS_OWN}:${NETXMS_GRP} ${PREFIX}/etc/netxmsd.conf-dist
+.if !exists(${STAGEDIR}${PREFIX}/etc/netxmsd.conf-dist)
+ ${CP} ${WRKSRC}/contrib/netxmsd.conf-dist ${STAGEDIR}${PREFIX}/etc/
.endif
.endif
.if ${PORT_OPTIONS:MSERVER} || ${PORT_OPTIONS:MAGENT}
-.if !exists(${PREFIX}/etc/nxagentd.conf-dist)
- ${INSTALL_DATA} ${WRKSRC}/contrib/nxagentd.conf-dist ${PREFIX}/etc
- ${CHOWN} ${NETXMS_OWN}:${NETXMS_GRP} ${PREFIX}/etc/nxagentd.conf-dist
+.if !exists(${STAGEDIR}${PREFIX}/etc/nxagentd.conf-dist)
+ ${CP} ${WRKSRC}/contrib/nxagentd.conf-dist ${STAGEDIR}${PREFIX}/etc/
.endif
.endif
-.if ${PORT_OPTIONS:MNXHTTPD}
-.if !exists(${PREFIX}/etc/nxhttpd.conf-dist)
- ${INSTALL_DATA} ${WRKSRC}/contrib/nxhttpd.conf-dist ${PREFIX}/etc
- ${CHOWN} ${NETXMS_OWN}:${NETXMS_GRP} ${PREFIX}/etc/nxhttpd.conf-dist
-.endif
-.endif
-
-post-install:
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PORTNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>