aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nfdump
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-01-23 01:11:38 +0000
committerWen Heping <wen@FreeBSD.org>2010-01-23 01:11:38 +0000
commit68064f712e08c4b678375deb6e4a0d4e4a271e13 (patch)
tree0640d08e5dad7daed87b8b2535e57b0102a0da64 /net-mgmt/nfdump
parentf85b2f40f6cd84e399ed3ebe1d686f5f9a953437 (diff)
downloadports-68064f712e08c4b678375deb6e4a0d4e4a271e13.tar.gz
ports-68064f712e08c4b678375deb6e4a0d4e4a271e13.zip
Notes
Diffstat (limited to 'net-mgmt/nfdump')
-rw-r--r--net-mgmt/nfdump/Makefile15
-rw-r--r--net-mgmt/nfdump/distinfo6
-rw-r--r--net-mgmt/nfdump/files/patch-Makefile.in16
-rw-r--r--net-mgmt/nfdump/files/patch-bin_ft2nfdump.c (renamed from net-mgmt/nfdump/files/patch-ft2nfdump.c)8
-rw-r--r--net-mgmt/nfdump/files/patch-configure4
5 files changed, 14 insertions, 35 deletions
diff --git a/net-mgmt/nfdump/Makefile b/net-mgmt/nfdump/Makefile
index 532a94e2d5a2..02c782907617 100644
--- a/net-mgmt/nfdump/Makefile
+++ b/net-mgmt/nfdump/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nfdump
-PORTVERSION= 1.5.8
+PORTVERSION= 1.6
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
@@ -23,20 +23,15 @@ OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
.include <bsd.port.pre.mk>
-#for compatibility
-#
-.ifndef(WITHOUT_NFDUMP14_SUPPORT)
-CONFIGURE_ARGS= --enable-compat14
-.endif
-
PLIST_FILES= bin/nfcapd bin/nfdump bin/nfreplay bin/nfexpire
MAN1= nfcapd.1 nfdump.1 nfreplay.1 nfexpire.1
+MAN1+= nfprofile.1 ft2nfdump.1 sfcapd.1
PORTDOCS= AUTHORS ChangeLog INSTALL README
.if defined(WITH_NFPROFILE)
CONFIGURE_ARGS+= --enable-nfprofile --with-rrdpath=${LOCALBASE}
PLIST_FILES+= bin/nfprofile
-MAN1+= nfprofile.1
+#MAN1+= nfprofile.1
BUILD_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool
RUN_DEPENDS+= ${BUILD_DEPENDS}
.endif
@@ -46,14 +41,14 @@ RUN_DEPENDS+= ${BUILD_DEPENDS}
BUILD_DEPENDS+= flow-cat:${PORTSDIR}/net-mgmt/flow-tools
CONFIGURE_ARGS+= --enable-ftconv --with-ftpath=${LOCALBASE}
PLIST_FILES+= bin/ft2nfdump
-MAN1+= ft2nfdump.1
+#MAN1+= ft2nfdump.1
.endif
#sflow capture support
.if defined(WITH_SFLOW)
CONFIGURE_ARGS+= --enable-sflow
PLIST_FILES+= bin/sfcapd
-MAN1+= sfcapd.1
+#MAN1+= sfcapd.1
.endif
.if !defined(NOPORTDOCS)
diff --git a/net-mgmt/nfdump/distinfo b/net-mgmt/nfdump/distinfo
index 42cb83af4956..6e36a0eb93b0 100644
--- a/net-mgmt/nfdump/distinfo
+++ b/net-mgmt/nfdump/distinfo
@@ -1,3 +1,3 @@
-MD5 (nfdump-1.5.8.tar.gz) = f314513652df18259f8303c542918cbb
-SHA256 (nfdump-1.5.8.tar.gz) = 3fbfb874377316cf322cf13cfab667207fe78e0910bbc82ba012e3a77c00de36
-SIZE (nfdump-1.5.8.tar.gz) = 331279
+MD5 (nfdump-1.6.tar.gz) = 772405b071202d65869a8b0987db60e5
+SHA256 (nfdump-1.6.tar.gz) = 8ef140ed68e4232864602f0093cb7e225996fd83068822bf3dc569cb5c0309b4
+SIZE (nfdump-1.6.tar.gz) = 494131
diff --git a/net-mgmt/nfdump/files/patch-Makefile.in b/net-mgmt/nfdump/files/patch-Makefile.in
deleted file mode 100644
index 29a56d6b2279..000000000000
--- a/net-mgmt/nfdump/files/patch-Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.in.orig
-+++ Makefile.in
-@@ -108,8 +108,8 @@
- test -d $(MANDIR)/man1 || install -d -o root -g bin -m 755 $(MANDIR)/man1
- for file in $(OBJECTS); do \
- if [ -f $$file.1 ]; then \
-- $(INSTALL) -o root -g bin -m 755 $$file $(PREFIX)/bin ; \
-- $(INSTALL) -o root -g bin -m 644 $$file.1 $(MANDIR)/man1 ; \
-+ $(BSD_INSTALL_PROGRAM) $$file $(PREFIX)/bin ; \
-+ $(BSD_INSTALL_MAN) $$file.1 $(MANDIR)/man1 ; \
- fi \
- done;
-
diff --git a/net-mgmt/nfdump/files/patch-ft2nfdump.c b/net-mgmt/nfdump/files/patch-bin_ft2nfdump.c
index 1910d7b254a4..4727835aa35c 100644
--- a/net-mgmt/nfdump/files/patch-ft2nfdump.c
+++ b/net-mgmt/nfdump/files/patch-bin_ft2nfdump.c
@@ -1,10 +1,10 @@
$FreeBSD$
---- ft2nfdump.c.orig
-+++ ft2nfdump.c
-@@ -66,7 +66,7 @@
- #include "nffile.h"
+--- bin/ft2nfdump.c.orig
++++ bin/ft2nfdump.c
+@@ -68,7 +68,7 @@
+ #include "nfx.h"
#include "launch.h"
-#include "ftbuild.h"
diff --git a/net-mgmt/nfdump/files/patch-configure b/net-mgmt/nfdump/files/patch-configure
index 28286602f934..56aa3b848e7a 100644
--- a/net-mgmt/nfdump/files/patch-configure
+++ b/net-mgmt/nfdump/files/patch-configure
@@ -3,7 +3,7 @@ $FreeBSD$
--- configure.orig
+++ configure
-@@ -2843,7 +2843,7 @@
+@@ -4011,7 +4011,7 @@
fi
if test -d "$WHERE_FTPATH"; then
@@ -12,7 +12,7 @@ $FreeBSD$
{ { echo "$as_me:$LINENO: error: ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH" >&5
echo "$as_me: error: ftlib.h file not found in flow-tools directory '$WHERE_FTPATH'. Use --with-ftpath=PATH" >&2;}
{ (exit 1); exit 1; }; }
-@@ -2853,7 +2853,7 @@
+@@ -4021,7 +4021,7 @@
echo "$as_me: error: libft.a not found in flow-tools directory '$WHERE_FTPATH'. Build flow tools first" >&2;}
{ (exit 1); exit 1; }; }
fi