aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nfdump
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-11-01 09:09:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-11-01 09:09:36 +0000
commitaddc18db1cd58259c2784874d6768a9ce19ffe15 (patch)
tree67d595e09f104ae35e2e41a531ba1baa6a98e1cd /net-mgmt/nfdump
parent6a41359b838eeb3e875a8cde7269863824dc900c (diff)
downloadports-addc18db1cd58259c2784874d6768a9ce19ffe15.tar.gz
ports-addc18db1cd58259c2784874d6768a9ce19ffe15.zip
Notes
Diffstat (limited to 'net-mgmt/nfdump')
-rw-r--r--net-mgmt/nfdump/Makefile20
-rw-r--r--net-mgmt/nfdump/distinfo6
-rw-r--r--net-mgmt/nfdump/files/patch-Makefile.in44
-rw-r--r--net-mgmt/nfdump/files/patch-ft2nfdump.c14
4 files changed, 37 insertions, 47 deletions
diff --git a/net-mgmt/nfdump/Makefile b/net-mgmt/nfdump/Makefile
index cb3d9ef3c083..926e74554bec 100644
--- a/net-mgmt/nfdump/Makefile
+++ b/net-mgmt/nfdump/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nfdump
-PORTVERSION= 1.5
+PORTVERSION= 1.5.2
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,15 +16,18 @@ COMMENT= Command-line tools to collect and process NetFlow data
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+#flow-tools support
+OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off \
+ SFLOW "Build sflow collector daemon also" off
+
+.include <bsd.port.pre.mk>
+
#for compatibility
#
.ifndef(WITHOUT_NFDUMP14_SUPPORT)
CONFIGURE_ARGS= --enable-compat14
.endif
-#flow-tools support
-OPTIONS= FT2NFDUMP "With Flow-tools to nfdump converter" off
-
-.include <bsd.port.pre.mk>
PLIST_FILES= bin/nfcapd bin/nfdump bin/nfprofile bin/nfreplay bin/nfclean.pl
MAN1= nfcapd.1 nfdump.1 nfprofile.1 nfreplay.1
@@ -38,6 +41,13 @@ PLIST_FILES+= bin/ft2nfdump
MAN1+= ft2nfdump.1
.endif
+#sflow capture support
+.if defined(WITH_SFLOW)
+CONFIGURE_ARGS+= --enable-sflow
+PLIST_FILES+= bin/sfcapd
+MAN1+= sfcapd.1
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
diff --git a/net-mgmt/nfdump/distinfo b/net-mgmt/nfdump/distinfo
index 632e71d4ea5d..a416dda6611e 100644
--- a/net-mgmt/nfdump/distinfo
+++ b/net-mgmt/nfdump/distinfo
@@ -1,3 +1,3 @@
-MD5 (nfdump-1.5.tar.gz) = 47a823b88210d979ad36a55bc4eebcae
-SHA256 (nfdump-1.5.tar.gz) = d1c70b0f7340d1c1bdc016132310a7656f085d3c84f20eb9a6eff646344fb48d
-SIZE (nfdump-1.5.tar.gz) = 187689
+MD5 (nfdump-1.5.2.tar.gz) = 4447c3338cc7eae6eee5288889f27d28
+SHA256 (nfdump-1.5.2.tar.gz) = d86d5ce09a67913fba93ca19321d1c20edcbbd4139b2b87d79b663d983dd1ee5
+SIZE (nfdump-1.5.2.tar.gz) = 224287
diff --git a/net-mgmt/nfdump/files/patch-Makefile.in b/net-mgmt/nfdump/files/patch-Makefile.in
index b0be54630a35..ff2f4e15cc62 100644
--- a/net-mgmt/nfdump/files/patch-Makefile.in
+++ b/net-mgmt/nfdump/files/patch-Makefile.in
@@ -3,38 +3,18 @@ $FreeBSD$
--- Makefile.in.orig
+++ Makefile.in
-@@ -90,23 +90,19 @@
- $(CC) $(CFLAGS) -o $@ $(FT2NF_OBJ) $(FT_LDFLAGS) $(FT_LIBS)
-
- install: $(OBJECTS)
-- test -d $(PREFIX) || install -d -o root -g bin -m 755 $(PREFIX)
-- test -d $(PREFIX)/bin || install -d -o root -g bin -m 755 $(PREFIX)/bin
-- test -d $(MANDIR) || install -d -o root -g bin -m 755 $(MANDIR)
-- test -d $(MANDIR)/man1 || install -d -o root -g bin -m 755 $(MANDIR)/man1
-- $(INSTALL) -o root -g bin -m 755 nfcapd $(PREFIX)/bin
-- $(INSTALL) -o root -g bin -m 755 nfdump $(PREFIX)/bin
-- $(INSTALL) -o root -g bin -m 755 nfprofile $(PREFIX)/bin
-- $(INSTALL) -o root -g bin -m 755 nfreplay $(PREFIX)/bin
+@@ -100,11 +100,11 @@
+ test -d $(MANDIR)/man1 || install -d -o root -g bin -m 755 $(MANDIR)/man1
+ for file in $(OBJECTS); do \
+ if [ -f $$file.1 ]; then \
+- $(INSTALL) -o root -g bin -m 755 $$file $(PREFIX)/bin ; \
+- $(INSTALL) -o root -g bin -m 644 $$file.1 $(MANDIR)/man1 ; \
++ $(BSD_INSTALL_PROGRAM) $$file $(PREFIX)/bin ; \
++ $(BSD_INSTALL_MAN) $$file.1 $(MANDIR)/man1 ; \
+ fi \
+ done;
- test -f $(PREFIX)/bin/nfclean.pl || $(INSTALL) -o root -g bin -m 755 nfclean.pl $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) nfcapd $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) nfdump $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) nfprofile $(PREFIX)/bin
-+ $(BSD_INSTALL_PROGRAM) nfreplay $(PREFIX)/bin
-+ $(BSD_INSTALL_SCRIPT) nfclean.pl $(PREFIX)/bin
-
-- $(INSTALL) -o root -g bin -m 644 nfcapd.1 $(MANDIR)/man1
-- $(INSTALL) -o root -g bin -m 644 nfdump.1 $(MANDIR)/man1
-- $(INSTALL) -o root -g bin -m 644 nfprofile.1 $(MANDIR)/man1
-- $(INSTALL) -o root -g bin -m 644 nfreplay.1 $(MANDIR)/man1
-+ $(BSD_INSTALL_MAN) nfcapd.1 $(MANDIR)/man1
-+ $(BSD_INSTALL_MAN) nfdump.1 $(MANDIR)/man1
-+ $(BSD_INSTALL_MAN) nfprofile.1 $(MANDIR)/man1
-+ $(BSD_INSTALL_MAN) nfreplay.1 $(MANDIR)/man1
- if test -f ft2nfdump; then \
-- $(INSTALL) -o root -g bin -m 755 ft2nfdump $(PREFIX)/bin; \
-- $(INSTALL) -o root -g bin -m 644 ft2nfdump.1 $(MANDIR)/man1; \
-+ $(BSD_INSTALL_PROGRAM) ft2nfdump $(PREFIX)/bin; \
-+ $(BSD_INSTALL_MAN) ft2nfdump.1 $(MANDIR)/man1; \
- fi;
++ test -f $(PREFIX)/bin/nfclean.pl || $(BSD_INSTALL_SCRIPT) nfclean.pl $(PREFIX)/bin
uninstall:
+ for file in $(OBJECTS); do \
diff --git a/net-mgmt/nfdump/files/patch-ft2nfdump.c b/net-mgmt/nfdump/files/patch-ft2nfdump.c
index 3a229331dd4b..2dbb1756cdf6 100644
--- a/net-mgmt/nfdump/files/patch-ft2nfdump.c
+++ b/net-mgmt/nfdump/files/patch-ft2nfdump.c
@@ -3,12 +3,12 @@ $FreeBSD$
--- ft2nfdump.c.orig
+++ ft2nfdump.c
-@@ -54,7 +54,7 @@
+@@ -64,7 +64,7 @@
+ #endif
- #include <string.h>
- #include <errno.h>
+ #include "version.h"
-#include "ftbuild.h"
-+/*#include "ftbuild.h" */
-
- #include <sys/stat.h>
-
++/*#include "ftbuild.h"*/
+ #include "nf_common.h"
+ #include "nffile.h"
+ #include "launch.h"