aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nfsen-devel
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-04-16 10:33:07 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-04-16 10:33:07 +0000
commit96b87012085412ace625d28c87b9490e50d6b719 (patch)
treea65bbf6366ade340a496aa0280bc1f1895438550 /net-mgmt/nfsen-devel
parentca2744ed5604eef34d8b0b180e972b3db8a7606f (diff)
downloadports-96b87012085412ace625d28c87b9490e50d6b719.tar.gz
ports-96b87012085412ace625d28c87b9490e50d6b719.zip
Notes
Diffstat (limited to 'net-mgmt/nfsen-devel')
-rw-r--r--net-mgmt/nfsen-devel/Makefile35
-rw-r--r--net-mgmt/nfsen-devel/distinfo2
-rw-r--r--net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf42
-rw-r--r--net-mgmt/nfsen-devel/pkg-descr12
-rw-r--r--net-mgmt/nfsen-devel/pkg-plist45
5 files changed, 136 insertions, 0 deletions
diff --git a/net-mgmt/nfsen-devel/Makefile b/net-mgmt/nfsen-devel/Makefile
new file mode 100644
index 000000000000..30fd31ccf365
--- /dev/null
+++ b/net-mgmt/nfsen-devel/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: nfsen
+# Date created: 25 March 2005
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= nfsen
+PORTVERSION= 1.1r3
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/rc/}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Web based frontend to nfdump netflow collector
+
+RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool \
+ nfdump:${PORTSDIR}/net-mgmt/nfdump
+
+HAS_CONFIGURE= yes
+USE_PERL5= yes
+USE_PHP= session pcre
+NO_BUILD= yes
+
+do-configure:
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/etc/nfsen-dist.conf > \
+ ${WRKSRC}/etc/nfsen.conf
+
+do-install:
+ @${MKDIR} -m 755 ${PREFIX}/${PORTNAME}
+ cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl
+ @${ECHO_MSG} "Configure your etc/nfsen.conf correctly to have necessary profiles ";
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nfsen-devel/distinfo b/net-mgmt/nfsen-devel/distinfo
new file mode 100644
index 000000000000..2612df873a6d
--- /dev/null
+++ b/net-mgmt/nfsen-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (nfsen-1.1rc3.tar.gz) = 38b595aa6e4013a444ea48fbabd478a6
+SIZE (nfsen-1.1rc3.tar.gz) = 2654426
diff --git a/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf b/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf
new file mode 100644
index 000000000000..e6c7910b88f0
--- /dev/null
+++ b/net-mgmt/nfsen-devel/files/patch-etc_nfsen-dist.conf
@@ -0,0 +1,42 @@
+
+$FreeBSD$
+
+--- etc/nfsen-dist.conf.orig
++++ etc/nfsen-dist.conf
+@@ -20,7 +20,7 @@
+ # NfSen base directory: Home of NfSen
+ # contains all scripts, modules and profile directories:
+ # bin, libexec, var, profiles
+-$BASEDIR = "/data/nfsen";
++$BASEDIR = "/%%PREFIX%%/nfsen";
+
+ # nfdump tools path
+ $PREFIX = '/usr/local/bin';
+@@ -30,7 +30,7 @@
+ # This may be a different or the same uid than your web server.
+ # Note: This user must be in group $WWWGROUP, otherwise nfcapd
+ # is not able to write data files!
+-$USER = "netflow";
++$USER = "www";
+
+ # user and group of the web server process
+ # All netflow processing will be done with this user
+@@ -52,15 +52,15 @@
+ # Ident strings must be 1 to 19 characters long only, containing characters [a-zA-Z0-9_].
+
+ %sources = (
+- 'upstream1' => { 'port' => '9995', 'col' => '#0000ff' },
+- 'peer1' => { 'port' => '9996', 'col' => '#ff0000' },
++# 'upstream1' => { 'port' => '9995', 'col' => '#0000ff' },
++# 'peer1' => { 'port' => '9996', 'col' => '#ff0000' },
+ );
+
+ #
+ # NfSen html pages directory:
+ # All php scripts will be installed here.
+ # URL: Entry point for nfsen: http://<webserver>/nfsen/nfsen.php
+-$HTMLDIR = "/var/www/nfsen/";
++$HTMLDIR = "/%%PREFIX%%/www/nfsen/";
+
+ #
+ # Low water mark: When expiring files, delete files until
diff --git a/net-mgmt/nfsen-devel/pkg-descr b/net-mgmt/nfsen-devel/pkg-descr
new file mode 100644
index 000000000000..312491947d5d
--- /dev/null
+++ b/net-mgmt/nfsen-devel/pkg-descr
@@ -0,0 +1,12 @@
+NfSen is a graphical web based front end for the nfdump netflow tools.
+
+NfSen allows you to:
+
+ * Display your netflow data: Flows, Packets and Bytes using RRD
+ (Round Robin Database).
+ * Easily navigate through the netflow data.
+ * Process the netflow data within the specified time span.
+ * Create history as well as continuous profiles.
+ * Write your own plugins to process netflow data on a regular interval
+
+WWW: http://nfsen.sourceforge.net/
diff --git a/net-mgmt/nfsen-devel/pkg-plist b/net-mgmt/nfsen-devel/pkg-plist
new file mode 100644
index 000000000000..e774c812bd25
--- /dev/null
+++ b/net-mgmt/nfsen-devel/pkg-plist
@@ -0,0 +1,45 @@
+nfsen/bin/GenGraph.pl
+nfsen/bin/nfsen
+nfsen/bin/nfsen-run
+nfsen/bin/nfsen.rc
+nfsen/bin/testPlugin
+nfsen/etc/nfsen-dist.conf
+nfsen/etc/nfsen-dist.conf.orig
+nfsen/etc/nfsen-shell-param
+nfsen/etc/nfsen.conf
+nfsen/libexec/Log.pm
+nfsen/libexec/NfConf.pm
+nfsen/libexec/NfProfile.pm
+nfsen/libexec/NfSen.pm
+nfsen/libexec/NfSenRRD.pm
+nfsen/libexec/Notification.pm
+nfsen/libexec/PluginTemplate.pm
+nfsen/libexec/demoplugin.pm
+nfsen/profiles/live/profile.dat
+www/nfsen/conf.php
+www/nfsen/css-admin.html
+www/nfsen/css.html
+www/nfsen/details.php
+www/nfsen/edit.png
+www/nfsen/info.php
+www/nfsen/invisible.gif
+www/nfsen/navigator.php
+www/nfsen/nfsen.php
+www/nfsen/nfsenutil.php
+www/nfsen/overview.php
+www/nfsen/pic.gif
+www/nfsen/pic.php
+www/nfsen/process.php
+www/nfsen/profileadmin.php
+www/nfsen/rrdgraph.php
+www/nfsen/trash.png
+@dirrm www/nfsen
+@dirrm nfsen/var/run
+@dirrm nfsen/var/filters
+@dirrm nfsen/var
+@dirrm nfsen/profiles/live
+@dirrm nfsen/profiles
+@dirrm nfsen/libexec
+@dirrm nfsen/etc
+@dirrm nfsen/bin
+@dirrm nfsen