aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nfsen
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2006-03-15 13:35:54 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2006-03-15 13:35:54 +0000
commit690a857320ae561020d530557448fb785c14faed (patch)
tree0d3a4b6bba762fd64aa13ffbd3daa75ea912f13a /net-mgmt/nfsen
parent10b48bab791524bb336b306a13db97d2ed963d8f (diff)
downloadports-690a857320ae561020d530557448fb785c14faed.tar.gz
ports-690a857320ae561020d530557448fb785c14faed.zip
Notes
Diffstat (limited to 'net-mgmt/nfsen')
-rw-r--r--net-mgmt/nfsen/Makefile28
-rw-r--r--net-mgmt/nfsen/distinfo6
-rw-r--r--net-mgmt/nfsen/files/patch-install.pl6
-rw-r--r--net-mgmt/nfsen/pkg-plist1
4 files changed, 26 insertions, 15 deletions
diff --git a/net-mgmt/nfsen/Makefile b/net-mgmt/nfsen/Makefile
index dc5b6ba7d466..5ea22e564604 100644
--- a/net-mgmt/nfsen/Makefile
+++ b/net-mgmt/nfsen/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nfsen
-PORTVERSION= 1.2.2
+PORTVERSION= 1.2.3
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://nfsen.sourceforge.net/
@@ -15,34 +15,38 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= janos.mohacsi@bsd.hu
COMMENT= Web based frontend to nfdump netflow collector
-RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool \
- nfdump:${PORTSDIR}/net-mgmt/nfdump
+RUN_DEPENDS= ${SITE_PERL}/RRDp.pm:${PORTSDIR}/net/rrdtool
+
+.if defined(WITH_IPV6) && !defined(NO_INET6)
+RUN_DEPENDS+= nfdump:${PORTSDIR}/net-mgmt/nfdump-devel
+.else
+RUN_DEPENDS+= nfdump:${PORTSDIR}/net-mgmt/nfdump
+.endif
-HAS_CONFIGURE= yes
USE_ICONV= yes
USE_PERL5= yes
USE_PHP= session pcre
NO_BUILD= yes
-USE_REINPLACE= yes
PLIST_SUB+= PORTNAME=${PORTNAME}
.include <bsd.port.pre.mk>
-pre-everything::
.if ${PERL_LEVEL} < 500600
IGNORE= requires at least perl 5.6.0
.endif
-do-configure:
- ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' -e 's,%%PORTNAME%%,${PORTNAME},' \
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' -e 's,%%PORTNAME%%,${PORTNAME},' \
${WRKSRC}/etc/nfsen-dist.conf
- ${REINPLACE_CMD} -e 's,%%PERL%%,${PERL},' ${WRKSRC}/install.pl
- ${RM} ${WRKSRC}/etc/nfsen-dist.conf.*
+ @${REINPLACE_CMD} -e 's,%%PERL%%,${PERL},' -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/install.pl
+ @${RM} ${WRKSRC}/etc/nfsen-dist.conf.*
do-install:
- ${MKDIR} ${PREFIX}/var/${PORTNAME}/profiles/live
- cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl ${WRKSRC}/etc/nfsen-dist.conf
+ @${MKDIR} ${PREFIX}/var/${PORTNAME}/profiles/live
+ @${MKDIR} ${PREFIX}/libexec/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/installer-items/CopyRecursive.pm ${PREFIX}/libexec/${PORTNAME}/
${INSTALL_SCRIPT} ${WRKSRC}/install.pl ${PREFIX}/bin/nfsen-reconfigure
+ cd ${WRKSRC} ;${PERL} ${WRKSRC}/install.pl ${WRKSRC}/etc/nfsen-dist.conf
@${ECHO_MSG} "Configure your ${LOCALBASE}/etc/nfsen.conf to have necessary profiles ";
@${ECHO_MSG} "Then run 'nfsen-reconfigure ${LOCALBASE}/etc/nfsen.conf' to correctly setup profile files";
diff --git a/net-mgmt/nfsen/distinfo b/net-mgmt/nfsen/distinfo
index 38da4e5ce623..c5efbfcb18ce 100644
--- a/net-mgmt/nfsen/distinfo
+++ b/net-mgmt/nfsen/distinfo
@@ -1,3 +1,3 @@
-MD5 (nfsen-1.2.2.tar.gz) = 26bbb94766ef70f1e350004cc671b2d7
-SHA256 (nfsen-1.2.2.tar.gz) = 6a9a4d31cb5fe7592656f16c3390fae0c3845283c2b47c938f07665fa7fa52a2
-SIZE (nfsen-1.2.2.tar.gz) = 3331005
+MD5 (nfsen-1.2.3.tar.gz) = bb18418d021526fea40bc3f88a837bc1
+SHA256 (nfsen-1.2.3.tar.gz) = dcd362f082d6a92b4400c69bf1784c3ee0c0e95a5c7c617ece36698ce7cba535
+SIZE (nfsen-1.2.3.tar.gz) = 3331295
diff --git a/net-mgmt/nfsen/files/patch-install.pl b/net-mgmt/nfsen/files/patch-install.pl
index 6aabeb302540..dd144f62fb55 100644
--- a/net-mgmt/nfsen/files/patch-install.pl
+++ b/net-mgmt/nfsen/files/patch-install.pl
@@ -3,6 +3,12 @@ $FreeBSD$
--- install.pl.orig
+++ install.pl
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -I installer-items
++#!%%PERL%% -I %%PREFIX%%/libexec/nfsen
+ #
+ #
+ # Copyright (c) 2004, SWITCH - Teleinformatikdienste fuer Lehre und Forschung
@@ -56,33 +56,7 @@
# Get Perl
sub GetPerl {
diff --git a/net-mgmt/nfsen/pkg-plist b/net-mgmt/nfsen/pkg-plist
index 3b824342b6b2..561603d08ca1 100644
--- a/net-mgmt/nfsen/pkg-plist
+++ b/net-mgmt/nfsen/pkg-plist
@@ -8,6 +8,7 @@ bin/testPlugin
etc/nfsen-dist.conf
@exec [ -f %D/etc/nfsen.conf ] || cp %D/etc/nfsen-dist.conf %D/etc/nfsen.conf
etc/nfsen-shell-param
+libexec/%%PORTNAME%%/CopyRecursive.pm
libexec/%%PORTNAME%%/GenGraph.pl
libexec/%%PORTNAME%%/Log.pm
libexec/%%PORTNAME%%/NfConf.pm