aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/ng_ipacct
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2006-12-25 10:38:10 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2006-12-25 10:38:10 +0000
commit1dd4882c4b95c0083a6ec3e5f27217a86ef3d632 (patch)
treedbe4c0c939b215d615e6c99fde0de8df065de867 /net-mgmt/ng_ipacct
parentf7d39607d413692421ac118d17e364230ea90d42 (diff)
downloadports-1dd4882c4b95c0083a6ec3e5f27217a86ef3d632.tar.gz
ports-1dd4882c4b95c0083a6ec3e5f27217a86ef3d632.zip
Notes
Diffstat (limited to 'net-mgmt/ng_ipacct')
-rw-r--r--net-mgmt/ng_ipacct/Makefile5
-rw-r--r--net-mgmt/ng_ipacct/distinfo6
-rw-r--r--net-mgmt/ng_ipacct/files/patch-ipacctctl.c66
3 files changed, 5 insertions, 72 deletions
diff --git a/net-mgmt/ng_ipacct/Makefile b/net-mgmt/ng_ipacct/Makefile
index 9134de012432..e92f239654f8 100644
--- a/net-mgmt/ng_ipacct/Makefile
+++ b/net-mgmt/ng_ipacct/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ng_ipacct
-PORTVERSION= 20050731
-PORTREVISION= 2
+PORTVERSION= 20061223
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_LOCAL:S!$!skv/!} \
ftp://ftp.wuppy.net.ru/pub/FreeBSD/local/kernel/ng_ipacct/
@@ -17,7 +16,7 @@ COMMENT= Netgraph IP accounting
NO_PACKAGE= "Depends on kernel"
-OPTIONS= MEM_ZONE "Use UMA zone allocator (5.x only)" off
+OPTIONS= MEM_ZONE "Use UMA zone allocator (>= 5.x only)" on
PLIST_SUB+= KMODDIR=${KMODDIR}
diff --git a/net-mgmt/ng_ipacct/distinfo b/net-mgmt/ng_ipacct/distinfo
index 08e4b7734ff7..d22558367cff 100644
--- a/net-mgmt/ng_ipacct/distinfo
+++ b/net-mgmt/ng_ipacct/distinfo
@@ -1,3 +1,3 @@
-MD5 (ng_ipacct-20050731.tar.gz) = 54bf5d2d0aee7c7d163623550f2a8fd2
-SHA256 (ng_ipacct-20050731.tar.gz) = 7a7d532d76424067741b0b40069235f5d17cccda0a678ffc521bb7d3f1b1f9d8
-SIZE (ng_ipacct-20050731.tar.gz) = 25342
+MD5 (ng_ipacct-20061223.tar.gz) = 4b950e705d47d2c13f137a812c3cdb28
+SHA256 (ng_ipacct-20061223.tar.gz) = 5c0d1f8626c80d9bc0ec0a5296adcc88645c4309f9accd2619ed852a5a9356e2
+SIZE (ng_ipacct-20061223.tar.gz) = 25543
diff --git a/net-mgmt/ng_ipacct/files/patch-ipacctctl.c b/net-mgmt/ng_ipacct/files/patch-ipacctctl.c
deleted file mode 100644
index 31438adb31ed..000000000000
--- a/net-mgmt/ng_ipacct/files/patch-ipacctctl.c
+++ /dev/null
@@ -1,66 +0,0 @@
---- ipacctctl/ipacctctl.c.orig 2006-02-07 19:55:24.406250000 +0300
-+++ ipacctctl/ipacctctl.c 2006-02-07 20:13:25.734375000 +0300
-@@ -36,6 +36,7 @@
- #include <sys/socket.h>
- #include <sys/queue.h>
- #include <sys/select.h>
-+#include <inttypes.h>
-
- #include <net/bpf.h> /* for DLT_XXX consts */
- #include <netinet/in.h>
-@@ -56,6 +57,10 @@
- #define IN_HOOK 0
- #define OUT_HOOK 1
-
-+#ifndef PRIu64
-+#define PRIu64 "qu"
-+#endif
-+
- int main(int, char **);
-
- static int ip_account_get_info(int _type, void *_buf, int _len, int _out);
-@@ -459,7 +464,7 @@
- (hi->hi_thrs_when) ? stime : "Never");
- printf("total number of packets:\t%u\n",
- hi->hi_packets);
-- printf("total number of bytes:\t\t%qu\n",
-+ printf("total number of bytes:\t\t%" PRIu64 "\n",
- hi->hi_bytes);
- return;
- }
-@@ -473,9 +478,9 @@
- ng_hookprefix, (outgoing) ? "out" : "in");
- printf("database type:\t\t%s\n",
- (type == NGM_IPACCT_CINFO) ? "checkpointed" : "active");
-- printf("accounted:\t\tpackets: %u\tbytes: %qu\n",
-+ printf("accounted:\t\tpackets: %u\tbytes: %" PRIu64 "\n",
- ai->ai_packets, ai->ai_bytes);
-- printf("exceed threshold:\tpackets: %u\tbytes: %qu\n",
-+ printf("exceed threshold:\tpackets: %u\tbytes: %" PRIu64 "\n",
- ai->ai_th_packets, ai->ai_th_bytes);
- strftime(stime, sizeof(stime), TIME_FMT, localtime(&ai->ai_start));
- printf("database was created:\t%s\n",
-@@ -642,7 +647,7 @@
- ip_account_print(data, hi.hi_flags);
- }
- if (ci.ai_th_packets)
-- printf(" Accounting exceed threshold by %u packets (%qu bytes)\n",
-+ printf(" Accounting exceed threshold by %u packets (%" PRIu64 " bytes)\n",
- ci.ai_th_packets, ci.ai_th_bytes);
-
- return (0);
-@@ -707,12 +712,12 @@
- inet_ntop(AF_INET, &pr->s.r_dst, dst, sizeof(dst));
- }
- if (flags & HI_VERBOSE_MODE) {
-- printf("%s\t%d\t%s\t%d\t%d\t%u\t%qu",
-+ printf("%s\t%d\t%s\t%d\t%d\t%u\t%" PRIu64,
- src, ntohs(pr->s.r_sport),
- dst, ntohs(pr->s.r_dport),
- pr->s.r_ip_p, pr->packets, pr->bytes);
- } else {
-- printf("%s\t%s\t%u\t%qu",
-+ printf("%s\t%s\t%u\t%" PRIu64,
- src, dst, pr->packets, pr->bytes);
- }
- if (flags & HI_SAVE_UID) {