aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nipper
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-05-03 19:46:00 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-05-03 19:46:00 +0000
commit8fc1e9fb8259ce019c26eddfe8367212b299a85a (patch)
tree5119ca58b51a33a482c2506ae6848d023b88a95c /net-mgmt/nipper
parent576e0520c8b4b477a4b9193e49941b7b5386a8a7 (diff)
downloadports-8fc1e9fb8259ce019c26eddfe8367212b299a85a.tar.gz
ports-8fc1e9fb8259ce019c26eddfe8367212b299a85a.zip
Notes
Diffstat (limited to 'net-mgmt/nipper')
-rw-r--r--net-mgmt/nipper/Makefile30
-rw-r--r--net-mgmt/nipper/distinfo3
-rw-r--r--net-mgmt/nipper/pkg-descr7
3 files changed, 40 insertions, 0 deletions
diff --git a/net-mgmt/nipper/Makefile b/net-mgmt/nipper/Makefile
new file mode 100644
index 000000000000..90d8887dc659
--- /dev/null
+++ b/net-mgmt/nipper/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: nipper
+# Date created: 3 May 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nipper
+PORTVERSION= 0.9.4
+CATEGORIES= net-mgmt
+MASTER_SITES= SF
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Netdev config analyzer
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= Changelog Readme TODO
+
+do-build:
+ @cd ${WRKSRC}/ && ${CC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/nipper ${PREFIX}/bin/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/nipper/distinfo b/net-mgmt/nipper/distinfo
new file mode 100644
index 000000000000..e3303888d459
--- /dev/null
+++ b/net-mgmt/nipper/distinfo
@@ -0,0 +1,3 @@
+MD5 (nipper-0.9.4.tgz) = 16ad94b950e3b1e449581634916e4f3b
+SHA256 (nipper-0.9.4.tgz) = 2a3b2d986a175f623a94d26c93a0351677418a47d9b45c9040e7dec1a21de14d
+SIZE (nipper-0.9.4.tgz) = 140377
diff --git a/net-mgmt/nipper/pkg-descr b/net-mgmt/nipper/pkg-descr
new file mode 100644
index 000000000000..678f3eb4e08b
--- /dev/null
+++ b/net-mgmt/nipper/pkg-descr
@@ -0,0 +1,7 @@
+nipper processes network device configuration files, performs a
+security audit and outputs a security report with recommendations and
+a configuration report. nipper currently supports Cisco IOS, PIX, ASA,
+FWSM, NMP, CatOS and Juniper NetScreen devices.
+
+WWW: http://sourceforge.net/projects/nipper
+Author: Ian Ventura-Whiting <ivwhiting at users.sourceforge.net>