aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nrpe2/Makefile
diff options
context:
space:
mode:
authorMichael Haro <mharo@FreeBSD.org>2004-12-13 19:58:55 +0000
committerMichael Haro <mharo@FreeBSD.org>2004-12-13 19:58:55 +0000
commitdcadc895ec37c35ae8bda17497a580c1677a57a2 (patch)
tree3694264bc3e8be6e85b59da8b984a01e0b384500 /net-mgmt/nrpe2/Makefile
parent7cc398a386f7b06ef8225517629ac3d129370fec (diff)
downloadports-dcadc895ec37c35ae8bda17497a580c1677a57a2.tar.gz
ports-dcadc895ec37c35ae8bda17497a580c1677a57a2.zip
Notes
Diffstat (limited to 'net-mgmt/nrpe2/Makefile')
-rw-r--r--net-mgmt/nrpe2/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-mgmt/nrpe2/Makefile b/net-mgmt/nrpe2/Makefile
index 00d6d744ea64..52a8235c482c 100644
--- a/net-mgmt/nrpe2/Makefile
+++ b/net-mgmt/nrpe2/Makefile
@@ -22,6 +22,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --libexecdir=${PREFIX}/libexec/nagios --bindir=${PREFIX}/sbin --sysconfdir=${PREFIX}/etc
+OPTIONS= SSL "SSL support" off \
+ ARGS "Enable command arguments *POTENTIAL SECURITY RISK*" off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_SSL)
USE_OPENSSL= yes
CONFIGURE_ARGS+= --enable-ssl
@@ -29,10 +34,8 @@ CONFIGURE_ARGS+= --enable-ssl
CONFIGURE_ARGS+= --disable-ssl
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not install on FreeBSD >= 5.x"
+.if defined(WITH_ARGS)
+CONFIGURE_ARGS+= --enable-command-args
.endif
do-install: