aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/nrpe2
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-02-20 19:18:37 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-02-20 19:18:37 +0000
commitee91cf83e5ecf21e9f585a04ba3550ef77ffae76 (patch)
tree7b5e403f341d0cea098a5389da9b0e6f16e884b5 /net-mgmt/nrpe2
parentc2678abcf0ad5f8a1a7a890d2f263929907e1068 (diff)
downloadports-ee91cf83e5ecf21e9f585a04ba3550ef77ffae76.tar.gz
ports-ee91cf83e5ecf21e9f585a04ba3550ef77ffae76.zip
Notes
Diffstat (limited to 'net-mgmt/nrpe2')
-rw-r--r--net-mgmt/nrpe2/Makefile3
-rw-r--r--net-mgmt/nrpe2/distinfo6
-rw-r--r--net-mgmt/nrpe2/files/patch-sample-config-nrpe.cfg.in17
-rw-r--r--net-mgmt/nrpe2/files/patch-src-nrpe.c15
4 files changed, 27 insertions, 14 deletions
diff --git a/net-mgmt/nrpe2/Makefile b/net-mgmt/nrpe2/Makefile
index 7105eb320f7d..7a2f0755915b 100644
--- a/net-mgmt/nrpe2/Makefile
+++ b/net-mgmt/nrpe2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= nrpe2
-PORTVERSION= 2.7
-PORTREVISION= 2
+PORTVERSION= 2.11
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= nagios
diff --git a/net-mgmt/nrpe2/distinfo b/net-mgmt/nrpe2/distinfo
index 99c8b9dc353b..49f72f2cab1a 100644
--- a/net-mgmt/nrpe2/distinfo
+++ b/net-mgmt/nrpe2/distinfo
@@ -1,3 +1,3 @@
-MD5 (nrpe-2.7.tar.gz) = c50b89d27f4ebbcedcb2bc6ab9f56a4e
-SHA256 (nrpe-2.7.tar.gz) = 13c25b63f07b96fbf4ca07dba6950309f2b350f19b9b48f36c067e127ebb352a
-SIZE (nrpe-2.7.tar.gz) = 101921
+MD5 (nrpe-2.11.tar.gz) = dcf3b7c5b7c94c0ba6cbb4999c1161f0
+SHA256 (nrpe-2.11.tar.gz) = 4cedfc2588ba65ebfe4e3310c9fbda08c6f0912cfcc2c1ac96636b6f5c839e1d
+SIZE (nrpe-2.11.tar.gz) = 405643
diff --git a/net-mgmt/nrpe2/files/patch-sample-config-nrpe.cfg.in b/net-mgmt/nrpe2/files/patch-sample-config-nrpe.cfg.in
index a5c7fad27f60..9d8893a9e039 100644
--- a/net-mgmt/nrpe2/files/patch-sample-config-nrpe.cfg.in
+++ b/net-mgmt/nrpe2/files/patch-sample-config-nrpe.cfg.in
@@ -1,15 +1,14 @@
---- sample-config/nrpe.cfg.in.orig Tue Dec 12 12:34:00 2006
-+++ sample-config/nrpe.cfg.in Tue Jun 26 20:16:45 2007
-@@ -190,8 +190,10 @@
+--- sample-config/nrpe.cfg.in.orig 2007-11-24 04:01:23.000000000 +1030
++++ sample-config/nrpe.cfg.in 2008-02-20 18:39:58.000000000 +1030
+@@ -198,7 +198,10 @@
command[check_users]=@libexecdir@/check_users -w 5 -c 10
command[check_load]=@libexecdir@/check_load -w 15,10,5 -c 30,25,20
--command[check_disk1]=@libexecdir@/check_disk -w 20 -c 10 -p /dev/hda1
--command[check_disk2]=@libexecdir@/check_disk -w 20 -c 10 -p /dev/hdb1
-+command[check_disk_root]=@libexecdir@/check_disk -w 20 -c 10 --path /
-+command[check_disk_var]=@libexecdir@/check_disk -w 20 -c 10 --path /var
-+command[check_disk_tmp]=@libexecdir@/check_disk -w 20 -c 10 --path /tmp
-+command[check_disk_usr]=@libexecdir@/check_disk -w 20 -c 10 --path /usr
+-command[check_hda1]=@libexecdir@/check_disk -w 20% -c 10% -p /dev/hda1
++command[check_root]=@libexecdir@/check_disk -w 20% -c 10% -p /
++command[check_var]=@libexecdir@/check_disk -w 20% -c 10% -p /var
++command[check_tmp]=@libexecdir@/check_disk -w 20% -c 10% -p /tmp
++command[check_usr]=@libexecdir@/check_disk -w 20% -c 10% -p /usr
command[check_zombie_procs]=@libexecdir@/check_procs -w 5 -c 10 -s Z
command[check_total_procs]=@libexecdir@/check_procs -w 150 -c 200
diff --git a/net-mgmt/nrpe2/files/patch-src-nrpe.c b/net-mgmt/nrpe2/files/patch-src-nrpe.c
new file mode 100644
index 000000000000..632b4c1430d4
--- /dev/null
+++ b/net-mgmt/nrpe2/files/patch-src-nrpe.c
@@ -0,0 +1,15 @@
+--- src/nrpe.c.orig 2007-12-27 05:55:05.000000000 +1030
++++ src/nrpe.c 2008-02-20 19:19:03.000000000 +1030
+@@ -1458,8 +1458,10 @@
+ }while(bytes_read==-1 && errno==EINTR);
+ }
+
+- if(bytes_read==-1 && output!=NULL)
+- strcpy(output,"");
++ if(bytes_read==-1)
++ *output='\0';
++ else
++ output[bytes_read]='\0';
+
+ /* if there was a critical return code and no output AND the command time exceeded the timeout thresholds, assume a timeout */
+ if(result==STATE_CRITICAL && bytes_read==-1 && (end_time-start_time)>=timeout){