aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/observium/Makefile
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-07-28 16:20:05 +0000
committerMark Felder <feld@FreeBSD.org>2014-07-28 16:20:05 +0000
commit5296f66b97dd0ff656a767a9f4490e848bb54f54 (patch)
tree9f179150e0555a80c1942d4474dcdf0b25c0573d /net-mgmt/observium/Makefile
parente603a10bea0f84de6eac08f820938b5ddd3ad51c (diff)
Notes
Diffstat (limited to 'net-mgmt/observium/Makefile')
-rw-r--r--net-mgmt/observium/Makefile92
1 files changed, 29 insertions, 63 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index eb8e6d84a028..c761f25db28e 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -2,14 +2,11 @@
# $FreeBSD$
PORTNAME= observium
-PORTVERSION= 0.11.5.2261
-PORTREVISION= 1
+PORTVERSION= 0.14.4.5229
CATEGORIES= net-mgmt
-MASTER_SITES= http://observium.org/ \
- http://cpansearch.perl.org/src/BBB/Net-Ping-2.31/demo/
-DISTNAME= ${PORTNAME}-latest
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} # prevent being 'fping' with JAIL
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+MASTER_SITES= http://www.observium.org/
+DISTNAME= ${PORTNAME}-community-latest
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Autodiscovering PHP/MySQL/SNMP based network monitoring
@@ -18,9 +15,16 @@ LICENSE= GPLv3
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= shebangfix
+SHEBANG_FILES= mibs/process.pl html/js/makemini.pl \
+ scripts/watchmaillog/watchmaillog.pl \
+ scripts/agent-local/postgresql.pl \
+ scripts/removespikes.pl scripts/add_ds.pl
USE_PHP= snmp ctype gd mysql session xml
WANT_PHP_CLI= yes
+NO_BUILD= yes
+
RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool \
dot:${PORTSDIR}/graphics/graphviz \
Magick-config:${PORTSDIR}/graphics/ImageMagick \
@@ -29,33 +33,28 @@ RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool \
${LOCALBASE}/share/pear/Net/IPv6.php:${PORTSDIR}/net/pear-Net_IPv6 \
snmpget:${PORTSDIR}/net-mgmt/net-snmp
-OPTIONS_DEFINE= APACHEMOD MYSQLD JAIL
+OPTIONS_DEFINE= APACHEMOD MYSQLD
OPTIONS_DEFAULT= APACHEMOD
APACHEMOD_DESC= Use PHP with Apache 2.2+ module
MYSQLD_DESC= Use local MySQL server
-JAIL_DESC= This is a jail installation
-NO_STAGE= yes
.include <bsd.port.options.mk>
SUB_FILES+= pkg-message
SUB_LIST+= PHP="${PHPBASE}/bin/php"
-# :r!ls *.php *.sql
-ROOT_FILES= addhost.php adduser.php alerts.php check-errors.php \
- check-services.php delhost.php discovery.php \
- generate-iplist.php irc.php poll-billing.php \
- poll-device.php poller.php renamehost.php snmptrap.php \
- syslog.php database-schema.sql database-update-pre1000.sql \
- database-update-pre1435.sql database-update-pre2245.sql \
- database-update.sql config.php.default
-ROOT_DIRS= attic contrib html includes mibs scripts upgrade-scripts
-PORTDOCS= CHANGELOG INSTALL README
+ROOT_FILES= rename_device.php snmptrap.php .scrutinizer.yml add_device.php \
+ snmpd.conf.example check-errors.php config_to_json.php delete_device.php \
+ syslog.php irc.php snmp.conf.example adduser.php discovery.php \
+ check-services.php poller.php config.php.default poller-wrapper.py
+ROOT_DIRS= html scripts includes update mibs
+
+PORTDOCS= INSTALL README
PORTEXAMPLES= snmp.conf.example snmpd.conf.example
.if ${PORT_OPTIONS:MAPACHEMOD} && !defined(PACKAGE_BUILDING)
WANT_PHP_MOD= yes
-USE_APACHE= 22+
+USE_APACHE_RUN= 22+
.else
# Package builder doesn't create php5 with module
WANT_PHP_WEB= yes
@@ -67,61 +66,28 @@ USE_MYSQL= server
USE_MYSQL= client
.endif
-.if ${PORT_OPTIONS:MJAIL}
-RUN_DEPENDS+= p5-Net-Ping>=0:${PORTSDIR}/net/p5-Net-Ping
-DISTFILES+= fping
-SUB_LIST+= FPING="${LOCALBASE}/bin/fping-perl"
-PLIST_SUB+= JAIL=""
-.else
-RUN_DEPENDS+= fping:${PORTSDIR}/net/fping
-SUB_LIST+= FPING="${LOCALBASE}/sbin/fping"
-PLIST_SUB+= JAIL="@comment "
-.endif
-
-post-extract:
- @${FIND} ${WRKSRC} -name '.svn' -exec ${RM} -rf {} +
-.if defined(WITH_JAIL)
- @${CP} ${DISTDIR}/fping ${WRKDIR}/fping
-.endif
-
-do-build:
-.if ${PORT_OPTIONS:MJAIL}
- @${REINPLACE_CMD} -e 's,^#!.*$$,#!${PERL},' ${WRKDIR}/fping
-.endif
- @${FIND} ${WRKSRC} -name '*.pl' | ${XARGS} ${REINPLACE_CMD} \
- -e 's,#!/usr/bin/perl,#!${PERL},'
- @${REINPLACE_CMD} -E 's,<\?=([^?]+)\?>,<?php echo \1;?>,g' \
- ${WRKSRC}/html/graph-realtime.php
- @${RM} ${WRKSRC}/html/includes/geshi/docs/COPYING
- @${RM} ${WRKSRC}/html/pages/addhost.inc.php.orig
-
do-install:
- @${MKDIR} ${WWWDIR}
- @${FIND} ${WRKSRC} -name '*.bak' -delete
+ @${MKDIR} ${STAGEDIR}/${WWWDIR}
.for dir in ${ROOT_DIRS}
- @${MKDIR} ${WWWDIR}/${dir}
- @${ECHO_MSG} "===> Installing ${dir}"
- @cd ${WRKSRC}/${dir} && ${COPYTREE_SHARE} . ${WWWDIR}/${dir}
+ @${MKDIR} ${STAGEDIR}/${WWWDIR}/${dir}
+ @cd ${WRKSRC}/${dir} && ${COPYTREE_SHARE} . ${STAGEDIR}/${WWWDIR}/${dir}
.endfor
- @${ECHO_MSG} "===> Installing root files"
.for f in ${ROOT_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${WWWDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${WWWDIR}
.endfor
+
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}/${DOCSDIR}
.for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${DOCSDIR}
.endfor
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}/${EXAMPLESDIR}
.for f in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}/${EXAMPLESDIR}
.endfor
.endif
-.if ${PORT_OPTIONS:MJAIL}
- @${INSTALL_SCRIPT} ${WRKDIR}/fping ${PREFIX}/bin/fping-perl
-.endif
post-install:
@${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}