aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/observium
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2016-02-09 22:27:53 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2016-02-09 22:27:53 +0000
commit433e0a25b03b5124f2cd927384fd5b18b6e9dbf6 (patch)
tree113613931319c964a36edd1edcf4a866255fdb25 /net-mgmt/observium
parent46592b9af903ae4b2cd8ed98cd2030dafdb0a0ad (diff)
downloadports-433e0a25b03b5124f2cd927384fd5b18b6e9dbf6.tar.gz
ports-433e0a25b03b5124f2cd927384fd5b18b6e9dbf6.zip
Notes
Diffstat (limited to 'net-mgmt/observium')
-rw-r--r--net-mgmt/observium/Makefile6
-rw-r--r--net-mgmt/observium/files/patch-html_includes_graphs_generic__multi__bits__separated.inc.php27
-rw-r--r--net-mgmt/observium/files/pkg-message.in15
3 files changed, 33 insertions, 15 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index 79812e8f8f28..97e9876a3e77 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= observium
PORTVERSION= 0.16.1.7533
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.observium.org/
DISTNAME= ${PORTNAME}-community-latest
@@ -63,7 +63,9 @@ RUN_DEPENDS+= rrdtool:${PORTSDIR}/databases/rrdtool \
mtr:${PORTSDIR}/net/mtr-nox11 \
${LOCALBASE}/share/pear/Net/IPv4.php:${PORTSDIR}/net/pear-Net_IPv4 \
${LOCALBASE}/share/pear/Net/IPv6.php:${PORTSDIR}/net/pear-Net_IPv6 \
- snmpget:${PORTSDIR}/net-mgmt/net-snmp
+ snmpget:${PORTSDIR}/net-mgmt/net-snmp \
+ sudo:${PORTSDIR}/security/sudo
+LIB_DEPENDS+= libpng.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= APACHEMOD FPING IPMITOOL LIBVIRT MYSQLD NAGPLUGINS NMAP PYPOLLER SVN WMIC
OPTIONS_DEFAULT= APACHEMOD FPING IPMITOOL LIBVIRT NAGPLUGINS NMAP PYPOLLER SVN WMIC
diff --git a/net-mgmt/observium/files/patch-html_includes_graphs_generic__multi__bits__separated.inc.php b/net-mgmt/observium/files/patch-html_includes_graphs_generic__multi__bits__separated.inc.php
new file mode 100644
index 000000000000..b6054c84aeac
--- /dev/null
+++ b/net-mgmt/observium/files/patch-html_includes_graphs_generic__multi__bits__separated.inc.php
@@ -0,0 +1,27 @@
+--- html/includes/graphs/generic_multi_bits_separated.inc.php.orig 2016-01-15 08:37:56 UTC
++++ html/includes/graphs/generic_multi_bits_separated.inc.php
+@@ -76,13 +76,13 @@ foreach ($rrd_list as $rrd)
+ $rrd_options .= " VDEF:totout".$i."=outB".$i.",TOTAL";
+ $rrd_options .= " VDEF:tot".$i."=octets".$i.",TOTAL";
+
+- if ($i) { $stack="STACK"; }
++ if ($i) { $stack=":STACK"; }
+
+ if ($vars['line_graph'])
+ {
+ $rrd_options .= " LINE1.25:inB".$i."#" . $colour_in . ":'" . $descr . "'";
+ } else {
+- $rrd_options .= " AREA:inB".$i."#" . $colour_in . ":'" . $descr . "':$stack";
++ $rrd_options .= " AREA:inB".$i."#" . $colour_in . ":'" . $descr . "'$stack";
+ }
+ $rrd_options .= " GPRINT:inB".$i.":LAST:%6.2lf%s$units";
+ $rrd_options .= " GPRINT:inB".$i.":AVERAGE:%6.2lf%s$units";
+@@ -97,7 +97,7 @@ foreach ($rrd_list as $rrd)
+ $rrd_options .= " 'LINE1.25:outB".$i."_neg#" . $colour_out . ":" . $descr_out . "'";
+ } else {
+ $rrd_options .= " 'HRULE:0#" . $colour_out.":".$descr_out."'";
+- $rrd_optionsb .= " 'AREA:outB".$i."_neg#" . $colour_out . "::$stack'";
++ $rrd_optionsb .= " 'AREA:outB".$i."_neg#" . $colour_out . ":$stack'";
+ }
+ $rrd_options .= " GPRINT:outB".$i.":LAST:%6.2lf%s$units";
+ $rrd_options .= " GPRINT:outB".$i.":AVERAGE:%6.2lf%s$units";
diff --git a/net-mgmt/observium/files/pkg-message.in b/net-mgmt/observium/files/pkg-message.in
index 4a10b1fd1a85..fa8ec2c39407 100644
--- a/net-mgmt/observium/files/pkg-message.in
+++ b/net-mgmt/observium/files/pkg-message.in
@@ -4,7 +4,6 @@ http://observium.org/wiki/Installation
with the following notes:
- Installation directory is %%WWWDIR%%
-- $config['fping'] should be set to '%%LOCALBASE%%/sbin/fping'
- The following lines should be added to /etc/crontab:
33 */6 * * * www cd %%WWWDIR%% && %%PHP%% discovery.php -h all
@@ -14,24 +13,16 @@ with the following notes:
Notes:
-- Setting $config['snmp']['internal'] to true is not recommended. The
- php function snmp_set_quick_print() used by Observium leaves units like
- kB in the value and Observium currently does not deal with that correctly.
-
- This line can be added to %%WWWDIR%%/config.php
-
- With newer MySQL databases you may need to disable strict mode for
Observium to function:
SET GLOBAL sql_mode = '';
-- Apache needs mod_rewrite enable; uncomment the line below in httpd.conf as needed.
+- Apache needs mod_rewrite enabled; uncomment the line below in httpd.conf as needed.
LoadModule rewrite_module libexec/apache24/mod_rewrite.so
-MINIMAL baseline install.
-
-A minimal install can be created with the following steps and configuration file:
+- A minimal install can be created with the following steps and configuration file:
0: make sure apache and mysql are up and running.
@@ -53,8 +44,6 @@ $config['db_user'] = 'observium';
$config['db_pass'] = 'notSecure';
$config['db_name'] = 'observium';
-$config['snmp']['internal'] = TRUE;
-
3: populate the admin user and initialize the database (as 'www' user):
sudo -u www %%WWWDIR%%/discovery.php -u