aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-BigIP-iControl
diff options
context:
space:
mode:
authorPhilippe Audeoud <jadawin@FreeBSD.org>2012-11-27 09:03:26 +0000
committerPhilippe Audeoud <jadawin@FreeBSD.org>2012-11-27 09:03:26 +0000
commitfbbd6f71fdf874026420f9dc40a965dba4ed204f (patch)
treee74008c66de8b5c7b73ef44f5b96cd7687987f46 /net-mgmt/p5-BigIP-iControl
parent0c089ccbe88c006fae31f8a274988c1cb9c196df (diff)
downloadports-fbbd6f71fdf874026420f9dc40a965dba4ed204f.tar.gz
ports-fbbd6f71fdf874026420f9dc40a965dba4ed204f.zip
Notes
Diffstat (limited to 'net-mgmt/p5-BigIP-iControl')
-rw-r--r--net-mgmt/p5-BigIP-iControl/Makefile21
-rw-r--r--net-mgmt/p5-BigIP-iControl/distinfo2
-rw-r--r--net-mgmt/p5-BigIP-iControl/pkg-descr6
-rw-r--r--net-mgmt/p5-BigIP-iControl/pkg-plist5
4 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/p5-BigIP-iControl/Makefile b/net-mgmt/p5-BigIP-iControl/Makefile
new file mode 100644
index 000000000000..1466df7e6a91
--- /dev/null
+++ b/net-mgmt/p5-BigIP-iControl/Makefile
@@ -0,0 +1,21 @@
+# Created by: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+# $FreeBSD$
+
+PORTNAME= BigIP-iControl
+PORTVERSION= 0.095
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A Perl interface to the F5 iControl API
+
+RUN_DEPENDS= p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= BigIP::iControl.3
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/p5-BigIP-iControl/distinfo b/net-mgmt/p5-BigIP-iControl/distinfo
new file mode 100644
index 000000000000..e58426950430
--- /dev/null
+++ b/net-mgmt/p5-BigIP-iControl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (BigIP-iControl-0.095.tar.gz) = a8e08c50f785bbae4f87e3e90047cc8fb6bd2f1dce354ffcabdbd8753dd8ea0a
+SIZE (BigIP-iControl-0.095.tar.gz) = 16760
diff --git a/net-mgmt/p5-BigIP-iControl/pkg-descr b/net-mgmt/p5-BigIP-iControl/pkg-descr
new file mode 100644
index 000000000000..ad6d7df3e579
--- /dev/null
+++ b/net-mgmt/p5-BigIP-iControl/pkg-descr
@@ -0,0 +1,6 @@
+This package provides a Perl interface to the F5 BigIP iControl API.
+
+The F5 BigIP iControl API is an open SOAP/XML for communicating with supported
+F5 BigIP products.
+
+WWW: http://search.cpan.org/dist/BigIP-iControl/
diff --git a/net-mgmt/p5-BigIP-iControl/pkg-plist b/net-mgmt/p5-BigIP-iControl/pkg-plist
new file mode 100644
index 000000000000..e2ed76d41ed5
--- /dev/null
+++ b/net-mgmt/p5-BigIP-iControl/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/BigIP/iControl.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/BigIP/iControl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BigIP/iControl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/BigIP
+@dirrmtry %%SITE_PERL%%/BigIP