aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-02-18 00:20:53 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-02-18 00:20:53 +0000
commita11c70c3dc85be054ad9e98d8bbec827ea0e7519 (patch)
tree321bb618c234c05155f4fc22aa834189537abec1 /net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery
parent356f831fd34b8d85465a6d8a71a6ca2efb187052 (diff)
downloadports-a11c70c3dc85be054ad9e98d8bbec827ea0e7519.tar.gz
ports-a11c70c3dc85be054ad9e98d8bbec827ea0e7519.zip
Notes
Diffstat (limited to 'net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery')
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile39
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/distinfo2
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/files/patch-lib-FusionInventory-Agent-Task-NetDiscovery.pm11
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-descr13
-rw-r--r--net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-plist25
5 files changed, 90 insertions, 0 deletions
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile
new file mode 100644
index 000000000000..3d2ed43067ee
--- /dev/null
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/Makefile
@@ -0,0 +1,39 @@
+# Created by: Emil Smolenski <am@raisa.eu.org>
+# $FreeBSD$
+
+PORTNAME= FusionInventory-Agent-Task-NetDiscovery
+PORTVERSION= 1.5
+CATEGORIES= net-mgmt
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:FUSINV
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= am@raisa.eu.org
+COMMENT= Network discovery support for FusionInventory Agent
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= p5-FusionInventory-Agent>=0:${PORTSDIR}/net-mgmt/p5-FusionInventory-Agent \
+ p5-Net-IP>=0:${PORTSDIR}/net-mgmt/p5-Net-IP \
+ p5-Net-NBName>=0:${PORTSDIR}/net/p5-Net-NBName \
+ p5-Net-SNMP>=0:${PORTSDIR}/net-mgmt/p5-Net-SNMP \
+ p5-Parallel-ForkManager>=0:${PORTSDIR}/devel/p5-Parallel-ForkManager \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-XML-TreePP>=0:${PORTSDIR}/textproc/p5-XML-TreePP
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+MAN3= FusionInventory::Agent::Task::NetDiscovery.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${RM} ${WRKSRC}/lib/FusionInventory/Agent/Task/NetDiscovery.pm.orig
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/distinfo b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/distinfo
new file mode 100644
index 000000000000..4411b6fcf37f
--- /dev/null
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/distinfo
@@ -0,0 +1,2 @@
+SHA256 (FusionInventory-Agent-Task-NetDiscovery-1.5.tar.gz) = ed1c07f41ef1f769d8396c9ba33de6b3dac32e0b7cf4cf35ce436f2642d74985
+SIZE (FusionInventory-Agent-Task-NetDiscovery-1.5.tar.gz) = 66587
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/files/patch-lib-FusionInventory-Agent-Task-NetDiscovery.pm b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/files/patch-lib-FusionInventory-Agent-Task-NetDiscovery.pm
new file mode 100644
index 000000000000..dbf62492ec14
--- /dev/null
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/files/patch-lib-FusionInventory-Agent-Task-NetDiscovery.pm
@@ -0,0 +1,11 @@
+--- lib/FusionInventory/Agent/Task/NetDiscovery.pm 2011-05-05 13:42:10.000000000 +0200
++++ lib/FusionInventory/Agent/Task/NetDiscovery.pm 2012-02-14 16:04:54.652712095 +0100
+@@ -41,7 +41,7 @@
+
+ $s .= $_ foreach @_;
+
+- return unless $s =~ /Nmap version (\S+) /;
++ return unless $s =~ /Nmap version (\d*\.?\d+)/;
+
+ return $1;
+ }
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-descr b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-descr
new file mode 100644
index 000000000000..1c90d0da4bea
--- /dev/null
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-descr
@@ -0,0 +1,13 @@
+This module scans your networks to get informations from devices with SNMP
+protocol:
+ - networking devices discovery within an IP range
+ - network switch, printer and router analyse
+ - relation between computer / printer / switch port
+ - identify unknown MAC addresses
+ - report printer cartridge and ounter status
+ - support management of SNMP versions v1, v2, v3
+
+The plugin depends on FusionInventory for GLPI. OCS Inventory can't use this
+plugin.
+
+WWW: http://search.cpan.org/dist/FusionInventory-Agent-Task-NetDiscovery/
diff --git a/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-plist b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-plist
new file mode 100644
index 000000000000..074dc70f8a88
--- /dev/null
+++ b/net-mgmt/p5-FusionInventory-Agent-Task-NetDiscovery/pkg-plist
@@ -0,0 +1,25 @@
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Dico.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Alcatel.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Axis.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Ddwrt.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Dell.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Epson.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/HewlettPackard.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Kyocera.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Ricoh.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Samsung.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Wyse.pm
+%%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer/Zebranet.pm
+%%SITE_PERL%%/mach/auto/FusionInventory/Agent/Task/NetDiscovery/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/FusionInventory/Agent/Task/NetDiscovery
+@dirrmtry %%SITE_PERL%%/mach/auto/FusionInventory/Agent/Task
+@dirrmtry %%SITE_PERL%%/mach/auto/FusionInventory/Agent
+@dirrmtry %%SITE_PERL%%/mach/auto/FusionInventory
+@dirrmtry %%SITE_PERL%%/mach/auto
+@dirrmtry %%SITE_PERL%%/mach
+@dirrm %%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery/Manufacturer
+@dirrm %%SITE_PERL%%/FusionInventory/Agent/Task/NetDiscovery
+@dirrmtry %%SITE_PERL%%/FusionInventory/Agent/Task
+@dirrmtry %%SITE_PERL%%/FusionInventory/Agent
+@dirrmtry %%SITE_PERL%%/FusionInventory