aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Nagios-Plugin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-08-24 11:13:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-08-24 11:13:51 +0000
commitc9bbdd6bef56a1b6fec5f24d2f0d52a074203e5c (patch)
tree5bf0d56562e71daec64281845f41d03ecbafeb82 /net-mgmt/p5-Nagios-Plugin
parent3161ba348e4cfd4e34ebfc75331509e638f64454 (diff)
downloadports-c9bbdd6bef56a1b6fec5f24d2f0d52a074203e5c.tar.gz
ports-c9bbdd6bef56a1b6fec5f24d2f0d52a074203e5c.zip
Notes
Diffstat (limited to 'net-mgmt/p5-Nagios-Plugin')
-rw-r--r--net-mgmt/p5-Nagios-Plugin/Makefile41
-rw-r--r--net-mgmt/p5-Nagios-Plugin/distinfo3
-rw-r--r--net-mgmt/p5-Nagios-Plugin/pkg-descr7
-rw-r--r--net-mgmt/p5-Nagios-Plugin/pkg-plist10
4 files changed, 61 insertions, 0 deletions
diff --git a/net-mgmt/p5-Nagios-Plugin/Makefile b/net-mgmt/p5-Nagios-Plugin/Makefile
new file mode 100644
index 000000000000..edb379a76964
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugin/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-Nagios-Plugin
+# Date created: 13 08 2006
+# Whom: Gerrit Beine <gerrit.beine@gmx.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Nagios-Plugin
+PORTVERSION= 0.12
+CATEGORIES= net-mgmt perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/T/TO/TONVOON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gerrit.beine@gmx.de
+COMMENT= Object oriented helper routines for Nagios plugin
+
+PERL_CONFIGURE= yes
+
+MAN3= Nagios::Plugin.3 \
+ Nagios::Plugin::Base.3 \
+ Nagios::Plugin::Performance.3 \
+ Nagios::Plugin::Range.3 \
+ Nagios::Plugin::Threshold.3 \
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= This port requires FreeBSD 5-STABLE.
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changes README
+
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/p5-Nagios-Plugin/distinfo b/net-mgmt/p5-Nagios-Plugin/distinfo
new file mode 100644
index 000000000000..d2205aa58c99
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (Nagios-Plugin-0.12.tar.gz) = 332c25b428ccd50963ac49a24eae9fcf
+SHA256 (Nagios-Plugin-0.12.tar.gz) = bea17584abf8f051efa44a83fef1fe65031fd9c5706a1582abfdae9258a7d91f
+SIZE (Nagios-Plugin-0.12.tar.gz) = 7778
diff --git a/net-mgmt/p5-Nagios-Plugin/pkg-descr b/net-mgmt/p5-Nagios-Plugin/pkg-descr
new file mode 100644
index 000000000000..82963bb59a1d
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugin/pkg-descr
@@ -0,0 +1,7 @@
+Object oriented helper routines for your Nagios plugin:
+
+This is the place for common routines when writing Nagios plugins. The idea is
+to make it as easy as possible for developers to conform to the plugin
+guidelines (http://nagiosplug.sourceforge.net/developer-guidelines.html).
+
+WWW: http://search.cpan.org/dist/Nagios-Plugins/
diff --git a/net-mgmt/p5-Nagios-Plugin/pkg-plist b/net-mgmt/p5-Nagios-Plugin/pkg-plist
new file mode 100644
index 000000000000..dff2f097f187
--- /dev/null
+++ b/net-mgmt/p5-Nagios-Plugin/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/Nagios/Plugin.pm
+%%SITE_PERL%%/Nagios/Plugin/Base.pm
+%%SITE_PERL%%/Nagios/Plugin/Performance.pm
+%%SITE_PERL%%/Nagios/Plugin/Range.pm
+%%SITE_PERL%%/Nagios/Plugin/Threshold.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios/Plugin/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Nagios
+@dirrm %%SITE_PERL%%/Nagios/Plugin
+@dirrmtry %%SITE_PERL%%/Nagios