aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/p5-Net-IPv4Addr/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-02-25 16:38:59 +0000
committerAde Lovett <ade@FreeBSD.org>2000-02-25 16:38:59 +0000
commitf652b0a0a211b11b19903445181e56404709cd29 (patch)
treeda79b3853682b4986f245325fafc4a88d6271045 /net-mgmt/p5-Net-IPv4Addr/Makefile
parent3e14cc210d4e801c84068f951cf80d5ec5d1446f (diff)
p5-Net-IPv4Addr provides functions to parse IPv4 addresses both
in traditional address/netmask format and in the new CIDR format. Methods for calculating the network and broadcast address, and also to check if a given address is in a specific network also exist. PR: 16984 Submitted by: Brad Hendrickse <bradh@uunet.co.za>
Notes
Notes: svn path=/head/; revision=26278
Diffstat (limited to 'net-mgmt/p5-Net-IPv4Addr/Makefile')
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-mgmt/p5-Net-IPv4Addr/Makefile b/net-mgmt/p5-Net-IPv4Addr/Makefile
new file mode 100644
index 000000000000..84681174a0c2
--- /dev/null
+++ b/net-mgmt/p5-Net-IPv4Addr/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Net-IPv4Addr
+# Version required: 0.08
+# Date created: 25 February 2000
+# Whom: Brad Hendrickse <bradh@uunet.co.za>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Net-IPv4Addr-0.08
+PKGNAME= p5-Net-IPv4Addr-0.08
+CATEGORIES= net perl5
+# not using CPAN due to them messing up the filename and version numbers
+MASTER_SITES= http://indev.insu.com/sources/
+
+MAINTAINER= bradh@uunet.co.za
+
+USE_PERL5= yes
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN1= ipv4calc.1
+MAN3= Net::IPv4Addr.3
+
+do-configure:
+
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL PREFIX=${PREFIX}
+
+.include <bsd.port.mk>