aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pads
diff options
context:
space:
mode:
authorFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-02-21 21:23:32 +0000
committerFelippe de Meirelles Motta <lippe@FreeBSD.org>2009-02-21 21:23:32 +0000
commit60f65fb65b59eaefafc51aa7ccf2cb9fa9d46d12 (patch)
tree1e0ee73c0d2fc4d195651daaab2af02214640563 /net-mgmt/pads
parent71184fc15ba30a7955bee3d5636141330fc9cea2 (diff)
downloadports-60f65fb65b59eaefafc51aa7ccf2cb9fa9d46d12.tar.gz
ports-60f65fb65b59eaefafc51aa7ccf2cb9fa9d46d12.zip
Notes
Diffstat (limited to 'net-mgmt/pads')
-rw-r--r--net-mgmt/pads/Makefile4
-rw-r--r--net-mgmt/pads/files/patch-src-util.c34
2 files changed, 36 insertions, 2 deletions
diff --git a/net-mgmt/pads/Makefile b/net-mgmt/pads/Makefile
index fee64deb05f4..14df522d9a0f 100644
--- a/net-mgmt/pads/Makefile
+++ b/net-mgmt/pads/Makefile
@@ -7,9 +7,9 @@
PORTNAME= pads
PORTVERSION= 1.2
+PORTREVISION= 1
CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= passive
+MASTER_SITES= SF/passive
MAINTAINER= ports@FreeBSD.org
COMMENT= Passively detect network assets
diff --git a/net-mgmt/pads/files/patch-src-util.c b/net-mgmt/pads/files/patch-src-util.c
new file mode 100644
index 000000000000..d134b1517c5b
--- /dev/null
+++ b/net-mgmt/pads/files/patch-src-util.c
@@ -0,0 +1,34 @@
+--- src/util.orig.c 2009-02-11 10:29:24.000000000 -0500
++++ src/util.c 2009-02-11 10:30:36.000000000 -0500
+@@ -117,16 +117,18 @@
+ struct passwd *this_user;
+
+ /* Default PID File */
+- if (gc.pid_file->slen >= 0)
+- gc.pid_file = bfromcstr("/var/run/pads.pid");
++ if (pid_file == NULL) {
++ pid_file = bfromcstr("/var/run/pads.pid");
++ gc.pid_file = bfromcstr("/var/run/pads.pid"); // Needed to unlink
++ }
+
+ /* Create PID File */
+- if ((fp = fopen(bdata(gc.pid_file), "w")) != NULL) {
++ if ((fp = fopen(bdata(pid_file), "w")) != NULL) {
+ pid = (int) getpid();
+ fprintf(fp, "%d\n", pid);
+ fclose(fp);
+ } else {
+- err_message("Unable to create PID file (%s).\n", bdata(gc.pid_file));
++ err_message("Unable to create PID file (%s).\n", bdata(pid_file));
+ }
+
+ /* Change PID File's Ownership */
+@@ -137,7 +139,7 @@
+ err_message("'%s' group does not appear to exist.", bdata(group));
+ if ((this_user = getpwnam(bdata(user))) == NULL)
+ err_message("'%s' user does not appear to exist.", bdata(user));
+- if ((chown(pid_file, this_user->pw_uid, this_group->gr_gid)) != 0)
++ if ((chown(bdata(pid_file), this_user->pw_uid, this_group->gr_gid)) != 0)
+ err_message("Unable to change PID file's ownership.");
+
+ }