aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pandorafms_console/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-08-20 20:01:17 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-08-20 20:01:17 +0000
commit582199510db502c680d3538a1b0112f3e6f2009a (patch)
treeadb6f8fd0786b54d43d2576035a6ddfe2d0b8298 /net-mgmt/pandorafms_console/Makefile
parent2c9868acf9f2e3603d7cc4b4f5b823089c519f08 (diff)
Notes
Diffstat (limited to 'net-mgmt/pandorafms_console/Makefile')
-rw-r--r--net-mgmt/pandorafms_console/Makefile45
1 files changed, 19 insertions, 26 deletions
diff --git a/net-mgmt/pandorafms_console/Makefile b/net-mgmt/pandorafms_console/Makefile
index aa0c61d93809..20e41085622c 100644
--- a/net-mgmt/pandorafms_console/Makefile
+++ b/net-mgmt/pandorafms_console/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= pandora_console
-PORTVERSION= ${PANDORA_VERSION}
-PORTREVISION= 1
CATEGORIES= net-mgmt
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= koichiro@rworks.jp
COMMENT= Pandora FMS console
LICENSE= ${PANDORA_LICENSE}
@@ -14,20 +12,21 @@ LICENSE_FILE= ${PANDORA_LICENSE_FILE}
RUN_DEPENDS= ${LOCALBASE}/bin/twopi:${PORTSDIR}/graphics/graphviz
-OPTIONS_DEFINE= PGSQL
+OPTIONS_DEFINE= DOCS PGSQL
+DOCS_DESC= Install AUTHORS and ChangeLog
PGSQL_DESC= Use PostgreSQL backend (experimental)
-USE_APACHE_RUN= 22+
USE_PHP= curl gd gettext json ldap mbstring mysql snmp session \
xml zip zlib
WANT_PHP_WEB= yes
+USE_APACHE_RUN= 22+
-SUB_FILES+= pandora_console.conf
-SUB_LIST+= APACHEETCDIR=${PREFIX}/${APACHEETCDIR}
+SUB_FILES+= pandora_console.conf pkg-message
-NO_STAGE= yes
.include "${.CURDIR}/../pandorafms_server/bsd.pandora.mk"
+PANDORA_INSTALLER_ARGS+= --destdir ${STAGEDIR}
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPGSQL}
@@ -36,7 +35,7 @@ USE_PHP+= pgsql
post-patch:
@${REINPLACE_CMD} \
- -e "s|%%WWWDIR%%|${WWWDIR}|g" \
+ -e "\|PANDORA_HOME=|s|=[^;]*|=${WWWDIR}|g" \
${WRKSRC}/pandora_console_install
@${REINPLACE_CMD} \
-e "s|/usr/bin|${LOCALBASE}/bin|g" \
@@ -46,28 +45,22 @@ post-patch:
${WRKSRC}/extras/check_other_languages.sh \
${WRKSRC}/include/languages/extract_newlines.sh
-do-install:
- @cd ${WRKSRC} && ${SH} pandora_console_install --force-install
-
post-install:
+ @cd ${STAGEDIR}${WWWDIR} \
+ && ${RM} -rf pandora_console_install* *.spec \
+ extras/check_other_languages.sh.bak \
+ include/languages/extract_newlines.sh.bak \
+ *.sql.bak COPYING ${PORTDOCS} DEBIAN/
+ @cd ${STAGEDIR}${WWWDIR} && ${MV} install.php install.done
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for x in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${x} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${x} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
- @cd ${WWWDIR} \
- && ${RM} -rf pandora_console_install* \
- pandora_console_upgrade *.spec \
- extras/check_other_languages.sh.bak \
- include/languages/extract_newlines.sh.bak \
- *.sql.bak COPYING ${PORTDOCS} DEBIAN/
- @if [ -e ${WWWDIR}/include/config.php ]; then \
- ${MV} ${WWWDIR}/install.php ${WWWDIR}/install.done; \
- fi;
- @${MKDIR} ${PREFIX}/${APACHEETCDIR}/Includes
+ @${MKDIR} -p ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes
@${INSTALL_DATA} ${WRKDIR}/pandora_console.conf \
- ${PREFIX}/${APACHEETCDIR}/Includes/pandora_console.conf
- @${LN} -sf ${_LICENSE_DIR}/${LICENSE} ${WWWDIR}/COPYING
+ ${STAGEDIR}${PREFIX}/${APACHEETCDIR}/Includes/pandora_console.conf.sample
+ @${LN} -sf ${_LICENSE_DIR}/${LICENSE} ${STAGEDIR}${WWWDIR}/COPYING
.include <bsd.port.post.mk>