aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/percona-monitoring-plugins/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2012-09-20 03:56:48 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2012-09-20 03:56:48 +0000
commit56fe090a2955eb4887f4f2aa4f401dc6aec3a1d7 (patch)
treed84b5f4019e4c45ea64141ea074eb5a98bbc8b82 /net-mgmt/percona-monitoring-plugins/Makefile
parente96f101fbb6372b2db364fcc779842cf0d12713e (diff)
Notes
Diffstat (limited to 'net-mgmt/percona-monitoring-plugins/Makefile')
-rw-r--r--net-mgmt/percona-monitoring-plugins/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-mgmt/percona-monitoring-plugins/Makefile b/net-mgmt/percona-monitoring-plugins/Makefile
new file mode 100644
index 000000000000..2f6f4bd26b99
--- /dev/null
+++ b/net-mgmt/percona-monitoring-plugins/Makefile
@@ -0,0 +1,58 @@
+# Created By: Alexey V. Degtyarev <alexey@renatasystems.org>
+# $FreeBSD$
+
+PORTNAME= percona-monitoring-plugins
+PORTVERSION= 1.0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://www.percona.com/downloads/percona-monitoring-plugins/ \
+ ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
+
+MAINTAINER= alexey@renatasystems.org
+COMMENT= Cacti templates for MySQL, Apache, Memcached, and more by Percona
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= cacti>=0:${PORTSDIR}/net-mgmt/cacti \
+ p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql \
+ p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+
+USE_MYSQL= yes
+USE_PHP= yes
+WANT_PHP_CLI= yes
+
+NO_BUILD= yes
+
+CACTIDIR?= share/cacti
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= Changelog
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/${doc}
+.endfor
+.endif
+
+ ${MKDIR} ${PREFIX}/share/cacti/scripts
+ ${MKDIR} ${PREFIX}/share/percona-monitoring-plugins
+
+.for dir in definitions misc templates
+ cd ${WRKSRC} && ${PAX} -r -w cacti/${dir} \
+ ${PREFIX}/share/percona-monitoring-plugins
+.endfor
+
+.for script in ss_get_by_ssh.php ss_get_mysql_stats.php
+ ${INSTALL_DATA} ${WRKSRC}/cacti/scripts/${script} \
+ ${PREFIX}/share/cacti/scripts/${script}
+.endfor
+
+ ${INSTALL_SCRIPT} ${WRKSRC}/cacti/bin/* ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/nagios/bin/* ${PREFIX}/bin
+
+.include <bsd.port.mk>