aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pftabled
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 16:22:57 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-20 16:22:57 +0000
commit4509c380cadb646d97eec668db6cbd1e2af885f1 (patch)
treede717a9bc3a2e831830cfaea29c15bc62c002d60 /net-mgmt/pftabled
parentd8216e53b584fc55fb84b44191dd70f9cb20744a (diff)
downloadports-4509c380cadb646d97eec668db6cbd1e2af885f1.tar.gz
ports-4509c380cadb646d97eec668db6cbd1e2af885f1.zip
Notes
Diffstat (limited to 'net-mgmt/pftabled')
-rw-r--r--net-mgmt/pftabled/Makefile15
-rw-r--r--net-mgmt/pftabled/files/patch-Makefile.in17
2 files changed, 23 insertions, 9 deletions
diff --git a/net-mgmt/pftabled/Makefile b/net-mgmt/pftabled/Makefile
index 7aa61be5f785..f5be58946c5f 100644
--- a/net-mgmt/pftabled/Makefile
+++ b/net-mgmt/pftabled/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pftabled
PORTVERSION= 1.09
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= http://www.wolfermann.org/
@@ -10,19 +11,18 @@ MAINTAINER= chifeng@gmail.com
COMMENT= The pftabled is a tool to manage your pf tables remotely
USE_RC_SUBR= pftabled
-MAN1= pftabled.0
-PLIST_FILES= bin/pftabled-client sbin/pftabled
+PLIST_FILES= bin/pftabled-client man/man1/pftabled.1.gz sbin/pftabled
GNU_CONFIGURE= yes
-USES= gmake
+USES= gmake shebangfix
+SHEBANG_FILES= pftabled-client.pl
OPTIONS_DEFINE= PERLC PYTHONC
OPTIONS_DEFAULT= PERLC PYTHONC
PERLC_DESC= A Sample Perl Client
PYTHONC_DESC= A Sample Python Client
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPERLC}
@@ -33,15 +33,12 @@ PLIST_FILES+= bin/pftabled-client.pl
PLIST_FILES+= bin/pftabled-client.py
.endif
-post-patch:
- @${REINPLACE_CMD} -e 's|cat1/pftabled.0|man1/pftabled.0|' ${WRKSRC}/Makefile.in
-
post-install:
.if ${PORT_OPTIONS:MPERLC}
- ${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.pl ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.pl ${STAGEDIR}${PREFIX}/bin/
.endif
.if ${PORT_OPTIONS:MPYTHONC}
- ${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.py ${PREFIX}/bin/
+ ${INSTALL_SCRIPT} ${WRKSRC}/pftabled-client.py ${STAGEDIR}${PREFIX}/bin/
.endif
.include <bsd.port.post.mk>
diff --git a/net-mgmt/pftabled/files/patch-Makefile.in b/net-mgmt/pftabled/files/patch-Makefile.in
new file mode 100644
index 000000000000..6c70cf442258
--- /dev/null
+++ b/net-mgmt/pftabled/files/patch-Makefile.in
@@ -0,0 +1,17 @@
+--- Makefile.in.orig 2014-06-21 00:18:35.407089008 +0800
++++ Makefile.in 2014-06-21 00:19:16.975090050 +0800
+@@ -36,11 +36,11 @@ pftabled-client: ${CLIENTOBJS}
+ install: @INSTALLTARGET@
+
+ server-install: pftabled pftabled.cat1
+- ${INSTALL} -s -m 555 pftabled ${sbindir}
+- ${INSTALL} -m 444 pftabled.cat1 ${mandir}/cat1/pftabled.0
++ ${INSTALL} -s -m 555 pftabled $(DESTDIR)${sbindir}
++ ${INSTALL} -m 444 pftabled.cat1 $(DESTDIR)${mandir}/man1/pftabled.1
+
+ client-install: pftabled-client
+- ${INSTALL} -s -m 555 pftabled-client ${bindir}
++ ${INSTALL} -s -m 555 pftabled-client $(DESTDIR)${bindir}
+
+ clean:
+ -rm -f pftabled pftabled-client *.o *.cat1