aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/phpweathermap/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 17:16:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-14 17:16:57 +0000
commitdd7be453cc5c5fbcb1d90617358a7164c644a6c8 (patch)
tree355bd1dc3789e17d8391b93628355c4ac90d3c26 /net-mgmt/phpweathermap/Makefile
parent79721c371493c3a12d8d3c3ffe054dea7325ec88 (diff)
Notes
Diffstat (limited to 'net-mgmt/phpweathermap/Makefile')
-rw-r--r--net-mgmt/phpweathermap/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/net-mgmt/phpweathermap/Makefile b/net-mgmt/phpweathermap/Makefile
index faedf75f8730..6aaf458db389 100644
--- a/net-mgmt/phpweathermap/Makefile
+++ b/net-mgmt/phpweathermap/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpweathermap
PORTVERSION= 0.97a
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
MASTER_SITES= http://www.network-weathermap.com/files/
DISTNAME= php-weathermap-${PORTVERSION}
@@ -12,11 +12,13 @@ MAINTAINER= hhyou@cs.nctu.edu.tw
COMMENT= Network visualisation tool with web editor
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/share/pear/Console/Getopt.php:${PORTSDIR}/devel/pear \
rrdtool:${PORTSDIR}/databases/rrdtool
NO_BUILD= yes
+NO_ARCH= yes
USES= zip
USE_PHP= gd
@@ -34,9 +36,10 @@ WRKSRC= ${WRKDIR}/weathermap
SUB_FILES= pkg-message
+PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
+
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/editor.php
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
@@ -53,18 +56,14 @@ do-install:
done
@${CP} -R ${WRKSRC}/lib ${STAGEDIR}/${DATADIR}
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "${WM_WWW_DIRS}" ${STAGEDIR}/${DATADIR}/www)
- @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}/${DATADIR}/www
-.if ${PORT_OPTIONS:MEXAMPLES}
+do-install-EXAMPLES-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} "random-bits" ${STAGEDIR}/${EXAMPLESDIR})
- @${FIND} ${STAGEDIR}/${EXAMPLESDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
- @${FIND} ${STAGEDIR}/${EXAMPLESDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-.endif
+ ${FIND} ${STAGEDIR}/${EXAMPLESDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} 644
+ ${FIND} ${STAGEDIR}/${EXAMPLESDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} 755
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}/${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}/${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}/${DOCSDIR}
.include <bsd.port.mk>