aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pixilate
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net-mgmt/pixilate
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net-mgmt/pixilate')
-rw-r--r--net-mgmt/pixilate/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-mgmt/pixilate/Makefile b/net-mgmt/pixilate/Makefile
index 38a3cdd50378..fd21bcf9c904 100644
--- a/net-mgmt/pixilate/Makefile
+++ b/net-mgmt/pixilate/Makefile
@@ -6,7 +6,7 @@
PORTNAME= pixilate
PORTVERSION= 0.4.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= winfingerprint
@@ -14,25 +14,28 @@ MASTER_SITE_SUBDIR= winfingerprint
MAINTAINER= ports@FreeBSD.org
COMMENT= Generates packets to match a list of Cisco PIX access lists
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
WRKSRC= ${WRKDIR}/pixilate
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet-config
-CFLAGS+= `${LIBNET_CONFIG} --cflags` `${LIBNET_CONFIG} --defines`
-CFLAGS+= -I${LOCALBASE}/include
-LIBS= `${LIBNET_CONFIG} --libs`
-GNU_CONFIGURE= yes
-USE_AUTOTOOLS= automake:15 autoconf:253
+USE_AUTOTOOLS= automake:15 autoconf:259
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
+#CONFIGURE_ENV= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${LIBS}" CPPFLAGS="-I${LOCALBASE}/include"
MAN1= pixilate.1
PORTDOCS= README
PLIST_FILES= bin/pixilate
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|libnet-config|${LIBNET_CONFIG}|; \
+ s|--defines`|& `${LIBNET_CONFIG} --cflags`|' \
+ ${WRKSRC}/configure.ac
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}