aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-05-27 12:57:25 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-05-27 12:57:25 +0000
commit1577a14a242fa67c2dabdd7076a7b91d0ed4dc74 (patch)
treecfa854295934b7fd2692406bf7c9ad9ac0cd449b /net-mgmt/pmacct/Makefile
parent17430d6dd144ee427034612683883eb1f44b5fca (diff)
downloadports-1577a14a242fa67c2dabdd7076a7b91d0ed4dc74.tar.gz
ports-1577a14a242fa67c2dabdd7076a7b91d0ed4dc74.zip
Notes
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile31
1 files changed, 23 insertions, 8 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 75c7cfbe93e7..7bef041f12a2 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,13 +6,27 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.8.5
+PORTVERSION= 0.8.6
CATEGORIES= net-mgmt
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
MAINTAINER= krion@FreeBSD.org
COMMENT= Accounting and aggregation tool for IPv4 and IPv6 traffic
+GNU_CONFIGURE= yes
+GNUCONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETOPT_LONG=yes
+USE_REINPLACE= yes
+
+OPTIONS= MYSQL "Enable MySQL support." Off \
+ PGSQL "Enable PostgreSQL support." Off \
+ MMAP "Disable mmap(2) support." Off \
+ LAYER2 "Disable Layer-2 support: MAC Adresses and VLANs" Off
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+=--enable-mysql
@@ -32,15 +46,16 @@ PLIST_SUB+= WITH_PGSQL="@comment "
.endif
.if defined(WITHOUT_MMAP)
+CONFIGURE_ARGS+=--enable-mmap
+.else
CONFIGURE_ARGS+=--disable-mmap
.endif
-GNU_CONFIGURE= yes
-GNUCONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-USE_GETOPT_LONG=yes
-USE_REINPLACE= yes
+.if defined(WITHOUT_LAYER2)
+CONFIGURE_ARGS+=--enable-l2
+.else
+CONFIGURE_ARGS+=--disable-l2
+.endif
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
@@ -55,4 +70,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>