aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-06-07 20:02:06 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-06-07 20:02:06 +0000
commit739a673bc51aef57b999a18092bd16746af2df41 (patch)
tree6272b11d694fb120ac1adb42ecee4b6f3b839e67 /net-mgmt/pmacct/Makefile
parent14ffd13f1468077edb231b1105b27b2f23520b83 (diff)
Notes
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index b48cafd00008..6e4b91bf7f71 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= pmacct
-DISTVERSION= 1.7.0
-PORTREVISION= 1
+DISTVERSION= 1.7.3
CATEGORIES= net-mgmt
MASTER_SITES= http://www.pmacct.net/
@@ -14,6 +13,7 @@ LICENSE= GPLv2
BROKEN_aarch64= fails to build: undefined reference to sbrk
+USES= libtool
USE_RC_SUBR= pmacctd nfacctd sfacctd
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
@@ -104,6 +104,7 @@ CONFIGURE_ARGS+=--disable-mongodb
.if ${PORT_OPTIONS:MRABBITMQ}
.if ${PORT_OPTIONS:MJANSSON}
+USES+= pkgconfig
LIB_DEPENDS+= libjansson.so:devel/jansson
CONFIGURE_ARGS+=--enable-jansson
.else
@@ -115,6 +116,7 @@ CONFIGURE_ARGS+=--enable-rabbitmq
.if ${PORT_OPTIONS:MKAFKA}
.if ${PORT_OPTIONS:MJANSSON}
+USES+= pkgconfig
LIB_DEPENDS+= libjansson.so:devel/jansson
CONFIGURE_ARGS+=--enable-jansson
.else
@@ -159,7 +161,7 @@ post-install:
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
-.for i in AUTHORS CONFIG-KEYS COPYING ChangeLog FAQS INSTALL QUICKSTART TOOLS UPGRADE
+.for i in AUTHORS CONFIG-KEYS COPYING ChangeLog FAQS INSTALL QUICKSTART UPGRADE
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
@${MKDIR} ${STAGEDIR}${DATADIR}