aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pmacct/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-12-10 09:45:32 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-12-10 09:45:32 +0000
commit303b1c78db0560a9e330b4006d3b6f50dea2b026 (patch)
tree15efb5d12029efffb8dc52aa3b9e40f6e03bfba4 /net-mgmt/pmacct/Makefile
parentcc2f41715715a303d47ed30a3c6f898839753aca (diff)
downloadports-303b1c78db0560a9e330b4006d3b6f50dea2b026.tar.gz
ports-303b1c78db0560a9e330b4006d3b6f50dea2b026.zip
Notes
Diffstat (limited to 'net-mgmt/pmacct/Makefile')
-rw-r--r--net-mgmt/pmacct/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index e00196f7ae9b..7f34939069a3 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pmacct
-PORTVERSION= 0.9.4p1
+PORTVERSION= 0.9.5
CATEGORIES= net-mgmt
MASTER_SITES= http://www.ba.cnr.it/~paolo/pmacct/
@@ -17,12 +17,12 @@ GNU_CONFIGURE= yes
GNUCONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-WRKSRC= ${WRKDIR}/${PORTNAME}-0.9.4
USE_GETOPT_LONG=yes
USE_REINPLACE= yes
OPTIONS= MYSQL "Enable MySQL support." Off \
PGSQL "Enable PostgreSQL support." Off \
+ SQLITE "Enable SQLite support." Off \
MMAP "Enable mmap(2) support." On \
LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" On
@@ -50,6 +50,14 @@ CONFIGURE_ARGS+= --disable-pgsql
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
+.if defined(WITH_SQLITE)
+LIB_DEPENDS+= sqlite3.8:${PORTSDIR}/databases/sqlite3
+CONFIGURE_ARGS+=--enable-sqlite3 \
+ --with-sqlite3-includes=${LOCALBASE}/include
+.else
+CONFIGURE_ARGS+=--disable-sqlite3
+.endif
+
.if defined(WITHOUT_MMAP)
CONFIGURE_ARGS+=--disable-mmap
.else