aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pmacct
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-04-26 21:33:54 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-04-26 21:33:54 +0000
commit99d25e58dbdc4bae84c8cee6e9c1f1b20848a6a8 (patch)
tree60550202cb257201320cf4e00ec6d444d3f3bab7 /net-mgmt/pmacct
parent99fba26b24ed08c81cb9fe201d5b821752a30b26 (diff)
downloadports-99d25e58dbdc4bae84c8cee6e9c1f1b20848a6a8.tar.gz
ports-99d25e58dbdc4bae84c8cee6e9c1f1b20848a6a8.zip
Notes
Diffstat (limited to 'net-mgmt/pmacct')
-rw-r--r--net-mgmt/pmacct/Makefile35
-rw-r--r--net-mgmt/pmacct/distinfo4
-rw-r--r--net-mgmt/pmacct/files/patch-src__isis__sockunion.c11
-rw-r--r--net-mgmt/pmacct/files/patch-src__ll.c11
-rw-r--r--net-mgmt/pmacct/files/pkg-message.in2
-rw-r--r--net-mgmt/pmacct/pkg-plist56
6 files changed, 66 insertions, 53 deletions
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index ebff70b8cea9..fd931e01049f 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= pmacct
-DISTVERSION= 0.12.5
-PORTREVISION= 1
+DISTVERSION= 0.14.0
CATEGORIES= net-mgmt
MASTER_SITES= http://www.pmacct.net/ \
http://mirrors.rit.edu/zi/
@@ -23,18 +22,20 @@ GNU_CONFIGURE= yes
CPPFLAGS+= "-I${LOCALBASE}/include"
LDFLAGS+= "-L${LOCALBASE}/lib"
-OPTIONS= MYSQL "Enable MySQL support." Off \
- PGSQL "Enable PostgreSQL support." Off \
- SQLITE "Enable SQLite support." Off \
- THREADS "Enable multi-threading." Off \
- MMAP "Enable mmap(2) support." On \
- LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" On \
- IPV6 "Enable IPv6 support." On
+OPTIONS= MYSQL "Enable MySQL support" off \
+ PGSQL "Enable PostgreSQL support" off \
+ SQLITE "Enable SQLite support" off \
+ THREADS "Enable multi-threading" off \
+ MMAP "Enable mmap(2) support" on \
+ LAYER2 "Enable Layer-2 support: MAC Adresses and VLANs" on \
+ IPV6 "Enable IPv6 support" on \
+ SHARED "Enable shared objects" on \
+ DEBUG "Enable debugging" off
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} == "sparc64"
-CONFIGURE_ARGS+= --enable-64bit
+CONFIGURE_ARGS+=--enable-64bit
.endif
.if defined(WITH_MYSQL)
@@ -42,7 +43,7 @@ USE_MYSQL= yes
CONFIGURE_ARGS+=--enable-mysql
PLIST_SUB+= WITH_MYSQL=""
.else
-CONFIGURE_ARGS+= --disable-mysql
+CONFIGURE_ARGS+=--disable-mysql
PLIST_SUB+= WITH_MYSQL="@comment "
.endif
@@ -51,7 +52,7 @@ USE_PGSQL= yes
CONFIGURE_ARGS+=--enable-pgsql
PLIST_SUB+= WITH_PGSQL=""
.else
-CONFIGURE_ARGS+= --disable-pgsql
+CONFIGURE_ARGS+=--disable-pgsql
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
@@ -87,12 +88,22 @@ CONFIGURE_ARGS+=--enable-threads
CONFIGURE_ARGS+=--disable-threads
.endif
+.if defined(WITHOUT_SHARED)
+CONFIGURE_ARGS+=--disable-so
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+=--enable-debug
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' ${WRKSRC}/configure
post-install:
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for i in ChangeLog EXAMPLES FAQS README
diff --git a/net-mgmt/pmacct/distinfo b/net-mgmt/pmacct/distinfo
index 8f94c0c35a46..a43fb2620472 100644
--- a/net-mgmt/pmacct/distinfo
+++ b/net-mgmt/pmacct/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pmacct-0.12.5.tar.gz) = 5252d7df24e9baefcc5a36ed66e9cac5ae505c9d502c8cffb96e6808acbb2fe8
-SIZE (pmacct-0.12.5.tar.gz) = 552007
+SHA256 (pmacct-0.14.0.tar.gz) = c4b4ed5608c600910bd580f92faefd8d3af0f6d5c4aabddb5ce31c6d192e0336
+SIZE (pmacct-0.14.0.tar.gz) = 700794
diff --git a/net-mgmt/pmacct/files/patch-src__isis__sockunion.c b/net-mgmt/pmacct/files/patch-src__isis__sockunion.c
new file mode 100644
index 000000000000..9ecc400eff6c
--- /dev/null
+++ b/net-mgmt/pmacct/files/patch-src__isis__sockunion.c
@@ -0,0 +1,11 @@
+--- ./src/isis/sockunion.c.orig 2012-04-26 16:51:31.000000000 -0400
++++ ./src/isis/sockunion.c 2012-04-26 16:51:56.000000000 -0400
+@@ -625,7 +625,7 @@
+ struct sockaddr_dl *sdl;
+
+ sdl = (struct sockaddr_dl *)&(su->sa);
+- printf ("link#%d\n", sdl->sdl_index);
++ //printf ("link#%d\n", sdl->sdl_index);
+ }
+ break;
+ #endif /* AF_LINK */
diff --git a/net-mgmt/pmacct/files/patch-src__ll.c b/net-mgmt/pmacct/files/patch-src__ll.c
deleted file mode 100644
index 42c55ba28b45..000000000000
--- a/net-mgmt/pmacct/files/patch-src__ll.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./src/ll.c.orig 2011-06-30 20:43:06.000000000 -0400
-+++ ./src/ll.c 2011-06-30 20:43:45.000000000 -0400
-@@ -118,7 +118,7 @@
-
- if (*caplen < 4) {
- pptrs->iph_ptr = NULL;
-- return;
-+ return 0;
- }
-
- do {
diff --git a/net-mgmt/pmacct/files/pkg-message.in b/net-mgmt/pmacct/files/pkg-message.in
index c0b30e7a1a95..7fec298a6f6d 100644
--- a/net-mgmt/pmacct/files/pkg-message.in
+++ b/net-mgmt/pmacct/files/pkg-message.in
@@ -5,7 +5,7 @@ Add these to /etc/rc.conf:
pmacctd_enable="YES"
pmacctd_flags="-DF %%PREFIX%%/etc/pmacctd.conf -i <interface>"
-Configuration examples are located in %%EXAMPLESDIR%%. You must copy
+Configuration examples are located in %%EXAMPLESDIR%%. You must copy
one of these to %%PREFIX%%/etc/pmacctd.conf and make any required edits
for your environment.
diff --git a/net-mgmt/pmacct/pkg-plist b/net-mgmt/pmacct/pkg-plist
index fe7ddd0475d5..7d0b84a7222e 100644
--- a/net-mgmt/pmacct/pkg-plist
+++ b/net-mgmt/pmacct/pkg-plist
@@ -9,9 +9,10 @@ sbin/uacctd
%%DATADIR%%/README.IPv6
%%DATADIR%%/README.agent_id2
%%DATADIR%%/README.cos
+%%DATADIR%%/README.etype
%%DATADIR%%/README.iface
-%%DATADIR%%/README.is_symmetric
%%DATADIR%%/README.mask
+%%DATADIR%%/README.mpls_vpn_rd
%%DATADIR%%/README.mysql
%%DATADIR%%/README.pgsql
%%DATADIR%%/README.sqlite3
@@ -48,30 +49,31 @@ sbin/uacctd
%%PORTDOCS%%%%DOCSDIR%%/EXAMPLES
%%PORTDOCS%%%%DOCSDIR%%/FAQS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%EXAMPLESDIR%%/agent_to_peer.map.example
-%%EXAMPLESDIR%%/bgp_md5.lst.example
-%%EXAMPLESDIR%%/allow-list.example
-%%EXAMPLESDIR%%/is_symmetric.map.example
-%%EXAMPLESDIR%%/gnuplot-example.sh
-%%EXAMPLESDIR%%/gnuplot.script.example
-%%EXAMPLESDIR%%/lpref.map.example
-%%EXAMPLESDIR%%/med.map.example
-%%EXAMPLESDIR%%/mrtg-example.sh
-%%EXAMPLESDIR%%/mrtg.conf.example
-%%EXAMPLESDIR%%/networks.lst.example
-%%EXAMPLESDIR%%/nfacctd-print.conf.example
-%%EXAMPLESDIR%%/nfacctd-sql_v1.conf.example
-%%EXAMPLESDIR%%/nfacctd-sql_v2.conf.example
-%%EXAMPLESDIR%%/peers.map.example
-%%EXAMPLESDIR%%/pmacctd-imt.conf.example
-%%EXAMPLESDIR%%/pmacctd-multiple-plugins.conf.example
-%%EXAMPLESDIR%%/pmacctd-sql_v1.conf.example
-%%EXAMPLESDIR%%/pmacctd-sql_v2.conf.example
-%%EXAMPLESDIR%%/pmacctd-sqlite3_v4.conf.example
-%%EXAMPLESDIR%%/ports.lst.example
-%%EXAMPLESDIR%%/pretag.map.example
-%%EXAMPLESDIR%%/probe_netflow.conf.example
-%%EXAMPLESDIR%%/probe_sflow.conf.example
-%%EXAMPLESDIR%%/rrdtool-example.sh
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/agent_to_peer.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bgp_md5.lst.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/allow-list.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/iface_to_rd.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnuplot-example.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gnuplot.script.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/lpref.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/med.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mrtg-example.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mrtg.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/networks.lst.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nfacctd-print.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nfacctd-sql_v1.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nfacctd-sql_v2.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/peers.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmacctd-imt.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmacctd-multiple-plugins.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmacctd-sql_v1.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmacctd-sql_v2.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pmacctd-sqlite3_v4.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ports.lst.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pretag.map.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/probe_netflow.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/probe_sflow.conf.example
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rrdtool-example.sh
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sampling.map.example
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%