aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pnp/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-08-18 15:42:50 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-08-18 15:42:50 +0000
commitd4dff41f01150989f9378c3bc34d762b6fec9cd5 (patch)
tree7a30380a3906868d1d96931fb3b461a47eddfb73 /net-mgmt/pnp/Makefile
parent8edf38e1e74c6f03451b98353bb7aef1d2e5be80 (diff)
downloadports-d4dff41f01150989f9378c3bc34d762b6fec9cd5.tar.gz
ports-d4dff41f01150989f9378c3bc34d762b6fec9cd5.zip
Notes
Diffstat (limited to 'net-mgmt/pnp/Makefile')
-rw-r--r--net-mgmt/pnp/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-mgmt/pnp/Makefile b/net-mgmt/pnp/Makefile
index 37124d1771aa..5e63cebf36df 100644
--- a/net-mgmt/pnp/Makefile
+++ b/net-mgmt/pnp/Makefile
@@ -1,5 +1,5 @@
# New ports collection makefile for: pnp
-# Date created: unknown
+# Date created: 16 August 2008
# Whom: rea-fbsd@codelabs.ru
#
# $FreeBSD$
@@ -7,7 +7,7 @@
PORTNAME= pnp
PORTVERSION= 0.4.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pnp4nagios
@@ -21,9 +21,10 @@ RUN_DEPENDS= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
OPTIONS= PDF "Use built-in fpdf library to produce PDF views" ON
-USE_PHP= yes
+USE_PHP= zlib gd xml
WANT_PHP_WEB= yes
USE_RC_SUBR= npcd.sh
+MAN1= pnpsender.1
NAGIOSDIR?= /var/spool/nagios
NAGIOSHTMURL?= /nagios
@@ -35,7 +36,6 @@ PNP_SPOOL= ${PNP_STATE}/perfspool
FPDF_DIR?= share/fpdf
.if defined(WITH_PDF)
-USE_PHP= zlib
.else
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-share::pnp::include::function.inc.php
.endif
@@ -85,6 +85,9 @@ post-patch:
.endfor
post-install:
+.for m in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/man1/${m} ${MAN1PREFIX}/man/man1/${m}
+.endfor
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}