aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/pnp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-12-25 00:32:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-12-25 00:32:12 +0000
commitd2d864e5435eb79eac09a63b87c3987a6aa0cf1a (patch)
tree3e5eec11a643fc0fa185ede47ee88bb2db14c27a /net-mgmt/pnp
parent52039b88f7c50b7ddfb31420c13d012a5b25b72b (diff)
downloadports-d2d864e5435eb79eac09a63b87c3987a6aa0cf1a.tar.gz
ports-d2d864e5435eb79eac09a63b87c3987a6aa0cf1a.zip
Notes
Diffstat (limited to 'net-mgmt/pnp')
-rw-r--r--net-mgmt/pnp/Makefile8
-rw-r--r--net-mgmt/pnp/distinfo6
-rw-r--r--net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php54
-rw-r--r--net-mgmt/pnp/files/patch-sample-config::Makefile.in64
-rw-r--r--net-mgmt/pnp/files/patch-scripts::Makefile.in37
-rw-r--r--net-mgmt/pnp/files/patch-share::Makefile.in68
-rw-r--r--net-mgmt/pnp/files/patch-src::Makefile.in13
-rw-r--r--net-mgmt/pnp/files/pkg-message.in5
-rw-r--r--net-mgmt/pnp/pkg-plist11
9 files changed, 88 insertions, 178 deletions
diff --git a/net-mgmt/pnp/Makefile b/net-mgmt/pnp/Makefile
index 98fe6b41a815..b7c93a4fa671 100644
--- a/net-mgmt/pnp/Makefile
+++ b/net-mgmt/pnp/Makefile
@@ -6,11 +6,9 @@
#
PORTNAME= pnp
-PORTVERSION= 0.4.10
-PORTREVISION= 3
+PORTVERSION= 0.4.12
CATEGORIES= net-mgmt
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= pnp4nagios
+MASTER_SITES= SF/pnp4nagios
MAINTAINER= rea-fbsd@codelabs.ru
COMMENT= Nagios performance data collector and grapher
@@ -43,6 +41,8 @@ EXTRA_PATCHES+= ${FILESDIR}/extra-patch-share::pnp::include::function.inc.php
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= \
--prefix=${LOCALBASE} \
+ --sysconfdir=${PREFIX}/etc/pnp \
+ --datarootdir=${WWWDIR} \
--datadir=${WWWDIR} \
--localstatedir=/var/log \
--with-rrdtool=${LOCALBASE}/bin/rrdtool \
diff --git a/net-mgmt/pnp/distinfo b/net-mgmt/pnp/distinfo
index 1487e8a6f420..8bf304b08ce4 100644
--- a/net-mgmt/pnp/distinfo
+++ b/net-mgmt/pnp/distinfo
@@ -1,3 +1,3 @@
-SIZE (pnp-0.4.10.tar.gz) = 301021
-MD5 (pnp-0.4.10.tar.gz) = 5e57d50e2d895878b626497fd7b217b7
-SHA256 (pnp-0.4.10.tar.gz) = 35392c83fc9468eba38187e17b773090dff923f7b74c86c3c11e2574b99c214d
+MD5 (pnp-0.4.12.tar.gz) = eb833a4769a5b58aad0ac53cae3e3e9f
+SHA256 (pnp-0.4.12.tar.gz) = 8b74ff0fd32a08e416d0f760c36166aec67bfc1e839dd3c07c1dc08db69d96fb
+SIZE (pnp-0.4.12.tar.gz) = 311844
diff --git a/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php b/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php
index 7fe0021b2b1b..c42e389da088 100644
--- a/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php
+++ b/net-mgmt/pnp/files/extra-patch-share::pnp::include::function.inc.php
@@ -1,6 +1,6 @@
---- share/pnp/include/function.inc.php.orig 2008-06-18 12:02:41.000000000 +0400
-+++ share/pnp/include/function.inc.php 2008-08-16 23:35:30.000000000 +0400
-@@ -819,114 +819,15 @@
+--- share/pnp/include/function.inc.php.orig 2008-10-11 18:13:34.000000000 +0400
++++ share/pnp/include/function.inc.php 2008-12-24 01:03:58.000000000 +0300
+@@ -982,123 +982,6 @@
}
function doPDF($display,$data) {
@@ -54,12 +54,16 @@
- $pdf->AddPage();
- if($use_bg){$pdf->useTemplate($tplIdx);}
- }
--
-- $pdf->SetFont('Arial', '', 10);
-- $pdf->CELL(120, 5, $d["n_hostname"]." / ".$d["n_servicedesc"] , 0, 1);
-- $pdf->SetFont('Arial', '', 8);
-- $pdf->CELL(120, 5, $d["view_title"]. " (" . $d["f_start"]." - ".$d["f_end"].")", 0, 1);
--
+- if($d['source'] == 1){
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->CELL(120, 5, $d["n_hostname"]." / ".$d["n_servicedesc"] , 0, 1);
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, $d["view_title"]. " (" . $d["f_start"]." - ".$d["f_end"].")", 0, 1);
+- $pdf->CELL(120, 5, _DATASOURCE ." ".$d["ds_name"], 0, 1);
+- }else{
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, _DATASOURCE ." ".$d["ds_name"], 0, 1);
+- }
- $img = saveImage($d['rrd_opts']);
- $Y = $pdf->GetY();
- $cell_height = ($img['height'] * 0.23);
@@ -96,10 +100,16 @@
- $pdf->AddPage();
- if($use_bg){$pdf->useTemplate($tplIdx);}
- }
-- $pdf->SetFont('Arial', '', 10);
-- $pdf->CELL(120, 7, $d["hostname"]." / ".$d["servicedesc"] , 0, 1);
-- $pdf->SetFont('Arial', '', 8);
-- $pdf->CELL(120, 5, $d["f_start"]." - ".$d["f_end"], 0, 1);
+- if($d['source'] == 1){
+- $pdf->SetFont('Arial', '', 10);
+- $pdf->CELL(120, 5, $d["n_hostname"]." / ".$d["n_servicedesc"] , 0, 1);
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, $d["view_title"]. " (" . $d["f_start"]." - ".$d["f_end"].")", 0, 1);
+- $pdf->CELL(120, 5, _DATASOURCE ." ".$d["ds_name"], 0, 1);
+- }else{
+- $pdf->SetFont('Arial', '', 8);
+- $pdf->CELL(120, 5, _DATASOURCE ." ".$d["ds_name"], 0, 1);
+- }
-
- $img = saveImage($d['rrd_opts']);
- $Y = $pdf->GetY();
@@ -110,21 +120,11 @@
- unlink($img['name']);
- }
- }
--
-- $pdf->Output();
-+ print "<html>\n";
-+ print "<head>\n";
-+ print "<title>Failed</title>\n";
-+ print "</head>\n";
-+ print "<body>\n";
-+ print "<h1>Failed</h1>\n";
-+ print "</body>\n";
-+ print "<html>\n";
-+ exit(0);
+- $pdf->Output("pnp4nagios.pdf","I");
+ exit;
}
- function doStrip($string) {
-@@ -1173,23 +1074,6 @@
+@@ -1350,23 +1233,6 @@
}
function doPDFIcon($type){
@@ -139,7 +139,7 @@
-
- switch($type){
- case "PAGE":
-- print "<a href=\"index.php?page=$page&display=$display&view=$view&do=pdf\"><img src=\"images/pdf.png\" HEIGHT=\"32px\" WIDTH=\"32px\" title=\"Display PDF\" ></a>\n";
+- print "<a href=\"index.php?page=$page&display=$display&view=$view&end=$end&start=$start&do=pdf\"><img src=\"images/pdf.png\" HEIGHT=\"32px\" WIDTH=\"32px\" title=\"Display PDF\" ></a>\n";
- break;
- default:
- print "<a href=\"index.php?host=$hostname&srv=$servicedesc&display=$display&view=$view&source=$source&end=$end&start=$start&do=pdf\"><img src=\"images/pdf.png\" HEIGHT=\"32px\" WIDTH=\"32px\" title=\"Display PDF\" ></a>\n";
diff --git a/net-mgmt/pnp/files/patch-sample-config::Makefile.in b/net-mgmt/pnp/files/patch-sample-config::Makefile.in
index 18ca7b983306..9d15ac804bd6 100644
--- a/net-mgmt/pnp/files/patch-sample-config::Makefile.in
+++ b/net-mgmt/pnp/files/patch-sample-config::Makefile.in
@@ -1,53 +1,29 @@
---- sample-config/Makefile.in.orig 2008-06-18 12:02:38.000000000 +0400
-+++ sample-config/Makefile.in 2008-08-18 18:50:24.000000000 +0400
-@@ -13,6 +13,9 @@
-
- CP=@CP@
-
-+DIRMODE=755
-+FILEMODE=644
-+
- all html:
-
- clean:
-@@ -28,26 +31,22 @@
+--- sample-config/Makefile.in.orig 2008-10-11 18:13:17.000000000 +0400
++++ sample-config/Makefile.in 2008-12-24 17:33:32.000000000 +0300
+@@ -27,23 +27,19 @@
devclean: distclean
install:
-- -rm -f $(HTMLDIR)/conf/config.php
+- -rm -f $(DESTDIR)$(HTMLDIR)/conf/config.php
-
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)/config.php-sample
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(CFGDIR)/background.pdf-sample
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/check_commands
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/pages
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/pnp4nagios_release $(DESTDIR)$(SYSCONFDIR)
+- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)
+- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(SYSCONFDIR)
++ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)/config.php-sample
++ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/background.pdf $(DESTDIR)$(SYSCONFDIR)/background.pdf-sample
install-config:
- -rm -f $(DESTDIR)$(HTMLDIR)/conf/config.php
-
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/check_commands
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(CFGDIR)/pages
-
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/process_perfdata.cfg-sample $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/rra.cfg-sample $(DESTDIR)$(CFGDIR)
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/check_commands/check_nwstat.cfg-sample $(DESTDIR)$(CFGDIR)/check_commands
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/pages/web_traffic.cfg-sample $(DESTDIR)$(CFGDIR)/pages
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(CFGDIR)/config.php-sample
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/process_perfdata.cfg-sample $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/rra.cfg-sample $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/check_commands/check_nwstat.cfg-sample $(DESTDIR)$(CFGDIR)/check_commands
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/pages/web_traffic.cfg-sample $(DESTDIR)$(CFGDIR)/pages
-
-- $(INSTALL) -m 664 $(INSTALL_OPTS) pnp/npcd.cfg-sample $(DESTDIR)$(CFGDIR)
-+ $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) pnp/npcd.cfg-sample $(DESTDIR)$(CFGDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/check_commands
+ $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(SYSCONFDIR)/pages
+- $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)
++ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/config.php $(DESTDIR)$(SYSCONFDIR)/config.php-sample
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/process_perfdata.cfg-sample $(DESTDIR)$(SYSCONFDIR)
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/rra.cfg-sample $(DESTDIR)$(SYSCONFDIR)
+ $(INSTALL) -m 644 $(INSTALL_OPTS) pnp/check_commands/check_nwstat.cfg-sample $(DESTDIR)$(SYSCONFDIR)/check_commands
diff --git a/net-mgmt/pnp/files/patch-scripts::Makefile.in b/net-mgmt/pnp/files/patch-scripts::Makefile.in
index c148a5969ed4..5ddf46396dad 100644
--- a/net-mgmt/pnp/files/patch-scripts::Makefile.in
+++ b/net-mgmt/pnp/files/patch-scripts::Makefile.in
@@ -1,34 +1,23 @@
---- scripts/Makefile.in.orig 2008-06-18 12:02:39.000000000 +0400
-+++ scripts/Makefile.in 2008-08-18 18:53:43.000000000 +0400
-@@ -13,6 +13,8 @@
- PERFDATADIR=@PERFDATA_DIR@
- DATAROOTDIR=@datarootdir@
-
-+BINMODE=755
-+
- CP=@CP@
-
- all html:
-@@ -26,19 +28,15 @@
+--- scripts/Makefile.in.orig 2008-12-24 01:11:40.000000000 +0300
++++ scripts/Makefile.in 2008-12-24 01:12:25.000000000 +0300
+@@ -25,7 +25,6 @@
devclean: distclean
install-init:
-- $(INSTALL) -m 755 -d $(INIT_OPTS) $(DESTDIR)$(INIT_DIR)
-- $(INSTALL) -m 755 $(INIT_OPTS) rc.npcd $(DESTDIR)$(INIT_DIR)/npcd
-+ $(INSTALL) -m $(BINMODE) $(INIT_OPTS) rc.npcd $(DESTDIR)$(INIT_DIR)/npcd
+- $(INSTALL) -m 755 $(INIT_OPTS) -d $(DESTDIR)$(INIT_DIR)
+ $(INSTALL) -m 755 $(INIT_OPTS) rc.npcd $(DESTDIR)$(INIT_DIR)/npcd
install-processperfdata:
-- $(INSTALL) -m 774 $(INSTALL_OPTS) process_perfdata.pl $(DESTDIR)$(LIBEXECDIR)
-+ $(INSTALL) -m $(BINMODE) $(INSTALL_OPTS) process_perfdata.pl $(DESTDIR)$(LIBEXECDIR)
+@@ -35,12 +34,9 @@
+ $(INSTALL) -m 755 $(INSTALL_OPTS) check_pnp_rrds.pl $(DESTDIR)$(LIBEXECDIR)
install-net2pnp:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
-- $(INSTALL) -m 774 $(INSTALL_OPTS) net2pnp.pl $(DESTDIR)$(BINDIR)
-+ $(INSTALL) -m $(BINMODE) $(INSTALL_OPTS) net2pnp.pl $(DESTDIR)$(BINDIR)
+- $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
+ $(INSTALL) -m 755 $(INSTALL_OPTS) net2pnp.pl $(DESTDIR)$(BINDIR)
install:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(PERFDATADIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
+- $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(PERFDATADIR)
+- $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(LIBEXECDIR)
$(MAKE) install-processperfdata
-
-
+ $(MAKE) install-plugins
+
diff --git a/net-mgmt/pnp/files/patch-share::Makefile.in b/net-mgmt/pnp/files/patch-share::Makefile.in
deleted file mode 100644
index e73cc4e5e271..000000000000
--- a/net-mgmt/pnp/files/patch-share::Makefile.in
+++ /dev/null
@@ -1,68 +0,0 @@
---- share/Makefile.in.orig 2008-06-18 12:02:41.000000000 +0400
-+++ share/Makefile.in 2008-08-18 18:55:45.000000000 +0400
-@@ -11,6 +11,9 @@
-
- CP=@CP@
-
-+DIRMODE=755
-+FILEMODE=644
-+
- all html:
-
- clean:
-@@ -24,38 +27,38 @@
- devclean: distclean
-
- install:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/font
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/font/makefont
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/js
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/lang/
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/templates/
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/templates.dist/
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/images
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/font
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/font/makefont
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/include/js
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/lang/
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/templates/
-+ $(INSTALL) -m $(DIRMODE) $(INSTALL_OPTS) -d $(DESTDIR)$(HTMLDIR)/templates.dist/
-
- for file in pnp/*.php; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR); done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR); done
-
- for file in pnp/templates.dist/*.php; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/templates.dist; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/templates.dist; done
-
- for file in pnp/lang/*.php; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/lang; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/lang; done
-
- for file in pnp/images/*; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/images; done
-
- for file in pnp/include/*.*; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include; done
-
- for file in pnp/include/js/*; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/js; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/js; done
-
- for file in pnp/include/font/*.php; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/font; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/font; done
-
- for file in pnp/include/font/makefont/*; \
-- do $(INSTALL) -m 664 $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/font/makefont; done
-+ do $(INSTALL) -m $(FILEMODE) $(INSTALL_OPTS) $$file $(DESTDIR)$(HTMLDIR)/include/font/makefont; done
-
-
diff --git a/net-mgmt/pnp/files/patch-src::Makefile.in b/net-mgmt/pnp/files/patch-src::Makefile.in
index 9b5866e4474b..315868353d14 100644
--- a/net-mgmt/pnp/files/patch-src::Makefile.in
+++ b/net-mgmt/pnp/files/patch-src::Makefile.in
@@ -1,12 +1,11 @@
---- src/Makefile.in.orig 2008-06-18 12:02:39.000000000 +0400
-+++ src/Makefile.in 2008-08-18 18:56:20.000000000 +0400
-@@ -93,8 +93,7 @@
+--- src/Makefile.in.orig 2008-12-24 01:12:54.000000000 +0300
++++ src/Makefile.in 2008-12-24 01:13:31.000000000 +0300
+@@ -88,8 +88,6 @@
$(MAKE) install-basic
install-basic:
-- $(INSTALL) -m 775 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
-- $(INSTALL) -m 774 $(INSTALL_OPTS) @npcd_name@ $(DESTDIR)$(BINDIR)
-+ $(INSTALL) -m 755 $(INSTALL_OPTS) @npcd_name@ $(DESTDIR)$(BINDIR)
+- $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(BINDIR)
+- $(INSTALL) -m 755 $(INSTALL_OPTS) -d $(DESTDIR)$(PERFDATA_SPOOL_DIR)
+ $(INSTALL) -m 754 $(INSTALL_OPTS) @npcd_name@ $(DESTDIR)$(BINDIR)
strip-post-install:
- $(STRIP) $(DESTDIR)$(BINDIR)/@npcd_name@
diff --git a/net-mgmt/pnp/files/pkg-message.in b/net-mgmt/pnp/files/pkg-message.in
index 7b89f0a92f42..6603c575bcc9 100644
--- a/net-mgmt/pnp/files/pkg-message.in
+++ b/net-mgmt/pnp/files/pkg-message.in
@@ -48,6 +48,11 @@ configuration for the PNP area:
Deny from all
</Directory>
+Please, note that user who runs Apache processes should be able to
+read PNP RRD spool files from
+ %%PNP_RRDS%%
+so you should tune path permissions accordingly. Probably one could
+start from adding Apache user to the group '%%NAGIOSGROUP%%'.
Remember to restart NPCD service after upgrade if you're using
'bulk' mode with NPCD.
diff --git a/net-mgmt/pnp/pkg-plist b/net-mgmt/pnp/pkg-plist
index 0e3cc8956a26..47772725bdd8 100644
--- a/net-mgmt/pnp/pkg-plist
+++ b/net-mgmt/pnp/pkg-plist
@@ -1,4 +1,5 @@
bin/npcd
+etc/pnp/pnp4nagios_release
etc/pnp/config.php-sample
etc/pnp/background.pdf-sample
etc/pnp/check_commands/check_nwstat.cfg-sample
@@ -7,6 +8,7 @@ etc/pnp/process_perfdata.cfg-sample
etc/pnp/rra.cfg-sample
etc/pnp/npcd.cfg-sample
libexec/process_perfdata.pl
+libexec/check_pnp_rrds.pl
%%WWWDIR%%/images/ack.png
%%WWWDIR%%/images/calendar.png
%%WWWDIR%%/images/critical.png
@@ -27,6 +29,7 @@ libexec/process_perfdata.pl
%%WWWDIR%%/images/warning.png
%%WWWDIR%%/images/xml.png
%%WWWDIR%%/images/zoom.png
+%%WWWDIR%%/include/tpl_function.inc.php
%%WWWDIR%%/include/font/makefont/cp1250.map
%%WWWDIR%%/include/font/makefont/cp1251.map
%%WWWDIR%%/include/font/makefont/cp1252.map
@@ -112,6 +115,13 @@ libexec/process_perfdata.pl
%%WWWDIR%%/templates.dist/check_nwstat_LOAD15.php
%%WWWDIR%%/templates.dist/check_nwstat_LOAD5.php
%%WWWDIR%%/templates.dist/check_nwstat_ofiles.php
+%%WWWDIR%%/templates.dist/check_oracle_connection-time.php
+%%WWWDIR%%/templates.dist/check_oracle_health_connection-time.php
+%%WWWDIR%%/templates.dist/check_oracle_health_pga-in-memory-sort-ratio.php
+%%WWWDIR%%/templates.dist/check_oracle_health_redo-io-traffic.php
+%%WWWDIR%%/templates.dist/check_oracle_health_switch-interval.php
+%%WWWDIR%%/templates.dist/check_oracle_health_tablespace-usage.php
+%%WWWDIR%%/templates.dist/check_pnp_rrds.php
%%WWWDIR%%/templates.dist/check_smtp.php
%%WWWDIR%%/templates.dist/check_snmp_int-bits.php
%%WWWDIR%%/templates.dist/check_snmp_int.php
@@ -123,7 +133,6 @@ libexec/process_perfdata.pl
%%WWWDIR%%/ajax.php
%%WWWDIR%%/index.php
%%WWWDIR%%/zoom.php
-
@dirrmtry %%WWWDIR%%/templates.dist
@dirrmtry %%WWWDIR%%/templates
@dirrmtry %%WWWDIR%%/lang