aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-adal
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-09-30 10:50:14 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-09-30 10:50:14 +0000
commit5573592635c52fc1eaeea227cae444ee50b36015 (patch)
treed116479565e58bb1f3d3e8c4244eb20847c58f96 /net-mgmt/py-adal
parent54bca0608f04fc8d45b9e83d8de4c6dad7254896 (diff)
downloadports-5573592635c52fc1eaeea227cae444ee50b36015.tar.gz
ports-5573592635c52fc1eaeea227cae444ee50b36015.zip
Notes
Diffstat (limited to 'net-mgmt/py-adal')
-rw-r--r--net-mgmt/py-adal/Makefile23
-rw-r--r--net-mgmt/py-adal/distinfo3
-rw-r--r--net-mgmt/py-adal/pkg-descr5
3 files changed, 31 insertions, 0 deletions
diff --git a/net-mgmt/py-adal/Makefile b/net-mgmt/py-adal/Makefile
new file mode 100644
index 000000000000..94bd6ebc6c2b
--- /dev/null
+++ b/net-mgmt/py-adal/Makefile
@@ -0,0 +1,23 @@
+# Created by: Johannes Jost Meixner <johannes@perceivon.net>
+# $FreeBSD$
+
+PORTNAME= adal
+PORTVERSION= 0.4.7
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= johannes@perceivon.net
+COMMENT= Authentication ot Azure Active Directory for python apps
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=1.5:devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}pyjwt>=1.0.0:www/py-pyjwt \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-adal/distinfo b/net-mgmt/py-adal/distinfo
new file mode 100644
index 000000000000..b920748af86d
--- /dev/null
+++ b/net-mgmt/py-adal/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1505103027
+SHA256 (adal-0.4.7.tar.gz) = 114046ac85d0054791c21b00922f26286822bc6f2ba3716db42e7e57f762ef20
+SIZE (adal-0.4.7.tar.gz) = 28161
diff --git a/net-mgmt/py-adal/pkg-descr b/net-mgmt/py-adal/pkg-descr
new file mode 100644
index 000000000000..c0506f323e46
--- /dev/null
+++ b/net-mgmt/py-adal/pkg-descr
@@ -0,0 +1,5 @@
+The ADAL for Python library makes it easy for python application to
+authenticate to Azure Active Directory (AAD) in order to access AAD protected
+web resources.
+
+WWW: https://pypi.python.org/pypi/adal