aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-ciscoconfparse
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-03-25 04:56:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-03-25 04:56:13 +0000
commit5eb02106b74fb6a833241a8b319c508e30e64a7b (patch)
tree3ff56e166a98059ad8279a6b277c1768ef3d789e /net-mgmt/py-ciscoconfparse
parentacc42c7de4f508ba01d2ae890a122ef499d80e5f (diff)
downloadports-5eb02106b74fb6a833241a8b319c508e30e64a7b.tar.gz
ports-5eb02106b74fb6a833241a8b319c508e30e64a7b.zip
New port: net-mgmt/py-ciscoconfparse: Parse, audit, query, build and modify Cisco IOS-style configurations
PR: 226901 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=465496
Diffstat (limited to 'net-mgmt/py-ciscoconfparse')
-rw-r--r--net-mgmt/py-ciscoconfparse/Makefile24
-rw-r--r--net-mgmt/py-ciscoconfparse/distinfo3
-rw-r--r--net-mgmt/py-ciscoconfparse/pkg-descr24
3 files changed, 51 insertions, 0 deletions
diff --git a/net-mgmt/py-ciscoconfparse/Makefile b/net-mgmt/py-ciscoconfparse/Makefile
new file mode 100644
index 000000000000..508fcd5778be
--- /dev/null
+++ b/net-mgmt/py-ciscoconfparse/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= ciscoconfparse
+DISTVERSION= 1.3.10
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Parse, audit, query, build and modify Cisco IOS-style configurations
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ipaddr>=2.1.11:devel/py-ipaddr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}passlib>0:security/py-passlib@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-ciscoconfparse/distinfo b/net-mgmt/py-ciscoconfparse/distinfo
new file mode 100644
index 000000000000..d2b15ee7e910
--- /dev/null
+++ b/net-mgmt/py-ciscoconfparse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1521923586
+SHA256 (ciscoconfparse-1.3.10.tar.gz) = e4b69af27501b2d16e1deb55661733113b083999bff68ed836b38acd10d504fe
+SIZE (ciscoconfparse-1.3.10.tar.gz) = 91396
diff --git a/net-mgmt/py-ciscoconfparse/pkg-descr b/net-mgmt/py-ciscoconfparse/pkg-descr
new file mode 100644
index 000000000000..0a5f2397e2a7
--- /dev/null
+++ b/net-mgmt/py-ciscoconfparse/pkg-descr
@@ -0,0 +1,24 @@
+ciscoconfparse parses through Cisco IOS-style configurations. It can:
+
+- Audit existing router / switch / firewall / wlc configurations
+- Retrieve portions of the configuration
+- Modify existing configurations
+- Build new configurations
+
+It can also parse other vendor configurations:
+
+- Juniper Networks JunOS
+- F5 Networks configurations
+- Palo Alto Networks Firewall configurations
+
+The module handles anything that has a Cisco IOS style of configuration, e.g.:
+
+- Cisco IOS/IOS-XE/IOS-XR/Aironet/ASA/CatOS/Nexus
+- Arista EOS
+- Brocade
+- HP Switches
+- Force 10 Switches
+- Dell PowerConnect Switches
+- Enterasys, Extreme Networks, Screenos
+
+WWW: http://www.pennington.net/py/ciscoconfparse/