aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-dnsdiag
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /net-mgmt/py-dnsdiag
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'net-mgmt/py-dnsdiag')
-rw-r--r--net-mgmt/py-dnsdiag/Makefile21
-rw-r--r--net-mgmt/py-dnsdiag/distinfo3
-rw-r--r--net-mgmt/py-dnsdiag/pkg-descr7
3 files changed, 31 insertions, 0 deletions
diff --git a/net-mgmt/py-dnsdiag/Makefile b/net-mgmt/py-dnsdiag/Makefile
new file mode 100644
index 000000000000..228d0c3e22bd
--- /dev/null
+++ b/net-mgmt/py-dnsdiag/Makefile
@@ -0,0 +1,21 @@
+# Created by: Babak Farrokhi <farrokhi@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dnsdiag
+PORTVERSION= 1.6.3
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= farrokhi@FreeBSD.org
+COMMENT= DNS Diagnostics and measurement tools (ping, traceroute)
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.15.0:dns/py-dnspython@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cymruwhois>=1.6:net/py-cymruwhois@${FLAVOR}
+
+USES= python:3.3+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-dnsdiag/distinfo b/net-mgmt/py-dnsdiag/distinfo
new file mode 100644
index 000000000000..1567f90d7968
--- /dev/null
+++ b/net-mgmt/py-dnsdiag/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1493793506
+SHA256 (dnsdiag-1.6.3.tar.gz) = dad8a74643b2d224e1b1ac7b7745e68071164bfa9530d97328d4d45a7f0c5fad
+SIZE (dnsdiag-1.6.3.tar.gz) = 11676
diff --git a/net-mgmt/py-dnsdiag/pkg-descr b/net-mgmt/py-dnsdiag/pkg-descr
new file mode 100644
index 000000000000..d5a60c2101f0
--- /dev/null
+++ b/net-mgmt/py-dnsdiag/pkg-descr
@@ -0,0 +1,7 @@
+DNSDiag provides a handful of tools to measure and diagnose your DNS
+performance and integrity. Using dnsping, dnstraceroute and dnseval
+tools you can measure your DNS response quality from delay and loss
+perspective as well as tracing the path your DNS query takes to get
+to DNS server.
+
+WWW: https://github.com/farrokhi/dnsdiag