aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-pysmi
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2017-02-21 14:32:23 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2017-02-21 14:32:23 +0000
commit5f41c35e5b45dd684a39d2036d6a8a552c50fa95 (patch)
tree3054728f6835c2adc327b42442d91a387cfa7f1d /net-mgmt/py-pysmi
parent39bbc47899f66b43c9f8dc2d9e290ecfe48a442b (diff)
downloadports-5f41c35e5b45dd684a39d2036d6a8a552c50fa95.tar.gz
ports-5f41c35e5b45dd684a39d2036d6a8a552c50fa95.zip
Notes
Diffstat (limited to 'net-mgmt/py-pysmi')
-rw-r--r--net-mgmt/py-pysmi/Makefile5
-rw-r--r--net-mgmt/py-pysmi/distinfo5
-rw-r--r--net-mgmt/py-pysmi/files/patch-setup.py21
-rw-r--r--net-mgmt/py-pysmi/files/tests__init__.py2
4 files changed, 18 insertions, 15 deletions
diff --git a/net-mgmt/py-pysmi/Makefile b/net-mgmt/py-pysmi/Makefile
index 85f5fb5b0d66..ee877c27a004 100644
--- a/net-mgmt/py-pysmi/Makefile
+++ b/net-mgmt/py-pysmi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pysmi
-PORTVERSION= 0.0.6
+PORTVERSION= 0.0.7
CATEGORIES= net-mgmt python
MASTER_SITES= CHEESESHOP \
SF/pysmi/pysmi/${PORTVERSION}
@@ -31,10 +31,11 @@ post-patch:
${CP} ${FILESDIR}/tests__init__.py ${WRKSRC}/tests/__init__.py
${MV} ${WRKSRC}/tests ${WRKSRC}/${PORTNAME}
-post-install:
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${BASEDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
diff --git a/net-mgmt/py-pysmi/distinfo b/net-mgmt/py-pysmi/distinfo
index 39c6059763a0..6af7e675c113 100644
--- a/net-mgmt/py-pysmi/distinfo
+++ b/net-mgmt/py-pysmi/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pysmi-0.0.6.tar.gz) = f04641fd88239ad6708aad9f8b24bc1606b225346bb6a7bb7253cc2103a7d9a0
-SIZE (pysmi-0.0.6.tar.gz) = 55917
+TIMESTAMP = 1487436747
+SHA256 (pysmi-0.0.7.tar.gz) = 999f6db9e16f4cc2804263d825553dbdd188c4313ca5c1244eeb20a3c4a60116
+SIZE (pysmi-0.0.7.tar.gz) = 56233
diff --git a/net-mgmt/py-pysmi/files/patch-setup.py b/net-mgmt/py-pysmi/files/patch-setup.py
index 48643afcfe3a..9dd5e27e6caa 100644
--- a/net-mgmt/py-pysmi/files/patch-setup.py
+++ b/net-mgmt/py-pysmi/files/patch-setup.py
@@ -1,12 +1,13 @@
---- setup.py.orig 2015-11-07 19:23:39 UTC
+--- setup.py.orig 2016-02-13 18:11:15 UTC
+++ setup.py
-@@ -80,7 +80,8 @@ params.update( {
- 'pysmi.parser',
- 'pysmi.codegen',
- 'pysmi.borrower',
-- 'pysmi.writer' ],
-+ 'pysmi.writer',
-+ 'pysmi.tests' ],
- 'scripts': [ os.path.join('scripts','mibdump.py') ]
- } )
+@@ -83,7 +83,9 @@ params.update({
+ 'pysmi.parser',
+ 'pysmi.codegen',
+ 'pysmi.borrower',
+- 'pysmi.writer'],
++ 'pysmi.writer',
++ 'pysmi.tests',
++ ],
+ 'scripts': [os.path.join('scripts', 'mibdump.py')]
+ })
diff --git a/net-mgmt/py-pysmi/files/tests__init__.py b/net-mgmt/py-pysmi/files/tests__init__.py
index b6f4cc125c2a..598f43930ba6 100644
--- a/net-mgmt/py-pysmi/files/tests__init__.py
+++ b/net-mgmt/py-pysmi/files/tests__init__.py
@@ -1,7 +1,7 @@
from unittest import SkipTest, TestSuite
-def load_tests(loader, tests, pattern):
+def load_tests(*args, **kwargs):
import suite
return suite.suite