aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-snmp4-mibs/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-04-17 11:27:30 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-04-17 11:27:30 +0000
commit92c08628b62ebc16e128a126143c0020b7b61079 (patch)
treefd5301a9dc7e276fd55a6f7cf19e246c04116d64 /net-mgmt/py-snmp4-mibs/Makefile
parentea2d15b3ab8b87f5c03863f92f57fbc5c2116b9b (diff)
Notes
Diffstat (limited to 'net-mgmt/py-snmp4-mibs/Makefile')
-rw-r--r--net-mgmt/py-snmp4-mibs/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-mgmt/py-snmp4-mibs/Makefile b/net-mgmt/py-snmp4-mibs/Makefile
new file mode 100644
index 000000000000..f55014783e58
--- /dev/null
+++ b/net-mgmt/py-snmp4-mibs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: py-pysnmp4-mibs
+# Date created: Sun Apr 9 23:07:14 CDT 2006
+# Whom: Martin Jackson <mhjacks@swbell.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snmp4-mibs
+PORTVERSION= 0.0.3a
+CATEGORIES= net-mgmt python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pysnmp
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pysnmp-mibs-${PORTVERSION}
+
+MAINTAINER= mhjacks@swbell.net
+COMMENT= Additional python MIB files for pysnmp4 and friends
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pyasn1/__init__.py:${PORTSDIR}/devel/py-asn1
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+PORTDOCS= CHANGES \
+ LICENSE \
+ README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>