aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-yapsnmp/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-01-14 15:49:47 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-01-14 15:49:47 +0000
commit7e28f3f5c4f5ec2d0fef113e580138c2cb61731f (patch)
treeec25e9839f850362bb86fe1ed98b41eac58ea1cc /net-mgmt/py-yapsnmp/Makefile
parent158a360cc9836816e73af92404c2698611d2a448 (diff)
Notes
Diffstat (limited to 'net-mgmt/py-yapsnmp/Makefile')
-rw-r--r--net-mgmt/py-yapsnmp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-mgmt/py-yapsnmp/Makefile b/net-mgmt/py-yapsnmp/Makefile
new file mode 100644
index 000000000000..0d79437ed899
--- /dev/null
+++ b/net-mgmt/py-yapsnmp/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-yapsnmp
+# Date created: 2005-01-07
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= yapsnmp
+PORTVERSION= 0.7.8
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= yapsnmp
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= arved@FreeBSD.org
+COMMENT= Python SNMP module based on net-snmp
+
+LIB_DEPENDS= netsnmp.7:${PORTSDIR}/net-mgmt/net-snmp
+
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,-lsnmp,-lnetsnmp," \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>